X
Tap here to go to the mobile version of the site.

Support Forum

How do I permanently disable e10s multiprocessing?

Posted

I'm running the latest Firefox on a Windows 7 laptop with only a Dual Core processor & only 4 GB of RAM. The e10s multiprocessing is hogging way too much memory & is slowing Firefox down. I've been told to open up about:config & go to browser.tabs.remote.autostart & set any settings there to false. I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again. I need the multiprocessing to be permanently disabled.

I'm running the latest Firefox on a Windows 7 laptop with only a Dual Core processor & only 4 GB of RAM. The e10s multiprocessing is hogging way too much memory & is slowing Firefox down. I've been told to open up about:config & go to browser.tabs.remote.autostart & set any settings there to false. I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again. I need the multiprocessing to be permanently disabled.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

FredMcD
  • Top 10 Contributor
4351 solutions 61154 answers

Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar.

Question owner

Re-read my comment again! Pay attention to the 3rd sentence & onward.

Re-read my comment again! Pay attention to the 3rd sentence & onward.
Shadow110 1072 solutions 14836 answers

Animebryan said

Re-read my comment again! Pay attention to the 3rd sentence & onward.

Politely drawing attention to that comment would work better for us all. Please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please let us know if this solved your issue or if need further assistance.

''Animebryan [[#answer-1102654|said]]'' <blockquote> Re-read my comment again! Pay attention to the 3rd sentence & onward. </blockquote> Politely drawing attention to that comment would work better for us all. Please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST. *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles then *https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...: *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If is your Profile : *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Note: Any customization will revert back to default, you will also need to reinstall Extensions. Please let us know if this solved your issue or if need further assistance.
FredMcD
  • Top 10 Contributor
4351 solutions 61154 answers

Animebryan said

I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again

Sorry, I missed this.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

''Animebryan [[#question-1214371|said]]'' <blockquote> I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again </blockquote> Sorry, I missed this. https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
Happy112 561 solutions 5694 answers

Animebryan said

I've been told to open up about:config & go to browser.tabs.remote.autostart & set any settings there to false. I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again.

Just to make sure :

After you changed the value, did you then close and restart Firefox, in order for the change to take effect  ?

''Animebryan [[#question-1214371|said]]'' <blockquote> I've been told to open up about:config & go to browser.tabs.remote.autostart & set any settings there to false. I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again. </blockquote> Just to make sure : After you changed the value, did you then close and restart Firefox, in order for the change to take effect ?
Happy112 561 solutions 5694 answers

Would you please take a look at this article :

Firefox uses too much memory (RAM) - How to fix

Would you please take a look at this article : [https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram Firefox uses too much memory (RAM) - How to fix]
Murphy 20 solutions 264 answers

Is there a particular reason why you're using an older Firefox version  ?

Updating to the latest version (59.0.2) might be a good idea .....

Is there a particular reason why you're using an older Firefox version ? Updating to the latest version (59.0.2) might be a good idea .....

Modified by Murphy

Question owner

Pkshadow said

Animebryan said
Re-read my comment again! Pay attention to the 3rd sentence & onward.

Politely drawing attention to that comment would work better for us all. Please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please let us know if this solved your issue or if need further assistance.

What the heck are you even talking about? Why even bring up things like refreshing, installing & uninstalling? I'm not going to reinstall Firefox & have to deal with re-downloading my add-ons again. I also don't like the idea of deleting my cache or cookies if that causes Firefox to forget login passwords & stuff.

FredMcD said

Animebryan said
I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again

Sorry, I missed this.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

I'm not sure what Advanced System Care is but I don't recall ever downloading it or using it, so I don't think that's the issue.

Happy112 said

Animebryan said
I've been told to open up about:config & go to browser.tabs.remote.autostart & set any settings there to false. I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again.

Just to make sure :

After you changed the value, did you then close and restart Firefox, in order for the change to take effect  ?

Yes. But whenever I shutdown my computer & bring it to my local library & get on the internet again, the settings sometimes resets. It didn't do it this time but it could happen again.

Happy112 said

Would you please take a look at this article : Firefox uses too much memory (RAM) - How to fix

Why? That article has nothing to do with my problem.

Murphy said

Is there a particular reason why you're using an older Firefox version  ? Updating to the latest version (59.0.2) might be a good idea .....

When did I ever mention that I'm using an older version of Firefox? Besides, upgrading would have the opposite effect. The best solution would be to downgrade it back to the latest version before the e10s multiprocessing was implemented.

''Pkshadow [[#answer-1102675|said]]'' <blockquote> ''Animebryan [[#answer-1102654|said]]'' <blockquote> Re-read my comment again! Pay attention to the 3rd sentence & onward. </blockquote> Politely drawing attention to that comment would work better for us all. Please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST. *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles then *https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...: *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If is your Profile : *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Note: Any customization will revert back to default, you will also need to reinstall Extensions. Please let us know if this solved your issue or if need further assistance. </blockquote> What the heck are you even talking about? Why even bring up things like refreshing, installing & uninstalling? I'm not going to reinstall Firefox & have to deal with re-downloading my add-ons again. I also don't like the idea of deleting my cache or cookies if that causes Firefox to forget login passwords & stuff. ''FredMcD [[#answer-1102712|said]]'' <blockquote> ''Animebryan [[#question-1214371|said]]'' <blockquote> I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again </blockquote> Sorry, I missed this. https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software. </blockquote> I'm not sure what Advanced System Care is but I don't recall ever downloading it or using it, so I don't think that's the issue. ''Happy112 [[#answer-1102719|said]]'' <blockquote> ''Animebryan [[#question-1214371|said]]'' <blockquote> I've been told to open up about:config & go to browser.tabs.remote.autostart & set any settings there to false. I've been doing this but it keeps resetting itself between internet sessions or when my laptop powers off & on again. </blockquote> Just to make sure : After you changed the value, did you then close and restart Firefox, in order for the change to take effect ? </blockquote> Yes. But whenever I shutdown my computer & bring it to my local library & get on the internet again, the settings sometimes resets. It didn't do it this time but it could happen again. ''Happy112 [[#answer-1102722|said]]'' <blockquote> Would you please take a look at this article : [https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram Firefox uses too much memory (RAM) - How to fix] </blockquote> Why? That article has nothing to do with my problem. ''Murphy [[#answer-1102723|said]]'' <blockquote> Is there a particular reason why you're using an older Firefox version ? Updating to the latest version (59.0.2) might be a good idea ..... </blockquote> When did I ever mention that I'm using an older version of Firefox? Besides, upgrading would have the opposite effect. The best solution would be to downgrade it back to the latest version before the e10s multiprocessing was implemented.

Modified by Animebryan

Murphy 20 solutions 264 answers

You asked :

When did I ever mention that I'm using an older version of Firefox? "

You didn't - your system details (to the right of your original post) show that you're using Firefox version 58.0.

You asked : '' When did I ever mention that I'm using an older version of Firefox? "'' You didn't - your system details (to the right of your original post) show that you're using Firefox version 58.0.
Happy112 561 solutions 5694 answers

Quoting you :

" Happy112 said

Would you please take a look at this article : Firefox uses too much memory (RAM) - how to fix

Why? That article has nothing to do with my problem. "

Multi-process (e10s) might not be the (only) reason why you see a lot of RAM being used - that's why I asked you to take a look at that article. Only trying to help ......

Quoting you : '' " Happy112 said'' '' Would you please take a look at this article : '' [https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram Firefox uses too much memory (RAM) - how to fix] ''Why? That article has nothing to do with my problem. "'' Multi-process (e10s) might not be the (only) reason why you see a lot of RAM being used - that's why I asked you to take a look at that article. Only trying to help ......
cor-el
  • Top 10 Contributor
  • Moderator
17785 solutions 160874 answers

Instead of disabling multi-process you can first try to set the number of content processes to 1.

Multi-process gives some protection against problems. You can compare the memory usage with one content process and multi-process disabled, see about:memory for more detail.

Did you try to disable hardware acceleration in Firefox?

  • Options/Preferences -> General: Performance
    remove checkmark: [ ] "Use recommended performance settings"
    remove checkmark: [ ] "Use hardware acceleration when available"

Close and restart Firefox after modifying the setting to make the change effective.

Keep in mind that you need to start (use) as less programs at the same time if you are short on installed physical memory and also make sure your security software isn't interfering.

Instead of disabling multi-process you can first try to set the number of content processes to 1. *https://support.mozilla.org/en-US/kb/performance-settings Multi-process gives some protection against problems. You can compare the memory usage with one content process and multi-process disabled, see about:memory for more detail. Did you try to disable hardware acceleration in Firefox? *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" Close and restart Firefox after modifying the setting to make the change effective. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Keep in mind that you need to start (use) as less programs at the same time if you are short on installed physical memory and also make sure your security software isn't interfering.

Question owner

Murphy said

You asked : When did I ever mention that I'm using an older version of Firefox? " You didn't - your system details (to the right of your original post) show that you're using Firefox version 58.0.

I can't see it. Oh well. Its not like upgrading would help anyway.

Happy112 said

Quoting you : " Happy112 said Would you please take a look at this article : Firefox uses too much memory (RAM) - how to fix Why? That article has nothing to do with my problem. " Multi-process (e10s) might not be the (only) reason why you see a lot of RAM being used - that's why I asked you to take a look at that article. Only trying to help ......

The multiprocess is the only real issue that needs to be dealt with. I've actually looked through that recently & its all a bunch of mumbo-jumbo about disabling add-ons & hardware acceleration, etc. If I disable my add-ons then I can't use them, its so ridiculous.

cor-el said
Instead of disabling multi-process you can first try to set the number of content processes to 1. Multi-process gives some protection against problems. You can compare the memory usage with one content process and multi-process disabled, see about:memory for more detail. Did you try to disable hardware acceleration in Firefox?
  • Options/Preferences -> General: Performance
    remove checkmark: [ ] "Use recommended performance settings"
    remove checkmark: [ ] "Use hardware acceleration when available"
Close and restart Firefox after modifying the setting to make the change effective. Keep in mind that you need to start (use) as less programs at the same time if you are short on installed physical memory and also make sure your security software isn't interfering.

Multiprocess is for computers with multiple cores (3+). Mine is only a Dual Core so its counter-productive. I've disabled hardware acceleration but is that really a good idea? I couldn't change the number of processes because it was disabled. As for multiple programs being open, that's unavoidable considering that I need to multitask since my time on the internet is limited.

''Murphy [[#answer-1103360|said]]'' <blockquote> You asked : '' When did I ever mention that I'm using an older version of Firefox? "'' You didn't - your system details (to the right of your original post) show that you're using Firefox version 58.0. </blockquote> I can't see it. Oh well. Its not like upgrading would help anyway. ''Happy112 [[#answer-1103371|said]]'' <blockquote> Quoting you : '' " Happy112 said'' '' Would you please take a look at this article : '' [https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram Firefox uses too much memory (RAM) - how to fix] ''Why? That article has nothing to do with my problem. "'' Multi-process (e10s) might not be the (only) reason why you see a lot of RAM being used - that's why I asked you to take a look at that article. Only trying to help ...... </blockquote> The multiprocess is the only real issue that needs to be dealt with. I've actually looked through that recently & its all a bunch of mumbo-jumbo about disabling add-ons & hardware acceleration, etc. If I disable my add-ons then I can't use them, its so ridiculous. ''cor-el [[#answer-1103377|said]]'' <blockquote> Instead of disabling multi-process you can first try to set the number of content processes to 1. *https://support.mozilla.org/en-US/kb/performance-settings Multi-process gives some protection against problems. You can compare the memory usage with one content process and multi-process disabled, see about:memory for more detail. Did you try to disable hardware acceleration in Firefox? *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" Close and restart Firefox after modifying the setting to make the change effective. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Keep in mind that you need to start (use) as less programs at the same time if you are short on installed physical memory and also make sure your security software isn't interfering. </blockquote> Multiprocess is for computers with multiple cores (3+). Mine is only a Dual Core so its counter-productive. I've disabled hardware acceleration but is that really a good idea? I couldn't change the number of processes because it was disabled. As for multiple programs being open, that's unavoidable considering that I need to multitask since my time on the internet is limited.
Happy112 561 solutions 5694 answers

Your original question was and still is : how to permanently disable multi-process - you toggled the preferences on the 'about:config' page (and closed and restarted Firefox), but multi-process is still enabled.

FredMcD then gave you this link to look at :

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

And that's the only thing you haven't commented on .......


You say you can't see your system details :

To the right of your original post it says 'Question Details' - at the bottom you'll see 'System Details' (where it says 'Firefox 58.0')

Your original question was and still is : how to permanently disable multi-process - you toggled the preferences on the 'about:config' page (and closed and restarted Firefox), but multi-process is still enabled. FredMcD then gave you this link to look at : https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save And that's the only thing you haven't commented on ....... --------------------------------------------------------------------------------------------------------- You say you can't see your system details : To the right of your original post it says 'Question Details' - at the bottom you'll see 'System Details' (where it says 'Firefox 58.0')

Question owner

Happy112 said

Your original question was and still is : how to permanently disable multi-process - you toggled the preferences on the 'about:config' page (and closed and restarted Firefox), but multi-process is still enabled. FredMcD then gave you this link to look at : https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save And that's the only thing you haven't commented on .......

You say you can't see your system details :

To the right of your original post it says 'Question Details' - at the bottom you'll see 'System Details' (where it says 'Firefox 58.0')

OK, I see where it shows it now. As for that page, I have it saved onto my computer for future reference.

''Happy112 [[#answer-1103421|said]]'' <blockquote> Your original question was and still is : how to permanently disable multi-process - you toggled the preferences on the 'about:config' page (and closed and restarted Firefox), but multi-process is still enabled. FredMcD then gave you this link to look at : https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save And that's the only thing you haven't commented on ....... --------------------------------------------------------------------------------------------------------- You say you can't see your system details : To the right of your original post it says 'Question Details' - at the bottom you'll see 'System Details' (where it says 'Firefox 58.0') </blockquote> OK, I see where it shows it now. As for that page, I have it saved onto my computer for future reference.