Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why when I download, I cannot change the name of the file I am downloading. There is NO where to change the name, plus the DOWLOAD TO button is not highlighted

  • 9 replies
  • 2 have this problem
  • 6 views
  • Last reply by gcataline

more options

I am unable to change the name of anyone of the files I download, there is just NO spot to change the name. That was one of the reasons I quit FireFox years ago. I have to download the file and than when it is done, go into Explorer to change the name to what I want. Usually, it is just changing the date to be behind the name but there is NO where to do that??? Also, when I to download, the box of how I want the file TO OPEN or SAVE to a folder, the box is this "to do this always" is dulled out and will NOT allow me to check it and quit get bothering for everything I download. This was also a problem years ago and was another reason I quit. I got tired of NOT being allowed to name my file and reapeating over and over what I wanted to do with the file. After four years and many updates, it is still a problem with FireFox. Google will let me do both things, Opera will let me do them, even Brave will let me do the two things but NOT FireFox, why is that???? I have tried the new FireFox out several times in the last two weeks but it looks like I will be heading back to Google or Brave if I cannot find a fix for this. I do appreciate how you were able to get it to run faster and that is very good and also it was another reason why I dumped the old version. But out of three problems, you only addressed one??? Since I know other Browsers handle this without a problem, I am left to wonder why FireFox has not dealt with it. I used you older versions for many years until it got really slow and the download problems finally got too irritating. Thanks for listening to me and I hope there is finally a fix before I go back to Google!!

All Replies (9)

more options

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 59.0.2


Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.113

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Are you using any download managers, or just Firefox?

When the download manager window opens, you should be able to change the file name and/or the download folder.

Are you saying this is not the case?

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Yes, I updated it today and made NO difference. I can go in options and tell it what to do with downloads but When I actually download something, the box that says "do this automatically" is greyed out and it will not let me check it. So every time I download something, it asks me if I "want to open with a certain program" or lets me download it to my download file but I have to do it every single time. I had this problem before, with older versions. I did look through some download extensions today but I have NO idea of which one is any good and if they will let me fix that problem. Thanks

George

more options

Just using Fire Fox for downloads. It never even gives me a chance to change any file name. It goes into the box, as the next e-mail states and :says open with a certain program" or download to my download file. There is actually NOT anywhere that will let me change the name of the file. As I said in my original e-mail, it;s usually the date first, than the name, I prefer the name first and than the date, so to do that, I have to go into Windows Explorer (File Manager) and change the name than but it is just extra steps all the way around. Because I could NOT rename the File in the earlier version was one of the main reason I went to Google, which is starting to get on my nerves with trying to get me to not go to sites that I have used for years!! George

more options

Hi George, the normal sequence is:

(1) Firefox starts downloading the file to the Windows TEMP folder immediately

(2) If you have not previously instructed Firefox to open in a specific program or always save this type of file, Firefox shows the Open/Save dialog (for executables, you do not get an Open option)

(3) If you selected Save, then Firefox checks your download setting on the Options page (see attached screenshot) and if you set Firefox to ask you where to save downloads, it THEN should display a Save As window letting you (i) choose a folder and (ii) edit the file name

Are you not getting #3 or is your dialog only letting you select a folder, not change the name?

Modified by jscher2000

more options

When I click to save a file, say it is a PDF file, a box pops up and asks if I want to open it with Adobe or if I want to save it, not where I want to save it or anything like that, it says do you want to save it and click on the little "circle", which I do and now the file is downloading. It list the file at the top of that "box" but there is NO where to change the name of the file. There is also a check box in that "original box" that says "save here automically next time", well it is grey out and whether I decide to let it open in Adobe or Save it, that check box is always greyed out and will NOT let me click it to avoid going through it over and over. In the OPTIONS for Fire Fox, I have selected to "always to always save the file" but it seems to have NO bearing on that other box. No matter what type of file I choose to download, that box will pop up asking me to open or save and the little box to click to "do this automatically" is always greyed out and will never let me click in the box. The only option that I have is, to "save it" and than go into File Manager, once it is downloaded and rename the file there. That gets to be a pain when you are downloading a bunch of files and have to let them just download and go into Windows File Manager to rename them. I get NO chance to rename, I get NO chance to do the "automatically from now on" and I go through that over and over! I tried to copy the BOX that appears when I download something, but it won't let me to send it to you guys. I had this exact problem with older versions of Fire Fox and I got tired of having to do this again and again. I am not a NOVICE at this stuff. I have been at it for over 30 years. I have built computers for 7 grandsons for gaming. I have upgraded my own computers for me and for other people. I have set up computers for two different doctor's offices, so I know how to do this but I cannot stop Firefox from doing this, my fault, Firefox, whatever. I know it doesn't matter whether I stay with Fire Fox or not, I am one guy but I can't believe I am the only one getting this problem for the past ten years. I have been using Google for at least five years. I have been using Brave off and on for at least a year, I downloaded the new Opera before I tried Firefox again. I get this problem ONLY in Firefox and I am clueless as to why??? I like the new Fire Fox and have used Fire Fox only for many years but this will drive me away, as it did years ago!

more options

Have you tried using a download manager? Some of them make Firefox downloads run better.

Go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) and search for what you want.

This download manager works separately from the browser. The browser tells it what to download, and off it goes.

http://www.freedownloadmanager.org It is a powerful modern download accelerator and organizer for Windows and Mac.


It's possible something is wrong with the file that tells Firefox what to do with what type of file.

Deleting mimeTypes.rdf will reset all download actions to the default settings. In Firefox 55+, the file name was changed to handlers.json

more options

Hi George:

For Step (2):

Usually Firefox disables the checkbox in the Download dialog when the content type of the download is non-specific. The agreed content-type for a PDF file, which the server is supposed to send in a header with the file, is application/pdf. The setting under Applications for Portable Document Format (PDF) corresponds strictly to that content-type.

It could be a site issue: some sites do not send Firefox the application/pdf content type for some reason, and as far as I know, Firefox has no feature to override the given content type.

However, if this happens with PDFs from every site, it could be a corrupted settings file. Here's how to hide that file and trigger Firefox to create a new one:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then:

  • If you see a file named handlers.json, then right-click > Rename it to something like handlersOLD.json.
  • If you see a file named mimeTypes.rdf, then right-click > Rename it to something like mimeTypesOLD.rdf.

Start Firefox back up again. Any difference?

Note that you will need to update your preference for Portable Document Format (PDF) on the Options page after this procedure (it will revert to Preview in Firefox).

For Step (3):

Could you please check your setting for letting you choose the folder and file name of files that Firefox is saving. I need to know whether you can address that part of the problem by changing to "Always ask you where to save files" or whether your Firefox is ignoring that instruction.

more options

This is just a partial reply as I have not tried what you have told me. In the "options" for Fire Fox, I do have Save files to checked, so Fire Fox is ignoring that setting in Options! I just wanted to get that back to you before I try what you are suggesting. It is going to be a little while as I am fighting with WayFair about an item that I bought three weeks ago and it still has NOT shown up and the tracking info says it is still sitting in Tupelo and I am in Ohio!! Why is NOTHING ever easy???