Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Using Firefox Top sites I click through to a site that I know has SSL security certificate but it shows HTTP and not HTTPS. But click on Home page & shows HTTPS

more options

Firefox saves NB Data.co.uk as a top site (that I use often) I know NB Data has an SSL certificate When I click on the NB Data top site icon it shows just HTTP with the lock crossed through in red as if it isn't secure http://nbdata.co.uk/ If I then click on the home page of this site it shows HTTPS as it does on other pages https://www.nbdata.co.uk/index.php I have cleared cache and history Can you help? Using my laptop

Chosen solution

If the http address automatically redirected to https, I'm pretty sure Firefox would store the "final" address. But for now, you need to fix it by hand.

Find the site on your new tab page, hover the icon, click the ••• icon, then click Edit and you can fix the URL. Screenshots follow.

Read this answer in context 👍 0

All Replies (3)

more options

Hi, I get the same results as you. Should contact the website as there certificate is not configured properly.

Please let us know if this solved your issue or if need further assistance.

more options

Chosen Solution

If the http address automatically redirected to https, I'm pretty sure Firefox would store the "final" address. But for now, you need to fix it by hand.

Find the site on your new tab page, hover the icon, click the ••• icon, then click Edit and you can fix the URL. Screenshots follow.

Modified by jscher2000

more options

Thanks that solved it