X
Tap here to go to the mobile version of the site.

Support Forum

Firefox doesn't save password

Posted

Hi,

Summary :


Firefox doesn't save password. On form login webpage, the dialogbox asking if I want to save my login/password appears, but it is not saved (when I logout, no remember data is displayed on loggin form as usually. Nothing appears in Preference/Privacy & Security list of saved login/password : empty).

Environnement :


Mozilla Firefox 59.0.2 Ubuntu 17.10 64 bits

What I do to try to solve this problem:


1. I read the mozilla knowledge database https://support.mozilla.org/en-US/kb/usernames-and-passwords-are-not-saved

All is ok ( "Remember logins and passwords for websites." checked, always remember history... )

2. I check file permissions (chmod, chown) of .mozilla folder, read & write privileges for user (the profile folder cames from a windows installation : user switching to linux... )

3. A message error on console log


(/usr/lib/firefox/firefox:2827): dconf-WARNING **: Unable to open /var/lib/snapd/desktop/dconf/profile/user: Permission non accordée

This message appears when I load a webpage with the empty form loggin, (not when the dialog box asking to save appears...) . Pearhaps, do not relate this problem.

But this bring me to a similar support for firefox with this error https://bbs.archlinux.org/viewtopic.php?id=156416

So, I disable extension : same probleme. I empty extension folder : same problem

4. Rename file in profile folder : A solution suggested to solve no registering password I can read is to rename key3.db key4.db and login.json. Same problem.

When I ask to register login/password when the dialogbox appears, only login.json seams written.

List of profile folder modified file during theses tests : saved-telemetry-pings crashes prefs.js sessionCheckpoints.json webappsstore.sqlite favicons.sqlite SecurityPreloadState.txt AlternateServices.txt xulstore.json addons.json addonStartup.json.lz4 extensions.json extensions search.json.mozlz4 compatibility.ini permissions.sqlite logins.json


A solution finded


I run firefox --safe-mode option : all works fine : can register new passwords, and old user password (from his windows firefox installation) appears in preference/privacy dialog.

Can you help me ?

Thanks !

Hi, Summary : --------------- Firefox doesn't save password. On form login webpage, the dialogbox asking if I want to save my login/password appears, but it is not saved (when I logout, no remember data is displayed on loggin form as usually. Nothing appears in Preference/Privacy & Security list of saved login/password : empty). Environnement : ---------------------- Mozilla Firefox 59.0.2 Ubuntu 17.10 64 bits What I do to try to solve this problem: -------------------------------------------------- 1. I read the mozilla knowledge database https://support.mozilla.org/en-US/kb/usernames-and-passwords-are-not-saved All is ok ( "Remember logins and passwords for websites." checked, always remember history... ) 2. I check file permissions (chmod, chown) of .mozilla folder, read & write privileges for user (the profile folder cames from a windows installation : user switching to linux... ) 3. A message error on console log ------------------------------------------- (/usr/lib/firefox/firefox:2827): dconf-WARNING **: Unable to open /var/lib/snapd/desktop/dconf/profile/user: Permission non accordée This message appears when I load a webpage with the empty form loggin, (not when the dialog box asking to save appears...) . Pearhaps, do not relate this problem. But this bring me to a similar support for firefox with this error https://bbs.archlinux.org/viewtopic.php?id=156416 So, I disable extension : same probleme. I empty extension folder : same problem 4. Rename file in profile folder : A solution suggested to solve no registering password I can read is to rename key3.db key4.db and login.json. Same problem. When I ask to register login/password when the dialogbox appears, only login.json seams written. List of profile folder modified file during theses tests : saved-telemetry-pings crashes prefs.js sessionCheckpoints.json webappsstore.sqlite favicons.sqlite SecurityPreloadState.txt AlternateServices.txt xulstore.json addons.json addonStartup.json.lz4 extensions.json extensions search.json.mozlz4 compatibility.ini permissions.sqlite logins.json A solution finded ----------------------- I run firefox --safe-mode option : all works fine : can register new passwords, and old user password (from his windows firefox installation) appears in preference/privacy dialog. Can you help me ? Thanks !

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

FredMcD
  • Top 10 Contributor
4248 solutions 59433 answers

Are you using any password add-ons/programs?

Are you using any password add-ons/programs?

Question owner

No, it is a standard ubuntu gnu/linux installation. And I tryied to disable, and erase all extensions.

No, it is a standard ubuntu gnu/linux installation. And I tryied to disable, and erase all extensions.
FredMcD
  • Top 10 Contributor
4248 solutions 59433 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

It is what I relate in my first message (instead of shift, I launch from command line with --safe-mode parameter, it is the same (dialog box with "start in safe mode", confirm...)).

In safe mode, all works fine :

I can register new passwords, and old user password (from his windows firefox installation) appears in preference/privacy dialog.

It is what I relate in my first message (instead of shift, I launch from command line with --safe-mode parameter, it is the same (dialog box with "start in safe mode", confirm...)). In safe mode, all works fine : I can register new passwords, and old user password (from his windows firefox installation) appears in preference/privacy dialog.
FredMcD
  • Top 10 Contributor
4248 solutions 59433 answers

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Question owner

I didn't refer it into my first message but, I tryied to to switch off hardware acceleration. No effect onto my problem.

As explained at first, I tryied to disable all extensions. No effect.

After, I delete all extensions (./mozilla/firefox/USER_FOLDER/extensions).

No effect.

No other toolbar add ons.

There is no antivirus software on this systeme (commu Gnu/Linux Ubuntu 17.10 installation).

Firefox had been restarted after modifying.

I didn't refer it into my first message but, I tryied to to switch off hardware acceleration. No effect onto my problem. As explained at first, I tryied to disable all extensions. No effect. After, I delete all extensions (./mozilla/firefox/USER_FOLDER/extensions). No effect. No other toolbar add ons. There is no antivirus software on this systeme (commu Gnu/Linux Ubuntu 17.10 installation). Firefox had been restarted after modifying.
FredMcD
  • Top 10 Contributor
4248 solutions 59433 answers

Refreshing Firefox {web link} is a LAST RESORT ! !

Refreshing Firefox -- easily fix most problems

If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed.

[https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refreshing Firefox] {web link} is a '''LAST RESORT ! !''' Refreshing Firefox -- easily fix most problems If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed.