X
Tap here to go to the mobile version of the site.

Support Forum

Firfox running slow

Posted

Firefox slow after last update as title shows, i have issue with fire fox almost grinding my pc to a halt seems to have hapened after last update. Enclosed is a screen shot of "Task manager" showing "6" instances of FF running at the same time yet with only one window open. I also use the micro soft widget that shows the cpu and memory usage as as i type cpu is showing10% and memory 63% tried other browsers and all is good (except i dont like em) Since taking the screen shot earlier i have removed firefox and reinstalled it and its still the same.

Mike

Firefox slow after last update as title shows, i have issue with fire fox almost grinding my pc to a halt seems to have hapened after last update. Enclosed is a screen shot of "Task manager" showing "6" instances of FF running at the same time yet with only one window open. I also use the micro soft widget that shows the cpu and memory usage as as i type cpu is showing10% and memory 63% tried other browsers and all is good (except i dont like em) Since taking the screen shot earlier i have removed firefox and reinstalled it and its still the same. Mike
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 29.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

FredMcD
  • Top 10 Contributor
3668 solutions 50312 answers

Helpful Reply

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess ------------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you? 1
Quote

Question owner

Ok thanks for that. The links explain a lot. It’s looking like it’s just a coincidence the Firefox update and the slowing down of the pc, let me delve further into what’s going on.

Mike

Ok thanks for that. The links explain a lot. It’s looking like it’s just a coincidence the Firefox update and the slowing down of the pc, let me delve further into what’s going on. Mike
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.