X
Tap here to go to the mobile version of the site.

Support Forum

Header image and text for website does not load properly on Firefox - image partially visible, some text squished.

Posted

First off, thanks to everyone who pitches in to help resolve this headache. Sheesh!

Problem: The Header image and text do not display properly in Firefox: The content does displays properly in Chrome, Opera and Safari. By the way: I have read and attempted all the applicable troubleshooting suggestions Firefox has supplied without success.

Website: www.twoworlds.ca The page in question is www.twoworlds.ca/other-world.html

Note: I coded the site myself using largely a w3.css framework. Admittedly, the source code is messy. I'm still chimpin' around (experimenting) with things.

Incredibly, am unable to upload two 137 kb screen captures of the problem for visual reference - an endless spin wheel for 12-minutes. Wha..? In that case, please visit my site in Chrome and then Firefox to see the difference. the site again: www.twoworlds.ca/other-world.html

Thanks.

First off, thanks to everyone who pitches in to help resolve this headache. Sheesh! Problem: The Header image and text do not display properly in Firefox: The content does displays properly in Chrome, Opera and Safari. By the way: I have read and attempted all the applicable troubleshooting suggestions Firefox has supplied without success. Website: www.twoworlds.ca The page in question is www.twoworlds.ca/other-world.html Note: I coded the site myself using largely a w3.css framework. Admittedly, the source code is messy. I'm still chimpin' around (experimenting) with things. Incredibly, am unable to upload two 137 kb screen captures of the problem for visual reference - an endless spin wheel for 12-minutes. Wha..? In that case, please visit my site in Chrome and then Firefox to see the difference. the site again: www.twoworlds.ca/other-world.html Thanks.

Chosen solution

The <header> element doesn't have the height property. You need height instead of min-height (or both).

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

I checked your links, and saw no problem.

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 59.0.2


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

I checked your links, and saw no problem. https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version '''59.0.2''' In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!

Question owner

Hey FredMcD, I was able to upload screen captures this time.

Again, the page in question: www.twoworlds.ca/other-world.html

Thanks so much!

Hey FredMcD, I was able to upload screen captures this time. Again, the page in question: www.twoworlds.ca/other-world.html Thanks so much!

Question owner

And, yes FredMcD, I have the latest version of Firefox installed: 59.0.2

And, yes FredMcD, I have the latest version of Firefox installed: 59.0.2
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

Ah. I missed that the top is cut off. I called for more help.

Ah. I missed that the top is cut off. I called for more help.
TyDraniu
  • Top 25 Contributor
316 solutions 1780 answers

Chosen Solution

The <header> element doesn't have the height property. You need height instead of min-height (or both).

The <header> element doesn't have the height property. You need height instead of min-height (or both).

Question owner

TyDraniu, THAT'S IT!!! You have no idea how long I looked at this problem like an ape looking at fire for the first time.

It never dawned on me that a browser to browser quirk could be so specific. So, this is one quirk of Firefox quirk: The height property must be specified as 'height' instead of 'min-height'.

Thanks much to the Mozilla Support Community generally, and TyDraniu specifically, for pouncing on my problem so quickly.

Life is good!!!!

TyDraniu, THAT'S IT!!! You have no idea how long I looked at this problem like an ape looking at fire for the first time. It never dawned on me that a browser to browser quirk could be so specific. So, this is one quirk of Firefox quirk: The height property must be specified as 'height' instead of 'min-height'. Thanks much to the Mozilla Support Community generally, and TyDraniu specifically, for pouncing on my problem so quickly. Life is good!!!!
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.