X
Tap here to go to the mobile version of the site.

Support Forum

Самопроизвольный редирект в браузере с HTTP на HTTPS. Как это остановить?

Posted

Почему Firefox сам редиректит с HTTP на HTTPS? Это именно на уровне браузера Firefox! Как это остановить? Спасибо!

Почему Firefox сам редиректит с HTTP на HTTPS? Это именно на уровне браузера Firefox! Как это остановить? Спасибо!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

Question owner

В другом браузере такой проблемы нет. В Firefox проблема уходит, если очистить всю историю.

На доменах о котором Я говорю, никогда не было HTTPS.

В другом браузере такой проблемы нет. В Firefox проблема уходит, если очистить всю историю. На доменах о котором Я говорю, никогда не было HTTPS.
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.113

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 29.0.0.113 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

1) I refresh Flash Player.

2) I restart in safe mode, problem still there.

http://prntscr.com/iytc0v

3) I wrote http://bw.devplan.ru (this my domain available only for me) But firefox in safe mode change from HTTP on HTTPS, not via redirect.

http://prntscr.com/iytc9j

But, if i clear all history Firefox work correct. After a while, the problem repeats.

In other browser no this problem.

http://prntscr.com/iytctd

1) I refresh Flash Player. 2) I restart in safe mode, problem still there. http://prntscr.com/iytc0v 3) I wrote http://bw.devplan.ru (this my domain available only for me) But firefox in safe mode change from HTTP on HTTPS, not via redirect. http://prntscr.com/iytc9j But, if i clear all history Firefox work correct. After a while, the problem repeats. In other browser no this problem. http://prntscr.com/iytctd

Question owner

Please see screencast.

https://yadi.sk/i/SIV5bvC-3Tvzaa

Please see screencast. https://yadi.sk/i/SIV5bvC-3Tvzaa
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

This will show us your system details. No Personal Information Is Collected.

Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Now in the Reply Box on the forum page, do a right-click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.'''

Question owner

I try paste here text from browser :)

http://prntscr.com/iyu2ww

I try paste here text from browser :) http://prntscr.com/iyu2ww

Question owner

Please download from Yandex.Disk

https://yadi.sk/i/BMbU_YHv3Tw6e9

Please download from Yandex.Disk https://yadi.sk/i/BMbU_YHv3Tw6e9
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

I called for more help.

I called for more help.

Question owner

If necessary, I can provide access to the PC through TeamViewer.

If necessary, I can provide access to the PC through TeamViewer.
Shadow110 1072 solutions 14836 answers

HI, sorry we do not do that.

Suggest you clear your cache and cookies, restart Firefox and try.

You can ask your question here in your own language : https://mozilla-russia.org

HI, sorry we do not do that. Suggest you clear your cache and cookies, restart Firefox and try. You can ask your question here in your own language : https://mozilla-russia.org