X
Tap here to go to the mobile version of the site.

Support Forum

Scrolling lag problems

Posted

Ever since the new update(s) my FF gets laggy from time to time (scroll wise). It's like my FPS drops when trying to scroll through the pages. It happens randomly. The only way to get it back to normal is to minimize the browser and maximize again. What's going on? This is a really annoying problem, and I don't want to switch to Chrome or something since I've been with FF for over a decade.

Ever since the new update(s) my FF gets laggy from time to time (scroll wise). It's like my FPS drops when trying to scroll through the pages. It happens randomly. The only way to get it back to normal is to minimize the browser and maximize again. What's going on? This is a really annoying problem, and I don't want to switch to Chrome or something since I've been with FF for over a decade.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.113

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 29.0.0.113 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Type about:preferences<enter> in the address bar. Search for scrolling. And change the Use smooth scrolling setting.

Type '''about:preferences'''<enter> in the address bar. Search for '''scrolling.''' And change the '''Use smooth scrolling''' setting.

Question owner

FredMcD said

Type about:preferences<enter> in the address bar. Search for scrolling. And change the Use smooth scrolling setting.

It's already on. I do have a 144hz monitor which pushes out 144FPS constantly (while browsing at least) , so it might be an issue? Don't see how adobe flash could interfere with my scrolling tbh.

''FredMcD [[#answer-1093582|said]]'' <blockquote> Type '''about:preferences'''<enter> in the address bar. Search for '''scrolling.''' And change the '''Use smooth scrolling''' setting. </blockquote> It's already on. I do have a 144hz monitor which pushes out 144FPS constantly (while browsing at least) , so it might be an issue? Don't see how adobe flash could interfere with my scrolling tbh.
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Flash is used to display what the website sends when called for.

bobalo said

It's already on

Try turning it off.

Flash is used to display what the website sends when called for. ''bobalo [[#answer-1093583|said]]'' <blockquote> It's already on </blockquote> Try turning it off.

Question owner

FredMcD said

Flash is used to display what the website sends when called for. bobalo said
It's already on

Try turning it off.

Turning it off makes it, well not smooth, so I'd leave that on. Pages that get laggy do not necessarily have FLASH on them as well.

''FredMcD [[#answer-1093608|said]]'' <blockquote> Flash is used to display what the website sends when called for. ''bobalo [[#answer-1093583|said]]'' <blockquote> It's already on </blockquote> Try turning it off. </blockquote> Turning it off makes it, well not smooth, so I'd leave that on. Pages that get laggy do not necessarily have FLASH on them as well.
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?