Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to get longer, scrollable, list of visited URLs and bookmarks in Address Bar?

  • 12 replies
  • 2 have this problem
  • 423 views
  • Last reply by Henrik R.

more options

A long time ago Firefox limited the usefulness of the autocomplete feature in the Address Bar (also called location bar or 'Awesome bar') by making the list of visited URLs and bookmarks shorter and not scrollable. In that way I felt I lost access to half of my history and bookmarks. How can I get it back?

PS: I am currently using Firefox ESR because my favourite addons do not work in Webextension. Actually I think it's quite sad how Webextensions limits Firefox.

Chosen solution

Hero27 said

TyDraniu said
Go to about:config and increase value of browser.urlbar.maxRichResults.

Hi! It didn't work. I doubled the value, and restarted Firefox and checked that the value is still as I set it (to 20), but there are still only 10 results showing.

Now I realize that the userChrome.css is not enough. I need the browser.urlbar.maxRichResults setting too.

Read this answer in context 👍 0

All Replies (12)

more options

Go to about:config and increase value of browser.urlbar.maxRichResults.

more options

If you want more results than will fit on the screen or whatever maximum height Firefox sets internally, you may need to use a custom style rule to add a scrollbar. I think I have that as part of this rule set somewhere:

https://www.jeffersonscher.com/gm/url-bar-tweaks.html

more options

TyDraniu said

Go to about:config and increase value of browser.urlbar.maxRichResults.

Hi! It didn't work. I doubled the value, and restarted Firefox and checked that the value is still as I set it (to 20), but there are still only 10 results showing.

more options

jscher2000 said

If you want more results than will fit on the screen or whatever maximum height Firefox sets internally, you may need to use a custom style rule to add a scrollbar. I think I have that as part of this rule set somewhere: https://www.jeffersonscher.com/gm/url-bar-tweaks.html

Yes! Now I have 20 URL suggestions in the address bar / location bar! Thank you!

more options

There is still a peculiar problem though. Look at the strange indentations on the 2 attached screen shots.

more options

Hi Hero27, I don't know what is taking up that extra space.

What rule did you use to increase the height? For example:

/* All items visible without scrolling */
#PopupAutoCompleteRichResult .autocomplete-richlistbox {
  height:auto !important; /* for ESR52, not Quantum */
}
more options

jscher2000 said

Hi Hero27, I don't know what is taking up that extra space. What rule did you use to increase the height? For example:
/* All items visible without scrolling */
#PopupAutoCompleteRichResult .autocomplete-richlistbox {
  height:auto !important; /* for ESR52, not Quantum */
}

Thank you for your reply!

I have 2 rules similar to that:

 /* Ability to scroll in Fx57 */
 #PopupAutoCompleteRichResult .autocomplete-richlistbox > scrollbox {
   overflow-y: auto !important; 
   padding-right: 3px !important;
 }
 #PopupAutoCompleteRichResult .autocomplete-richlistbox {
   padding-right: 0 !important;
 }

Is that 1 too many? :-) NB! I use Firefox ESR v.52.6.0 (64-bit).

more options

Hi Hero27, I don't think either of those rules is the problem: padding-right is just empty space on the right side, and overflow-y affects the vertical dimension. More likely it's something on the left side, or something which hides or collapses certain icons.

more options

I just posted the following message, but the forum software cut the userChrome.css file in 2. Apparently because there is a comment taking up several lines:

jscher2000 said

Hi Hero27, I don't think either of those rules is the problem: padding-right is just empty space on the right side, and overflow-y affects the vertical dimension. More likely it's something on the left side, or something which hides or collapses certain icons.

Well. Here is the whole userChrome.css file. Can you see the problem somewhere?:

/* Taller Folder List in Edit Bookmark */
#editBMPanel_folderTree {
  min-height: 400px !important; 
}
/* 
  Firefox 57 users: https://www.jeffersonscher.com/gm/url-bar-tweaks.html
  You can copy/paste into a userChrome.css file, see https://www.userchrome.org/
  Firefox 52-56 users: roll back your Stylish to version 2.1.1 or 2.0.7 here:
  https://addons.mozilla.org/firefox/addon/stylish/versions/
  Then find Stylish on the Add-ons page, click its More link, and turn off updates
*/
@-moz-document url(chrome://browser/content/browser.xul) {
  /* " - Visit" or " - Search with" bar NOT HIDDEN */

  /* Restore persistent display of drop-marker */
  #urlbar:not(:hover) > .urlbar-textbox-container > .urlbar-history-dropmarker {
    opacity: 1 !important;
  }
  /* Set max-height for items visible without scrolling */
  #PopupAutoCompleteRichResult .autocomplete-richlistbox {
    height: auto !important;
    max-height: calc(30px * 20) !important;
  }
  /* Constrain drop-down width */
  #PopupAutoCompleteRichResult {
    max-width: 1200px !important;
  }
  /* Default font sizes */
  .autocomplete-richlistitem[selected=true] {
    background-color: Highlight !important;
  }
  .autocomplete-richlistitem[selected=true] .ac-title, 
  .ac-title[selected],
  .autocomplete-richlistitem[selected=true] .ac-url, 
  .ac-url[selected],
  .autocomplete-richlistitem[selected=true] .ac-action,
  .ac-action[selected],
  .autocomplete-richlistitem[selected=true] .ac-separator,
  .ac-separator[selected] {
    color: HighlightText !important;
  }
  /* Use default text matching style */

  /* Ability to scroll in Fx57 */
  #PopupAutoCompleteRichResult .autocomplete-richlistbox > scrollbox {
    overflow-y: auto !important; 
    padding-right: 3px !important;
  }
  #PopupAutoCompleteRichResult .autocomplete-richlistbox {
    padding-right: 0 !important;
  }
}

Modified by cor-el

more options

I don't see anything there that should cause this issue, sorry.

more options

jscher2000 said

I don't see anything there that should cause this issue, sorry.

OK. Thanks anyway! It doesn't happen all the time. So all in all your help has been a great improvement!

more options

Chosen Solution

Hero27 said

TyDraniu said
Go to about:config and increase value of browser.urlbar.maxRichResults.

Hi! It didn't work. I doubled the value, and restarted Firefox and checked that the value is still as I set it (to 20), but there are still only 10 results showing.

Now I realize that the userChrome.css is not enough. I need the browser.urlbar.maxRichResults setting too.