X
Tap here to go to the mobile version of the site.

Support Forum

Websites show in mobile format

Posted

All of my websites are showing in mobile format-- this started several months ago. It doesn't happen when I use other browsers. I've tried the about.config thing and resetting the agent (this was the solution from 2015), but none of my options are available for reset. I have cleared the cookies/cache already-- no change. Please advise!

All of my websites are showing in mobile format-- this started several months ago. It doesn't happen when I use other browsers. I've tried the about.config thing and resetting the agent (this was the solution from 2015), but none of my options are available for reset. I have cleared the cookies/cache already-- no change. Please advise!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17769 solutions 160708 answers

Hi Laura

Does this happen on this forum website as well?

Are you possibly zooming the page in case the screen dimensions are causing this?

Did you check the connection settings?

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Your user agent is normal for Firefox 58 on Windows 10, so that shouldn't be the problem.

  • Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Hi Laura Does this happen on this forum website as well? Are you possibly zooming the page in case the screen dimensions are causing this? Did you check the connection settings? *Options/Preferences -> General -> Network: Connection -> Settings If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can Your user agent is normal for Firefox 58 on Windows 10, so that shouldn't be the problem. *Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Question owner

I changed it to no proxy, but it didn't have much effect. I don't think it happens with all websites (I don't think it's happening with this one), but the important ones I need for work are definitely opening in mobile format, and it's driving me crazy.

I'm not zooming anything as far as I can tell. Everything's the same size, it's just in mobile format and the menus are impossible to navigate.

I changed it to no proxy, but it didn't have much effect. I don't think it happens with all websites (I don't think it's happening with this one), but the important ones I need for work are definitely opening in mobile format, and it's driving me crazy. I'm not zooming anything as far as I can tell. Everything's the same size, it's just in mobile format and the menus are impossible to navigate.
cor-el
  • Top 10 Contributor
  • Moderator
17769 solutions 160708 answers

Can you post some links to websites where this happens?

Can you post some links to websites where this happens?
cor-el
  • Top 10 Contributor
  • Moderator
17769 solutions 160708 answers

You can also check network.http.* prefs on the about:config page to see if some are user set (bold). You can reset user set (bold) pref(s) via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can also check <b>network.http.*</b> prefs on the <b>about:config</b> page to see if some are user set (bold). You can reset user set (bold) <b></b> pref(s) via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config

Modified by cor-el

Question owner

It's happening on our homepage, here: https://www.sdsmt.edu/

It's happening on our homepage, here: https://www.sdsmt.edu/

Question owner

To clarify, I should reset everything that's listed as bold? There's nothing about that in the article you linked to it. Will that make any other changes I don't want it to?

To clarify, I should reset everything that's listed as bold? There's nothing about that in the article you linked to it. Will that make any other changes I don't want it to?

Modified by Laura88

cor-el
  • Top 10 Contributor
  • Moderator
17769 solutions 160708 answers

What network.http prefs show bold if any?

For me all network.http prefs show as default (i.e. not bold).

What network.http prefs show bold if any? For me all network.http prefs show as default (i.e. not bold).
cor-el
  • Top 10 Contributor
  • Moderator
17769 solutions 160708 answers

There are @media rules on that web page that make the desktop version visible with a width of 992px and higher.

@media (min-width: 992px) and (max-width: 1199px)

Other media rules are for:

@media screen and (max-width: 767px)
@media (min-width: 768px) and (max-width: 991px)
@media (min-width: 1200px)
There are @media rules on that web page that make the desktop version visible with a width of 992px and higher. @media (min-width: 992px) and (max-width: 1199px) Other media rules are for: @media screen and (max-width: 767px) @media (min-width: 768px) and (max-width: 991px) @media (min-width: 1200px)

Question owner

I'm not sure what that means. It worked fine from August to November, then suddenly changed. It's only affecting the firefox on my work computer, not on my home computer, and it looks normal on chrome on my work computer. So, it's something with firefox specifically on my work computer.

I'm not sure what that means. It worked fine from August to November, then suddenly changed. It's only affecting the firefox on my work computer, not on my home computer, and it looks normal on chrome on my work computer. So, it's something with firefox specifically on my work computer.

Question owner

There are over 50 in bold when I go to about:config

There are over 50 in bold when I go to about:config

Question owner

Are there any other suggestions? It's getting to the point where I can't do any work on this computer.

Are there any other suggestions? It's getting to the point where I can't do any work on this computer.

Question owner

Hello. I still have this problem. Has any solution been found? Thanks!

Hello. I still have this problem. Has any solution been found? Thanks!
user633449 1539 solutions 10745 answers

Have you tried Refreshing Firefox? Refresh Firefox - reset add-ons and settings

Have you tried Refreshing Firefox? [[Refresh Firefox - reset add-ons and settings]]

Question owner

It says that will restore firefox to its default settings. I can't risk doing that since this is my work computer.

It says that will restore firefox to its default settings. I can't risk doing that since this is my work computer.
user633449 1539 solutions 10745 answers

It does, because something in your settings is what's causing the issue.

It will save all your personal data (bookmarks, passwords, history, etc.) as well as a copy of all your original settings on your desktop.

It does, because something in your settings is what's causing the issue. It will save all your personal data (bookmarks, passwords, history, etc.) as well as a copy of all your original settings on your desktop.

Question owner

Are there any other options that don't require me to risk losing important work things?

Are there any other options that don't require me to risk losing important work things?
user633449 1539 solutions 10745 answers

What important things are you thinking you will lose?

You can create a new profile, and see if the issue happens there, but that will cause a lot more work

What important things are you thinking you will lose? You can create a new profile, and see if the issue happens there, but that will cause a lot more work

Question owner

I've done this "put it all in a folder on the desktop" thing before, and it took A LOT of labor and several months to restore everything back to the way it was.

I've done this "put it all in a folder on the desktop" thing before, and it took A LOT of labor and several months to restore everything back to the way it was.
user633449 1539 solutions 10745 answers

Well, it's likely one of those settings that's causing the problem. You can refresh, or give a complete list of all your modified prefs.

Well, it's likely one of those settings that's causing the problem. You can refresh, or give a complete list of all your modified prefs.

Question owner

Seriously? That's the only solution after 3 months of working on this? What about all the other things that were suggested above and that I never received responses to?

Seriously? That's the only solution after 3 months of working on this? What about all the other things that were suggested above and that I never received responses to?