X
Tap here to go to the mobile version of the site.

Support Forum

When trying to logon to IBIS website using Firefox, their analysis says I'm not on Firefox but instead "lua-resty-http/0.10 (Lua) ngx_lua/10000". Why?

Posted

I'm trying to logon to the International Baccalauareate IBIS website using Firefox (which they require I use). I've followed all their directions to the letter, but it errors out every time. Their tech guy says that it shows that I'm NOT logging on using Firefox, but instead it shows my browser is "lua-resty-http/0.10 (Lua) ngx_lua/10000". It says the same thing for all my colleagues at work that are also trying to log on. My colleagues are using work computers that have had all their software downloaded by IT guys at work. My computer is a personal PC that had Firefox downloaded myself from the web. So it doesn't make sense that we would have the same problem unless the problem is intrinsic to Firefox or some common virus that was hidden from us but affected all of us. Any help or advice would be appreciated, as we are required to use Firefox for this website, but the administrator of the website says our logins don't look like they are coming from Firefox ?????

I'm trying to logon to the International Baccalauareate IBIS website using Firefox (which they require I use). I've followed all their directions to the letter, but it errors out every time. Their tech guy says that it shows that I'm NOT logging on using Firefox, but instead it shows my browser is "lua-resty-http/0.10 (Lua) ngx_lua/10000". It says the same thing for all my colleagues at work that are also trying to log on. My colleagues are using work computers that have had all their software downloaded by IT guys at work. My computer is a personal PC that had Firefox downloaded myself from the web. So it doesn't make sense that we would have the same problem unless the problem is intrinsic to Firefox or some common virus that was hidden from us but affected all of us. Any help or advice would be appreciated, as we are required to use Firefox for this website, but the administrator of the website says our logins don't look like they are coming from Firefox ?????

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Are you posting this question from the 'bad' computer?

Your system details shows; User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Windows 10, Firefox v58 @ 64bit

https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

http://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network.

[v57+] Select Privacy. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Are you posting this question from the 'bad' computer? Your system details shows; User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0 Windows 10, Firefox v58 @ 64bit https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox http://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/ ------------------ Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. Type '''about:preferences'''<enter> in the address bar. * '''Cookies; ''' Select '''Privacy. ''' Under '''History, ''' select Firefox will '''Use Custom Settings. ''' Press the button on the right side called '''Show Cookies. ''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache; ''' Select '''Advanced > Network. ''' [v57+] Select '''Privacy. ''' Across from '''Cached Web Content, ''' Press '''Clear Now. ''' If there is still a problem, '''Start Firefox in Safe Mode''' https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}