Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't ask to remember a password, on one site, on one PC

more options

One site that I use regularly (https://studio.zenplanner.com) starts off with a login page. At one point I changed my password, and Firefox kept pre-filling with the wrong one. I went into Saved Logins and deleted the login. Since then, Firefox never asks to remember the password again. My email address does show as an autocomplete option in the email field on the form, but no password remembering.

Things I have checked:

- The site does not block saving logins like some banking sites do; Firefox will remember passwords for this site on other PCs. - The site is not listed under Exceptions. - Adding an Exception for this site and then removing it had no effect. - Unchecking and rechecking "Remember logins and passwords for websites" had no effect. - I am not running in Private Browsing mode. - I do not have a third-party password manager installed. - I do have Kaspersky Total Security installed, but I have it installed on other PCs as well and it does not interfere with password saving.

I'm trying Safe Mode next, but I can't find anything else to try in the support articles...

All Replies (20)

more options

https://support.mozilla.org/en-US/kb/usernames-and-passwords-are-not-saved Usernames and passwords are not saved

https://support.mozilla.org/en-US/kb/fix-login-issues-on-websites-require-passwords Fix login issues on websites that require a username and password

more options

Tried all that. No luck.

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network.

[v57+] Select Privacy. Across from Cached Web Content, Press Clear Now.

more options

After doing all that, still same behavior.

more options

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

more options

Nope, still no offer to remember a password. This might be a genuine bug...

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Hi,

Stab in the dark, but : after you changed your password for that site, did you then do what's described in this article :

https://support.mozilla.org/en-US/kb/password-manager-remember-delete-change-and-import

It says :

If you've stored the wrong username or password, just type the right one into the website and Firefox will prompt you to save it. To save the new username and password, click on Update."

Did you click on 'Update'  ?

(Probably a rhetorical question, but was worth a shot .... )

more options

Do you see any entries from the website (domain) in the logins.json file in the profile folder?

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

@FredMcD - Tried safe mode, no dice. (In general, I tried everything in pretty much every support article that came up in a search.)

@Happy112 - I didn't, but it's kind of moot. Since I removed the stored password, Firefox never asks me at all to save or update the password -- that's the problem.

@cor-el - no, the site does not appear in logins.json.

more options

On the theme of profiles, it occurred to me to create a new one a launch a new window using that profile. Didn't help.

more options

Try to clear the Site Preferences.

  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for password and other website specific data
more options

Where do I find that? The only spot I see is under History, Use custom settings, Clear history when Firefox closes. It would be nice to not lose all my other saved passwords in order to fix this, but I will if I have to.

more options

You only lose exceptions and other site specific data that Firefox has stored. Stored passwords aren't affected.

Is there anything present under disabledHosts in logins.json ("disabledHosts":[])?

more options

Clearing Site Preferences made FF forget the email addresses that had been entered into this site's login form, but it still doesn't ask to remember the password after I log in.

disabledHosts at the end of logins.json is empty. I.e., exactly as you show.

more options

I want you to check something,

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Firefox changed the password files from key3.db to key4.db

Look in the profile and see if you still have the key3.db file. If you do, rename key4.db by adding .old to it. Restart Firefox.

more options

@FredMcD - yes, both key3.db and key4.db were present. Both dated after the problem started occurring. Renamed key3.db as suggested. No change in behavior.

more options

Please re-read my rename instructions.

more options

fencer_gregj said

Since I removed the stored password, Firefox never asks me at all to save or update the password -- that's the problem.

Just to make sure : This is the only site that no longer displays the Remember Password
prompt  ?

more options

@FredMcD - sorry, I misread (thought the older file would be the problem causer). Closed FF, renamed key4.db and put key3.db back, restarted, still no change.

@Happy112 - yes, this is the only site showing this problem on this PC, and this is the only PC showing the problem with this site. It is also the only PC where I told FF to forget the saved login for this site.

  1. 1
  2. 2