X
Tap here to go to the mobile version of the site.

Support Forum

I lost all my bookmarks after upgrading and then downgrading. Anyone know how to find bookmarks?

Posted

I've been using Firefox 13.0 forever...quite comfortably...but certain financial sites were 'complaining', so I finally upgraded. I found I DID NOT LIKE certain (lack of) features so I deleted Version 58? and went back to 13.0. BUT....NONE OF MY BOOKMARKS WENT BACK!!! I'm SCREWED...I have over 1500 major or sub/sub bookmarks!

I FOUND THEM under Mozilla/Firefox/profiles/(default#)/bookmarkbackups. When you finally get to bookmarkbackups you have several date options. However, they are in JSON files, and when I open in WordPad it shows just continuing text and marks. BUT...you can read the text and see that the bookmarks ARE STILL IN THE COMPUTER. I just can't get them back to the regular bookmarks drop-down at the top of the browser page.

So...does anyone know how to get the JSON file(s) back over to the bookmark toolbar?

I've been using Firefox 13.0 forever...quite comfortably...but certain financial sites were 'complaining', so I finally upgraded. I found I DID NOT LIKE certain (lack of) features so I deleted Version 58? and went back to 13.0. BUT....NONE OF MY BOOKMARKS WENT BACK!!! I'm SCREWED...I have over 1500 major or sub/sub bookmarks! I FOUND THEM under Mozilla/Firefox/profiles/(default#)/bookmarkbackups. When you finally get to bookmarkbackups you have several date options. However, they are in JSON files, and when I open in WordPad it shows just continuing text and marks. BUT...you can read the text and see that the bookmarks ARE STILL IN THE COMPUTER. I just can't get them back to the regular bookmarks drop-down at the top of the browser page. So...does anyone know how to get the JSON file(s) back over to the bookmark toolbar?
Quote

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 18.9.20044
  • 5.1.50907.0
  • GEPlugin
  • VLC media player Web Plugin 2.0.0-rc
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

jscher2000
  • Top 10 Contributor
7259 solutions 59071 answers

JSON data is hard to read. Did you try using the Restore feature from inside Firefox? See: Restore bookmarks from backup or move them to another computer

JSON data is hard to read. Did you try using the Restore feature from inside Firefox? See: [[Restore bookmarks from backup or move them to another computer]]
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
7259 solutions 59071 answers

Now, I have to say, there are many ways to modify Firefox's appearance and add features, so if you can be more specific about your needs, we may be able to help you get a more secure browsing experience.

Now, I have to say, there are many ways to modify Firefox's appearance and add features, so if you can be more specific about your needs, we may be able to help you get a more secure browsing experience.
Was this helpful to you? 0
Quote

Question owner

Yes, I tried the "import and backup" drop-down from the "Show all bookmarks" under the Bookmark title (top-leftish). When I click on "Import and Backup" the "restore" button opens a right-hand box showing about a dozen dates. I clicked on all dates. Box comes up saying something about all your 'other bookmarks' will be lost or something like that. I pick a date, click "okay" to the earlier warning box, and it comes up saying it get to the file. All that's left is to click, "okay". Nothing happens. And I have NO IDEA how to work with the JSON files under the RUN %appdata% subfiles...which finally reach "bookmarkbackups", whereupon you find the different dates....about 12 within a month or so. I am $#$#$#ING DYING here!

HOW do I get the Bookmarks BACK into ANY version of FF?

I have over 1400 primary, secondary, and beyond Bookmarks....I am REALLY screwed if I can't get this fixed.

Yes, I tried the "import and backup" drop-down from the "Show all bookmarks" under the Bookmark title (top-leftish). When I click on "Import and Backup" the "restore" button opens a right-hand box showing about a dozen dates. I clicked on all dates. Box comes up saying something about all your 'other bookmarks' will be lost or something like that. I pick a date, click "okay" to the earlier warning box, and it comes up saying it get to the file. All that's left is to click, "okay". Nothing happens. And I have NO IDEA how to work with the JSON files under the RUN %appdata% subfiles...which finally reach "bookmarkbackups", whereupon you find the different dates....about 12 within a month or so. I am $#$#$#ING DYING here! HOW do I get the Bookmarks BACK into ANY version of FF? I have over 1400 primary, secondary, and beyond Bookmarks....I am REALLY screwed if I can't get this fixed.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7259 solutions 59071 answers

Helpful Reply

Hi snowcrow, the Restore should be automatic once you select the date from the menu.

If that doesn't work, it's possible the database file (places.sqlite) somehow became corrupted by upgrading/downgrading. You could try removing it and letting Firefox generate a new one, hopefully automatically populating your bookmarks into it. Not sure if you already tried that.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, find the Profile Folder row and click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "Firefox" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its file cleanup, then rename places.sqlite to something like placesOLD.sqlite. If you see files places.sqlite-shm and places.sqlite-wal, you can delete those.

Start Firefox back up again. Does it recover your last bookmark backup?

Hi snowcrow, the Restore should be automatic once you select the date from the menu. If that doesn't work, it's possible the database file (places.sqlite) somehow became corrupted by upgrading/downgrading. You could try removing it and letting Firefox generate a new one, hopefully automatically populating your bookmarks into it. Not sure if you already tried that. Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, find the Profile Folder row and click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "Firefox" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its file cleanup, then rename '''places.sqlite''' to something like placesOLD.sqlite. If you see files places.sqlite-shm and places.sqlite-wal, you can delete those. Start Firefox back up again. Does it recover your last bookmark backup?
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
7259 solutions 59071 answers

Helpful Reply

Also, try converting your latest JSON backup file to the importable HTML format. I have a tool for that here:

https://www.jeffersonscher.com/res/bookbackreader.html

I haven't tested that page in old versions of Firefox. If it doesn't work, try running it in Chrome.

Once you have the HTML file, this article has the steps to import it:

Import Bookmarks from an HTML file

Also, try converting your latest JSON backup file to the importable HTML format. I have a tool for that here: https://www.jeffersonscher.com/res/bookbackreader.html I haven't tested that page in old versions of Firefox. If it doesn't work, try running it in Chrome. Once you have the HTML file, this article has the steps to import it: [[Import Bookmarks from an HTML file]]
Was this helpful to you? 2
Quote

Question owner

Hello all.

By the grace of gods...I WAS able to fix the issue. I went to Bing, typed in what the final box said (about not being able to find the file), and got a HUGE article on the issue.

You basically go into your "Run" enter %appdata%, mozilla, firefox, profiles, etc as it says to do. You delete the "places.squilt"? name? file, and then from the 'backupbookmarks" file area you pick on...(a few days old), and copy it as HTML to a thumb drive.

Leave the thumb drive in), and eliminate all other JSON files,

Restart computer, restart FIrefox....TA DA...it replaces the "place.squilt" file (I think that's the name) and then use the "Import and backup" button at the top of the "show all bookmarks" and FF finds the HTML file and uses that.

Once I had the first computer working I also could have done a SNYC but I wasn't having good results cuz every time it sent me a code via email I could open it...."Error 500"....? So I just did what I did on the first computer....(since they're the same Dell computers anyway.

Thanks to all for your info and help.

Hello all. By the grace of gods...I WAS able to fix the issue. I went to Bing, typed in what the final box said (about not being able to find the file), and got a HUGE article on the issue. You basically go into your "Run" enter %appdata%, mozilla, firefox, profiles, etc as it says to do. You delete the "places.squilt"? name? file, and then from the 'backupbookmarks" file area you pick on...(a few days old), and copy it as HTML to a thumb drive. Leave the thumb drive in), and eliminate all other JSON files, Restart computer, restart FIrefox....TA DA...it replaces the "place.squilt" file (I think that's the name) and then use the "Import and backup" button at the top of the "show all bookmarks" and FF finds the HTML file and uses that. Once I had the first computer working I also could have done a SNYC but I wasn't having good results cuz every time it sent me a code via email I could open it...."Error 500"....? So I just did what I did on the first computer....(since they're the same Dell computers anyway. Thanks to all for your info and help.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.