X
Tap here to go to the mobile version of the site.

Support Forum

Cannot click on links in MSN Hotmail

Posted

I recently reinstalled Windows, and after reinstalling Firefox, when I go into certain emails, I can't click on any of the links. Instead I just get returned to the main Inbox page. I think this is a setting in Firefox, not the MSN Hotmail site, but I can't figure out how to resolve it.

I recently reinstalled Windows, and after reinstalling Firefox, when I go into certain emails, I can't click on any of the links. Instead I just get returned to the main Inbox page. I think this is a setting in Firefox, not the MSN Hotmail site, but I can't figure out how to resolve it.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

Helpful Reply

Please note, I have tested this problem in Internet Explorer and also Google Chrome and I can click on any of the links in those two browsers. This problem is specific to my Firefox browser.

Please note, I have tested this problem in Internet Explorer and also Google Chrome and I can click on any of the links in those two browsers. This problem is specific to my Firefox browser.
WestEnd
  • Top 10 Contributor
54 solutions 2901 answers

Screen of what your clicking? I think something was changed in you email settings that it goes to the main page rather then back to email accounts. This is what I see is going on and if this is the case then you need to contact Hotmail support to find the settings and change it back.

Screen of what your clicking? I think something was changed in you email settings that it goes to the main page rather then back to email accounts. This is what I see is going on and if this is the case then you need to contact Hotmail support to find the settings and change it back.
cor-el
  • Top 10 Contributor
  • Moderator
16553 solutions 149454 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
jscher2000
  • Top 10 Contributor
7682 solutions 62546 answers

Outlook has a "Reading Pane" you can show on the right side of the Inbox. In that case, when you click a message, it displays on the side. (Example screenshot attached.)

If you hide the Reading Pane, then the message appears in front of the Inbox.

In Firefox 58, there is some strange problem with links that appear in front of text in the Inbox list. A click in that area (on a link or even on the message background) seems to "pass through" to the Inbox and select a different message instead of being received by the currently displayed message. It doesn't happen on every message, but once it starts happening, it seems to keep happening. I don't know why.

When I switch to the "beta" Outlook design, I cannot replicate this problem. It seems to work fine.

Two thoughts:

(1) If you have a wide display, you could try using the Reading pane on the right. However, if your display is not wide enough, there will be an inconvenient amount of horizontal scrolling. Also, you see a smaller section of your Inbox.

(2) You could try sliding the "Try the beta" switch that appears above the Inbox and see whether that works better for you.

Do either of those workarounds help?

Outlook has a "Reading Pane" you can show on the right side of the Inbox. In that case, when you click a message, it displays on the side. (Example screenshot attached.) If you hide the Reading Pane, then the message appears ''in front of'' the Inbox. In Firefox 58, there is some strange problem with links that appear in front of text in the Inbox list. A click in that area (on a link or even on the message background) seems to "pass through" to the Inbox and select a different message instead of being received by the currently displayed message. It doesn't happen on every message, but once it starts happening, it seems to keep happening. I don't know why. When I switch to the "beta" Outlook design, I cannot replicate this problem. It seems to work fine. Two thoughts: (1) If you have a wide display, you could try using the Reading pane on the right. However, if your display is not wide enough, there will be an inconvenient amount of horizontal scrolling. Also, you see a smaller section of your Inbox. (2) You could try sliding the "Try the beta" switch that appears above the Inbox and see whether that works better for you. Do either of those workarounds help?
jscher2000
  • Top 10 Contributor
7682 solutions 62546 answers

Hi johnparadis74, if you don't like the Reading Pane or Beta, here's another workaround, a settings change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste stylo and pause while the list is filtered

(3) Double-click the layout.css.stylo-blocklist.enabled preference to switch the value from false to true

(4) Double-click the layout.css.stylo-blocklist.blocked_domains preference and set the value to live.com and click OK.

(In the unlikely event that you already had a site listed add ,live.com to the list.)

Then exit/quit Firefox and start it up again to make the change effective.

A real fix is expected in February some time.

Hi johnparadis74, if you don't like the Reading Pane or Beta, here's another workaround, a settings change: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''stylo''' and pause while the list is filtered (3) Double-click the '''layout.css.stylo-blocklist.enabled''' preference to switch the value from false to true (4) Double-click the '''layout.css.stylo-blocklist.blocked_domains''' preference and set the value to '''live''.''com''' and click OK. ''(In the unlikely event that you already had a site listed add ''',live''.''com''' to the list.)'' Then exit/quit Firefox and start it up again to make the change effective. A real fix is expected in February some time.