X
Tap here to go to the mobile version of the site.

Support Forum

a couple of links load every time I start Firefox (ie https://www.shopjustice.com/assets/images/brand-logo.png) how do I stop that?

Posted

Images and sites load when Firefox loads. How do I block these or permanently delete them? https://www.shopjustice.com/assets/images/brand-logo.png https://www.creativeirishgifts.com/images/icon-72x72.png (tab says 404 error but page image doesn't)

Images and sites load when Firefox loads. How do I block these or permanently delete them? https://www.shopjustice.com/assets/images/brand-logo.png https://www.creativeirishgifts.com/images/icon-72x72.png (tab says 404 error but page image doesn't)

Chosen solution

Here are a few things to check:

Home Page Setting

Does the extra tab appear in a new window? You can open a new window from the menu button or by pressing Ctrl+n.

If an extra tab appears in every new window, it might have been saved with your home page -- Firefox can show multiple tabs as your home pages. This article has more information on updating your home page setting: How to set the home page.

If you change that and test it out in a new window, does that work?

Does it stay fixed the next time you exit Firefox and start it up again?


If the extra tab only appears in the first window when you start Firefox, please check:

(1) Could an extension be at fault?

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

(2) Could your Firefox shortcut/icon be hijacked?

The Firefox icon can be set up to launch specific pages at startup (or more specifically, when you use the icon). To check whether that is set:

First, open the shortcut as follows:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On Windows, that usually is no more and no less than the following (depending on 32-bit/64-bit):

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
"C:\Program Files\Mozilla Firefox\firefox.exe"

If anything follows after that, try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your home page. Either:

  • double-click desktop shortcut
  • right-click pinned taskbar icon, click Mozilla Firefox

Success?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

WestEnd
  • Top 10 Contributor
51 solutions 2486 answers

That comes from sites you go to not from FF.

That comes from sites you go to not from FF.
Was this helpful to you? 0
Quote

Question owner

Thank you, Westend, but why do they load and how do I get rid of them?

Thank you, Westend, but why do they load and how do I get rid of them?
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Chosen Solution

Here are a few things to check:

Home Page Setting

Does the extra tab appear in a new window? You can open a new window from the menu button or by pressing Ctrl+n.

If an extra tab appears in every new window, it might have been saved with your home page -- Firefox can show multiple tabs as your home pages. This article has more information on updating your home page setting: How to set the home page.

If you change that and test it out in a new window, does that work?

Does it stay fixed the next time you exit Firefox and start it up again?


If the extra tab only appears in the first window when you start Firefox, please check:

(1) Could an extension be at fault?

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

(2) Could your Firefox shortcut/icon be hijacked?

The Firefox icon can be set up to launch specific pages at startup (or more specifically, when you use the icon). To check whether that is set:

First, open the shortcut as follows:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On Windows, that usually is no more and no less than the following (depending on 32-bit/64-bit):

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
"C:\Program Files\Mozilla Firefox\firefox.exe"

If anything follows after that, try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your home page. Either:

  • double-click desktop shortcut
  • right-click pinned taskbar icon, click Mozilla Firefox

Success?

Here are a few things to check: '''''Home Page Setting''''' Does the extra tab appear in a new window? You can open a new window from the menu button or by pressing Ctrl+n. If an extra tab appears in every new window, it might have been saved with your home page -- Firefox can show multiple tabs as your home pages. This article has more information on updating your home page setting: [[How to set the home page]]. If you change that and test it out in a new window, does that work? Does it stay fixed the next time you exit Firefox and start it up again? ---- If the extra tab only appears in the first window when you start Firefox, please check: '''(1) Could an extension be at fault?''' You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement? '''(2) Could your Firefox shortcut/icon be hijacked?''' The Firefox icon can be set up to launch specific pages at startup (or more specifically, when you use the icon). To check whether that is set: First, open the shortcut as follows: * Desktop shortcut: right-click the icon, choose Properties * Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab. You'll see the Target highlighted. On Windows, that usually is no more and no less than the following (depending on 32-bit/64-bit): "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" "C:\Program Files\Mozilla Firefox\firefox.exe" If anything follows after that, try clearing it out. After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your home page. Either: * double-click desktop shortcut * right-click pinned taskbar icon, click Mozilla Firefox Success?
Was this helpful to you? 1
Quote

Question owner

Something helped. Had already checked addons and shortcut and homepage, but "dismissed" the offending items. they did not reload upon restart. Thanks!

Something helped. Had already checked addons and shortcut and homepage, but "dismissed" the offending items. they did not reload upon restart. Thanks!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.