X
Tap here to go to the mobile version of the site.

Support Forum

<body> on some websites is rendered with wrong color.

Posted

For some reason Firefox displays the <body> element of many websites in a wrong color.

Take a look on this website: http://xcmag.com/magazine-articles/mastering-paragliding-the-45-degree-rule/

I have attached a screenshot of Firefox and Chrome side-by-side showing the same page. Note that the problem persists in most other websites (it is not the specific to have problem).

I tried to start Firefox in safe mode, but the problem persists. i tried to disable any themes, but still the same. I also made sure that the default theme is selected. On other machines with Firefox the problem does not happen.

I tried to move my profile folder to another machine and the problem was also moved! So something I guess is wrong with my profile?

Any ideas on how to fix this?

For some reason Firefox displays the <body> element of many websites in a wrong color. Take a look on this website: http://xcmag.com/magazine-articles/mastering-paragliding-the-45-degree-rule/ I have attached a screenshot of Firefox and Chrome side-by-side showing the same page. Note that the problem persists in most other websites (it is not the specific to have problem). I tried to start Firefox in safe mode, but the problem persists. i tried to disable any themes, but still the same. I also made sure that the default theme is selected. On other machines with Firefox the problem does not happen. I tried to move my profile folder to another machine and the problem was also moved! So something I guess is wrong with my profile? Any ideas on how to fix this?
Attached screenshots

Additional System Details

Application

  • Firefox 57.0
  • User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
  • Support URL: https://support.mozilla.org/1/firefox/57.0/Linux/en-US/

Extensions

  • Adblock Plus 3.0.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • GNOME Shell integration 8.2.1 (chrome-gnome-shell@gnome.org) (Inactive)
  • New Tab Homepage 0.6.2 ({66E978CD-981F-47DF-AC42-E3CF417C1467}) (Inactive)
  • Undo Closed Tabs Button 4.0.1 (undoclosedtabsbutton@supernova00.biz) (Inactive)
  • Wikiwand: Wikipedia Modernized 5.0.0 (jid1-D7momAzRw417Ag@jetpack) (Inactive)
  • YoutubeMp3 1.0 (@addonharmali) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce GTX 1070/PCIe/SSE2
  • adapterDeviceID: GeForce GTX 1070/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • crashGuards: []
  • driverDate:
  • driverVersion: 4.6.0 NVIDIA 387.22
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 4
  • offMainThreadPaintEnabled: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4259 solutions 59628 answers

Helpful Reply

I opened the webpage using Firefox 54 and 57. There was no problem. I called for more help.

I opened the webpage using Firefox 54 and 57. There was no problem. I called for more help.
cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

Not all pages specify both text and background color.

Did you make changes to the default color settings?

  • Options/Preferences -> General: Fonts & Colors -> Colors
Not all pages specify both text and background color. Did you make changes to the default color settings? *Options/Preferences -> General: Fonts & Colors -> Colors

Question owner

No I haven't changed anything in color settings.

Just cross checked it.

No I haven't changed anything in color settings. Just cross checked it.
cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

It could be something that Fedora ads to is own branded Firefox version. I vaguely remember having seen another question about color issues also on a Fedora Firefox build.

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

It could be something that Fedora ads to is own branded Firefox version. I vaguely remember having seen another question about color issues also on a Fedora Firefox build. Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.