Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Just udated firefox. It is no more speaking french but turned back to english. What can I do ?

  • 1 reply
  • 2 have this problem
  • 5 views
  • Last reply by FredMcD

more options

When searching in options, I found out how to translate web pages : not what I want. I want my Browser to speak french again. It did before the automatic update. How can I turn French release on ?

When searching in options, I found out how to translate web pages : not what I want. I want my Browser to speak french again. It did before the automatic update. How can I turn French release on ?

All Replies (1)

more options

Get the full installer from; Download Firefox For All languages And Systems {web link}