X
Tap here to go to the mobile version of the site.

Support Forum

Version 57 how do I get a menu bar?

Posted

Tried to find answer. Couldn't.

Tried to find answer. Couldn't.
Attached screenshots

Chosen solution

Who set up this Firefox? Your toolbar icons are definitely non-standard.

I'm going to suggest creating a new profile.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it. Hopefully the address bar works!

Click the Create a New Profile button, then click Next. Assign a name like Jan2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Firefox may invite you to make privacy settings changes, or approve extensions. But the key thing is to try out the interface and see whether you can call up a toolbar list.

Any improvement?

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

More Information

FredMcD
  • Top 10 Contributor
4267 solutions 59836 answers

Press the <Alt> key.

Press the <Alt> key.

Question owner

That was already suggested by several ... but ... Pressing the alt key does NOTHING!

That was already suggested by several ... but ... Pressing the alt key does NOTHING!
FredMcD
  • Top 10 Contributor
4267 solutions 59836 answers

<Alt> is the default key. Also, try <F10>.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

<Alt> is the default key. Also, try <F10>. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Hmm, what are those interesting icons at the left end of your tab bar?

Normally, you can turn different bars on and off from the toolbar list. To show the list, either:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Show/Hide Toolbars (see: Customize Firefox controls, buttons and toolbars)

To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list. Repeat to turn it off.

Does that work?

Hmm, what are those interesting icons at the left end of your tab bar? Normally, you can turn different bars on and off from the toolbar list. To show the list, either: * right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars<br><em>On Windows, tap the Alt key to activate the menu bar temporarily.</em> * in Customize mode > Show/Hide Toolbars (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list. Repeat to turn it off. Does that work?
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Are you using a userChrome.css file to modify your toolbar area? In that case, you may need to check the file for possibly conflicting rules that block the menu bar.

Are you using a userChrome.css file to modify your toolbar area? In that case, you may need to check the file for possibly conflicting rules that block the menu bar.

Question owner

jscher2000 said

Hmm, what are those interesting icons at the left end of your tab bar? Normally, you can turn different bars on and off from the toolbar list. To show the list, either:
  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Show/Hide Toolbars (see: Customize Firefox controls, buttons and toolbars)
To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list. Repeat to turn it off. Does that work?

No list, no 'customize' option, no menu bar, no toolbar, no right click action, etc. etc. I've got a clean win10 install .... and maybe a beta version of v57.*.*? (can't even see where to click to see which version I have). Tearing my hair out here! Doesn't someone from Firefox monitor this forum?

''jscher2000 [[#answer-1058811|said]]'' <blockquote> Hmm, what are those interesting icons at the left end of your tab bar? Normally, you can turn different bars on and off from the toolbar list. To show the list, either: * right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars<br><em>On Windows, tap the Alt key to activate the menu bar temporarily.</em> * in Customize mode > Show/Hide Toolbars (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list. Repeat to turn it off. Does that work? </blockquote> No list, no 'customize' option, no menu bar, no toolbar, no right click action, etc. etc. I've got a clean win10 install .... and maybe a beta version of v57.*.*? (can't even see where to click to see which version I have). Tearing my hair out here! Doesn't someone from Firefox monitor this forum?
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Chosen Solution

Who set up this Firefox? Your toolbar icons are definitely non-standard.

I'm going to suggest creating a new profile.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it. Hopefully the address bar works!

Click the Create a New Profile button, then click Next. Assign a name like Jan2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Firefox may invite you to make privacy settings changes, or approve extensions. But the key thing is to try out the interface and see whether you can call up a toolbar list.

Any improvement?

Who set up this Firefox? Your toolbar icons are definitely non-standard. I'm going to suggest creating a new profile. Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Hopefully the address bar works! Click the Create a New Profile button, then click Next. Assign a name like Jan2018, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Set as default profile''' button below that profile, then scroll back up and click the '''Restart normally''' button. (There are some other buttons, but please ignore them.) Firefox should exit and then start up using the new profile, which will just look brand new. Firefox may invite you to make privacy settings changes, or approve extensions. But the key thing is to try out the interface and see whether you can call up a toolbar list. Any improvement?
FredMcD
  • Top 10 Contributor
4267 solutions 59836 answers

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

This will show us your system details. No Personal Information Is Collected.

Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Now in the Reply Box on the forum page, do a right-click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.'''
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems