Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New FireFox

  • 10 replies
  • 3 have this problem
  • 38 views
  • Last reply by fattyma1973

more options

The new Firefox release is depressingly slow. When I click on a Tab a blue circle keeps moving back and forth hypnotically instead of either opening a new tab or displaying a previously opened tab immediately. I use AOL and again I am experiencing problems after replying to 2-3 emails, AOL hangs. I should not have to keep using about:support to refresh Firefox - which does work. I am currently writing from IE since I cannot use Firefox.

All Replies (10)

more options

What's your computer system and Firefox version?

Is it you have a hard time getting to all websites, some, a few? Or is there no connection to anything outside the browser?

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

I am using: Windows 8.1 Firefox Quantum 57.0.4 AOL

I tried what you suggested and it seemed to work better for a few hours. However, it still does not immediately load the tabs when i click on them particularly if I leave my computer and return to it. The slowest windows to load are from my AOL emails. Any other suggestions please?

more options

go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with.

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow said

go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

This helped and when I changed it initially I was overwhelmed by the speed of Firefox. I still get problems with the first tab loading and have to select the 2nd tab. However, the Tabs do now load immediately. Thanks

more options

How was your FF upgrade or reinstalled? Was it x86 before going x64? What version of O/S are you using x86 or x64? This makes a difference when you doing a Online upgrade. Why so, everything before if it was x86 is not transferred to the x64 install and the previous version isn't removed there is a high chance it didn't properly remove all artifacts from previous FF that could lead to Browser problems. This is what I saw from my experiences when compared to upgrading to a removing and clearing of any old FFx86 version before going to FFx64 version. After doing the right installation did I not have any FF problems.

more options

Seems to be getting worse - loading new tabs and previously opened ones is like watching paint dry. My FF was an upgrade. Not sure whether it was x86 since I do not remember which version I upgraded from. I think it was the latest version before this one since it use to auto update. I am running windows 8.1 x64. Should I remove FF and then re-install it?

more options

Many have reported issues using the 64bit Firefox. Install the 32bit version from; Download Firefox For All languages And Systems {web link}

more options

FredMcD said

Many have reported issues using the 64bit Firefox. Install the 32bit version from; Download Firefox For All languages And Systems {web link}

do I need to remove the current version. Also how do I import all my bookmarks to the 32 bit version?

more options

Firefox comes in two or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.

more options

I have just looked in my Program and Features and I have installed:

Firefox 58 (x64) and Firefox 56 (x86). I guess this is the reason it is not working correctly. I am going to remove Firefox 56 and see if it works correctly after that.