Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't go into general settings

  • 23 replies
  • 1 has this problem
  • 24 views
  • Last reply by nishkle

more options

as the title says, i can't access the general settings. im running 57, but this problem is also on 56. i've refreshed, uninstalled and reinstalled a bunch, run in safe mode, went back to 55 when the settings were different but nothing has helped. i haven't messed with any of the files to cause this. none of the other threads have helped. thanks

All Replies (20)

more options

Separate Security Issue: Update your Flash Player Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 28.0.0.126

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Please explain the problem in detail. What happens? Error messages?

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD said

Please explain the problem in detail. What happens? Error messages? Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

what happens is that the general settings tab is just whats in the search settings tab. and safe mode doesnt do anything

more options

FredMcD said

Separate Security Issue: Update your Flash Player Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox). Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: Version 28.0.0.126 https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

updated flash and it didnt do anything

more options

Try doing it this way : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 57.0.3 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow said

Try doing it this way : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 57.0.3 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.

still doesn't work

more options

Create a new profile as a TESTt to check if your current profile is causing the problem.

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem. Never work with original files.

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow said

Create a new profile as a TESTt to check if your current profile is causing the problem. If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem. Never work with original files. Please let us know if this solved your issue or if need further assistance.

created the new profile and the problem is still there

more options

Very strange. Type about:preferences<enter> in the address bar

more options

FredMcD said

Very strange. Type about:preferences<enter> in the address bar

still shows the search thing

more options

Many have reported issues using the 64bit Firefox. Install the 32bit version from; Download Firefox For All languages And Systems {web link}

more options

One moment. The picture shows you are on the options/preferences page.

more options

FredMcD said

One moment. The picture shows you are on the options/preferences page.

yeah, i can get to the option page, just not the general tab. also 32bit didnt work

more options

This image says you are running Nightly (test version of Firefox 59) with automatic private browsing:

Does that sound right?

more options

What options/preference are you looking for?

more options

FredMcD said

What options/preference are you looking for?

nothing in particular, i just think i should be able to go into my settings

more options

jscher2000 said

This image says you are running Nightly (test version of Firefox 59) with automatic private browsing: Does that sound right?

i am using nightly, but i found it when i was first using the regular version (happens in both. don't think im using automatic private browsing

more options

nishkle said

i am using nightly, but i found it when i was first using the regular version (happens in both. don't think im using automatic private browsing

Under Privacy & Security > History, you can check that. Either of these would cause that message:

  • Firefox will "Never remember history" OR
  • Firefox will "Use custom settings for history" PLUS "Always use private browsing mode"
more options

jscher2000 said

nishkle said
i am using nightly, but i found it when i was first using the regular version (happens in both. don't think im using automatic private browsing

Under Privacy & Security > History, you can check that. Either of these would cause that message:

  • Firefox will "Never remember history" OR
  • Firefox will "Use custom settings for history" PLUS "Always use private browsing mode"

i have remember history on

more options

Note if you've used a profile with a Nightly build then it isn't save to use it with an older Firefox version like the current release. You always need to use separate profiles with each Firefox version and with a Nightly alpha build this is even more important.

Try to start Firefox in Safe Mode to see if that works.

  • Windows: hold down the Shift key while starting Firefox
  • Mac: hold down the Options key while starting Firefox

You may not be able to open the General tab because some settings can't be resolved like hardware acceleration.

  1. 1
  2. 2