Search Support

Despite trying all of the solutions suggested on the Support site, Firefox consistently monopolises 99% of memory.

more options

Firefox consistently monopolises 99% of memory (except, inexplicably, whenever I am on a Mozilla Support page).

I have tried all of the solutions suggested on the Support site (disabled all add-ons, run in Safe mode, uninstalled – then re-installed latest version of Firefox) but all to no avail. When left unattended for an hour or more, Firefox crashes. I use Windows XP, have an up-to-date Norton anti-virus protection and do not use Pocket.

All Replies (16)

more options

oops.....

Modified by Shadow110

more options

Not sure at all but please check as something I read said they might be turned on : You can disable multi-process windows in Firefox by setting these prefs to false on the Copy/Paste to Address Bar about:config then Enter. Copy/Paste 1 at a time below into the search in the new window. With out false. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://kb.mozillazine.org/about:config Also can reverse everything this tells you to enable it. http://www.ghacks.net/2016/07/22/multi-process-firefox/

more options

Thank you very much for your prompt reply.

browser.tabs.remote.autostart was already "false", but I have now changed browser.tabs.remote.autostart.2 to "false"

Let's see whether this solves the problem.

Again, with very sincere thanks

more options

To Pkshadow

Your message (received via email, but which does not appear in this tread) suggested that I:

please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

In my (recently re-installed) version of Firefox, Privacy and Security are separate panels, neither of which include "Permissions", and so I cannot see how to "check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser". See the attached screenshots.

more options

I am now on the verge of uninstalling Firefox and moving (reluctantly) to another browser.

I have tried all of the measures suggested by the various contributors:

  • refreshed
  • disabled all add-ons,
  • run in Safe mode,
  • uninstalled – then re-installed latest version of Firefox
  • browser.tabs.remote.autostart was already "false", but have now also changed browser.tabs.remote.autostart.2 to "false"

all to no avail.

Firefox continues to monopolise 99% of my CPU, making it impossible to work on anything else.

Further, when left unattended for an hour or more, Firefox crashes.

I use Windows XP, have an up-to-date Norton anti-virus protection and do not use Pocket.

Can anyone suggest any other solution before I (reluctantly) turn my back on Firefox for good?

more options

Hi, I would think a Admin deleted my post due to wrong directions for your version.

You may as well start figuring something out now as there will be no browsers available for XP soon. https://support.mozilla.org/en-US/kb/end-support-windows-xp-and-vista

Try uninstalling this way : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's(WIn10)) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 52.7.3ESR with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow

Thank you very much for your continued efforts to resolve my difficulty.

I followed the instructions in your most recent -- except that:

1. after uninstalling Firefox, there were no Mozilla Firefox folders in C:\Program Files, C:\Program Files(x86) or & C:\ProgramData)

and,

2. after restarting the system and after running Windows Disk Cleanup, there is no button "Cleanup System Files" (see attached screenshot). Perhaps that is not a Windows XP feature.

I then installed the full version of the Current Release Firefox 52.7.3ESR

Even after all this, Firefox still monopolises 99% of my CPU, except -- as noted in my earliest post, and this is just bizarre -- when I am on any Mozilla page such as this one.

Is there anything else you can suggest?

With very sincere thanks for your ongoing efforts,

Rutherford2017

more options

Are you options to see any hidden folder and files are turned off just incase something is there that was missed?

more options

I apologise, but I don't understand your question.

Are you referring to the results of a search ("options to see any hidden folder and files")?

What search? Search for what?

Please explain.

With very sincere thanks for your time.

more options

Forgive my brain fart. You were referring to the search of C:\Program Files for C:\Program Files(x86) & C:\ProgramData

No. The options to see any hidden folder and files is not turned off.

Sorry.

more options

Here's a try uninstall all of Norton and use the Norton cleaner to remove it all. Then uninstall all FF and delete any Mozilla folders. But as you do this save your bookmarks if you have any and write down your Addon/Extension so you can find them to install later. After this reboot and download FF from here that matches your O/S version if x64 get FFx64 not FFx86 unless your O/S is x86 then get FFx86 latest version.

https://www.mozilla.org/en-US/firefox/all/

Reinstall slowly and read what is being installed so you know if you want those options or not "Choose custom install" for FF when doing so. And after this set your HomePage and close and load FF again and go to a trusted page and see what happens. If not thing slowing install your Addons but leave Norton out. My personal experience it hurts more then it helps if your XP get MSE that is free from Microsoft and works far better in my Opinion. And see how that goes.

more options

Thank you very much for your continued assistance.

I will do as you suggest at the end of the week (I am an academic working from home for the next couple of days) and then let you know what happens.

R2017

more options

Hi, Norton A/V or products do not cause issues with Firefox, as far as I am concerned ever since I have been using them since before Win95 and have been a Norton Beta Tester for many years.

You may want to Click Help then About in Norton then look up that version to make sure it is compatible though.

Below is just in case Norton has missed something. Please do a scan of your system as there maybe malware causing Firefox to go off like that. Bitcoin Mining software can do that and some sites have had issues and some sites do not tell you that while there they will use you.

If running Windows XP (Service Pack 2 or later, 32-bit only) please grab this : https://www.malwarebytes.com/mwb-intercept/ and https://www.superantispyware.com/portablescanner.html lastly https://www.bleepingcomputer.com/download/tdsskiller/ If need help the last one has a Windows Forum.

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow

Thank you very much for jumping in with your assurance (that Norton A/V or products do not cause issues with Firefox). This will save me from the time-consuming (and potentially dangerous) steps recommended by WestEnd (to uninstall all of Norton and use the Norton cleaner to remove it all. Then uninstall all FF and delete any Mozilla folders).

I will do as you suggest (but over the weekend, as I am in the middle of marking dissertations) and let you know whether your recommended actions finally resolve the problem. (I really don't want to change to a different browser -- but at the same time, I cannot go on like this.)

more options

HI, ya sorry has been a long time since used a version 52 and memory of where things are and changes made now does not help when describe where to go. Unfortunately some info for you : https://support.mozilla.org/en-US/kb/end-support-windows-xp-and-vista

Note no other browsers support XP.

more options

Pkshadow,

Thank you again for your perseverance.

A (Norton) scan of my system showed no malware.

I have never used (or even visited the site of) Bitcoin.

I am running Windows XP (Service Pack 2, 32-bit) and so downloaded and ran https://www.malwarebytes.com/mwb-intercept/ and https://www.superantispyware.com/portablescanner.html and https://www.bleepingcomputer.com/download/tdsskiller/

None of which indicated any significant issues (although a few items were quarantined).

Firefox sill continues to monopolise 94-99% of CPU.

Sigh.

Is there anything else you can suggest?

With very sincere thanks,