X
Tap here to go to the mobile version of the site.

Support Forum

stuttering, then buffering, then halts on Youtube

Posted

Hello, I'm sure I won't be the first or last to report this, but after having to switch to Firefox from the youtube app built into firestick tv, the browser just isn't working when playing YouTube videos. Reading the reviews it seems a lot of people have the same issues.

It starts ok, then after a few minutes it starts lagging, then you get the buffering icon, then the buffering icon doesn't go away and halts the display and trying to quit the app takes a few minutes.

This is not my wifi. Netflix, Amazon Prime, old youtube app, all stream perfectly. In fact, I've moved over to Kodi and their built in Youtube app works perfectly.

This fault happens with the Silk browser too. I know they are different rendering engines, but they do seem to share a common theme of being run from within a browser...

I'm sure this fault is logged somewhere already, but is there likely to be a fix for this because Kodi is clunky to use?

Hello, I'm sure I won't be the first or last to report this, but after having to switch to Firefox from the youtube app built into firestick tv, the browser just isn't working when playing YouTube videos. Reading the reviews it seems a lot of people have the same issues. It starts ok, then after a few minutes it starts lagging, then you get the buffering icon, then the buffering icon doesn't go away and halts the display and trying to quit the app takes a few minutes. This is not my wifi. Netflix, Amazon Prime, old youtube app, all stream perfectly. In fact, I've moved over to Kodi and their built in Youtube app works perfectly. This fault happens with the Silk browser too. I know they are different rendering engines, but they do seem to share a common theme of being run from within a browser... I'm sure this fault is logged somewhere already, but is there likely to be a fix for this because Kodi is clunky to use?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.108 Safari/537.36

More Information

Seburo
  • Top 10 Contributor
  • Moderator
862 solutions 6439 answers

Hi

Thank you for reporting this and for confirming that Silk has the same issue.

I have contacted one of the developers for Firefox for Fire TV who has confirmed that this may be an issue with the underlying technology used by both browsers and that this is currently being looked into as an outstanding issue.

Hi Thank you for reporting this and for confirming that Silk has the same issue. I have contacted one of the developers for Firefox for Fire TV who has confirmed that this may be an issue with the underlying technology used by both browsers and that this is currently being looked into as an outstanding issue.