X
Tap here to go to the mobile version of the site.

Support Forum

costomised toobars

Posted

The "Refresh Firefox - reset add-ons and settings" article does not whether customised toolbars are removed or retained in a "Refresh".

The "Refresh Firefox - reset add-ons and settings" article does not whether customised toolbars are removed or retained in a "Refresh".

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Pkshadow
  • Top 10 Contributor
915 solutions 11890 answers

Removed. Try:

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST If issues still : Can try this instead (though Refresh fixes other issues) : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer

Create a new profile as a test to check if your current profile is causing the problem.

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem. Never work with original files.

fyi: https://www.howtogeek.com/334716/how-to-customize-firefoxs-user-interface-with-userchrome.css/ http://techdows.com/2017/09/classic-theme-restorer-userchrome-css-modify-firefox-57-photon-ui.html

Please let us know if this solved your issue or if need further assistance.

Removed. Try: *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected TEST If issues still : Can try this instead (though Refresh fixes other issues) : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Create a new profile as a test to check if your current profile is causing the problem. *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem. Never work with original files. *https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox fyi: https://www.howtogeek.com/334716/how-to-customize-firefoxs-user-interface-with-userchrome.css/ http://techdows.com/2017/09/classic-theme-restorer-userchrome-css-modify-firefox-57-photon-ui.html Please let us know if this solved your issue or if need further assistance.
jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

Did you want to mention why you are considering using the Refresh feature?

Did you want to mention why you are considering using the Refresh feature?

Question owner

Firefox is running slow.

Firefox is running slow.
Pkshadow
  • Top 10 Contributor
915 solutions 11890 answers

go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with.

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Please let us know if this solved your issue or if need further assistance.

go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with. Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance.

Question owner

I have isolated the problem to having too many tabs open.

I have isolated the problem to having too many tabs open.
Pkshadow
  • Top 10 Contributor
915 solutions 11890 answers

dforrest said

I have isolated the problem to having too many tabs open.

Really need to expand on the issue or would have had you do this as some people run with 100's of tabs open.

Go to the Firefox 3 Bar Menu --> Help ? --> Troubleshooting Information Page and take a look in the Accessibility section if accessibility is set to "true" there. if yes, go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to.

Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Please let us know if this solved your issue or if need further assistance.

''dforrest [[#answer-1057156|said]]'' <blockquote> I have isolated the problem to having too many tabs open. </blockquote> Really need to expand on the issue or would have had you do this as some people run with 100's of tabs open. Go to the Firefox 3 Bar Menu --> Help ? --> Troubleshooting Information Page and take a look in the Accessibility section if accessibility is set to "true" there. if yes, go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check the setting to Prevent Accessibility Services from accessing your browser. Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to. Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance.

Helpful Reply

Thanks again. I have seven tabs.

All but performance setting were set as you recommended. I have lowered this to 2.

There is no improvement.

Thanks again. I have seven tabs. All but performance setting were set as you recommended. I have lowered this to 2. There is no improvement.
Pkshadow
  • Top 10 Contributor
915 solutions 11890 answers

dforrest said

Thanks again. I have seven tabs. All but performance setting were set as you recommended. I have lowered this to 2. There is no improvement.

Change to 1 then. That is what older Firefox is using. Giving system info on how much ram you have and what processor you are using would also be helpful.

Can keep track of things in the Task Manager it might be a better way of noting improvement by saying how many megs/gigs of ram and what % of the CPU it is using so we know and can figure out if is normal usage.

Each extension you use takes 20megs give or take. No mention of what you use. Some people run a hundred, As to why I do not know. info :

Please let us know if this solved your issue or if need further assistance.

''dforrest [[#answer-1057230|said]]'' <blockquote> Thanks again. I have seven tabs. All but performance setting were set as you recommended. I have lowered this to 2. There is no improvement. </blockquote> Change to 1 then. That is what older Firefox is using. Giving system info on how much ram you have and what processor you are using would also be helpful. Can keep track of things in the Task Manager it might be a better way of noting improvement by saying how many megs/gigs of ram and what % of the CPU it is using so we know and can figure out if is normal usage. *https://support.microsoft.com/en-ca/help/15055/windows-7-optimize-windows-better-performance Each extension you use takes 20megs give or take. No mention of what you use. Some people run a hundred, As to why I do not know. info : *https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster *https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix *https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram *https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding Please let us know if this solved your issue or if need further assistance.