X
Tap here to go to the mobile version of the site.

Support Forum

updates cause system to bog down from non-administrator accounts

Posted

My wife's account on her Windows 7 PC is a non-administrator account. When Firefox detects an update, it consistently misbehaves. It appears to consume an excessive amount of resources and the machine is almost unusable. I have to login to my administrator-level account and update Firefox. This usually resolves the issue until the next update, but today it's not. I can only seem to launch Firefox as an administrator.

Can you please fix Firefox so that it doesn't even try to update itself from a non-administrator account?

I never run into this problem when logged on as an administrator. It makes me wonder how this works on Unix/Linux when not running as root.

My wife's account on her Windows 7 PC is a non-administrator account. When Firefox detects an update, it consistently misbehaves. It appears to consume an excessive amount of resources and the machine is almost unusable. I have to login to my administrator-level account and update Firefox. This usually resolves the issue until the next update, but today it's not. I can only seem to launch Firefox as an administrator. Can you please fix Firefox so that it doesn't even try to update itself from a non-administrator account? I never run into this problem when logged on as an administrator. It makes me wonder how this works on Unix/Linux when not running as root.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.84 Safari/537.36

More Information

Shadow110 1072 solutions 14836 answers

Updates are important.

go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with.

Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.


Please let us know if this solved your issue or if need further assistance.

Updates are important. go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with. Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Please let us know if this solved your issue or if need further assistance.