Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On start of Firefox I have network activity 100% of the time?

more options

I have recently discovered that when I start Firefox I also start getting network activity that continues as long as I am in Firefox even if I just start the application and let it sit doing nothing. I then decided to check if Edge did the same thing and it does not. When I first start Edge there is some network activity to bring up the "Home" page and then the network activity stops and sits idle.

NOTE: I am sending this post via Edge so I don't have the continued network activity which I am concerned may be a virus of some sort.

Bob Roddy

I have recently discovered that when I start Firefox I also start getting network activity that continues as long as I am in Firefox even if I just start the application and let it sit doing nothing. I then decided to check if Edge did the same thing and it does not. When I first start Edge there is some network activity to bring up the "Home" page and then the network activity stops and sits idle. NOTE: I am sending this post via Edge so I don't have the continued network activity which I am concerned may be a virus of some sort. Bob Roddy

All Replies (1)

more options

Hi Bob, could you try starting Firefox in its Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Also, this article describes the expected connections, which should be few and far between: How to stop Firefox from making automatic connections.