Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Please add Warning for NOT Compatible addons PRIOR to updating, Plus Previous Version Fallback Option.

  • 2 replies
  • 1 has this problem
  • 52 views
  • Last reply by flatform

more options

You should add a popup warning, if some addons are not compatible withi new version of firefox, prior to the update:

ie. (Popup Message) Firefox 57.0.2 update: Some of your add-ons are not compatible with the new version, continue with update? YES NO Manage Addons.

This is a serious issue for professional or personal use. Download queues, professional add-ons/readers etc.

This issue must be resolved in next version of Firefox, it has been extremely annoying for years now, as all automatic updating with no meaninfull user prompts.

In any case, an easy way to FALLBACK to previous version of Firefox wew be appreciated, as well.

Thank you in advance, Thank you for developing Mozilla Firefox.

Chosen solution

Hi,

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.

I was going to suggest filing a bugzilla report but a similar request was made long ago. See Bug 468072 - Check add-on compatibility *BEFORE* running automatic updates Status: RESOLVED WONTFIX

(See Bugzilla Etiquette before commenting in bug reports.)

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected by a team of people who read it and gather data about the most common issues.

As for incompatible add-ons, see Firefox add-on technology is modernizing and Frequently asked questions - Firefox add-on technology is modernizing.

If you have important add-ons that aren't compatible with the latest Firefox update and you can't find a replacement, you can downgrade Firefox to a previous version as a last resort. See Install an older version of Firefox for details.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Hi,

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.

I was going to suggest filing a bugzilla report but a similar request was made long ago. See Bug 468072 - Check add-on compatibility *BEFORE* running automatic updates Status: RESOLVED WONTFIX

(See Bugzilla Etiquette before commenting in bug reports.)

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected by a team of people who read it and gather data about the most common issues.

As for incompatible add-ons, see Firefox add-on technology is modernizing and Frequently asked questions - Firefox add-on technology is modernizing.

If you have important add-ons that aren't compatible with the latest Firefox update and you can't find a replacement, you can downgrade Firefox to a previous version as a last resort. See Install an older version of Firefox for details.

more options

Thanks Alice, checking.