Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Default search engine keeps defaulting to Bing.

  • 8 replies
  • 196 have this problem
  • 31673 views
  • Last reply by SHempsey

more options

I've been scouring the internet for a few days now looking for a solution as to how to permanently remove Bing as my default browser, but none of them have worked. Every time I open Nightly, I go to options, and check to see the default search engine. It's always Bing. So I delete Bing, and change it to Google. Well, when I close the browser, I have a nice surprise waiting for me. Bing.

I've spent almost all day scanning my computer with different anti-virus/malware programs, deleted several viruses (hopefully there aren't any more), and it still happens. I've started Nightly in safe mode with all of the add-ons off, and it still happens. Went to about:config, prefs.js, user.js, and searched for invalidprefs.js (and so on), and nothing worked.

One thing I've noticed, is after having refreshed Nightly (I don't want to go through the whole changing my settings and customization thing again, so no screenshots), the list of browsers had Bing twice. One on top (the one that comes with the browser), and one on bottom (the one that keeps getting added). For this reason, I think it could be malware, or some unwanted program that I, for the life of me, cannot find in file explorer or control panel.

Any help would be appreciated, as this issue is incredibly infuriating, thank you.

Chosen solution

No it is the updates or install and running a Beta expect the unexpected.

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: SHould be Pinned run weekly, if Never done below, expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer

Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

Read this answer in context 👍 10

All Replies (8)

more options

Chosen Solution

No it is the updates or install and running a Beta expect the unexpected.

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: SHould be Pinned run weekly, if Never done below, expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer

Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

more options

It worked! Thank you!

more options

Thanks for this fix on this it was a huge pain in the ass!!!!!!!!!!!!!!

Modified by SHempsey

more options

On my computer it looked like it was a problem made by a lavasoft ad-aware update. I removed 2 files: dsengine.cfg en dsengine.js. from the program files (x86) folder/Mozilla Firefox (root and folder defaults) , put the preferences like homepage back to my preferences and bing was gone en didn't return. Regards, Peter

more options

For me it was a file called "dsengine.cfg" setting the default search engine to bing. So if anyone still has the same problem caused by this file: It should be located in your main directory of your firefox installation. Just delete it, and you should be happy ;)

more options

Hi Sleage, also look for this because otherwise there may be problems on your next Firefox startup:

  • C:\Program Files\Mozilla Firefox\defaults\pref\dsengine.js -- or --
  • C:\Program Files (x86)\Mozilla Firefox\defaults\pref\dsengine.js
more options

jscher2000 said

Hi Sleage, also look for this because otherwise there may be problems on your next Firefox startup:
  • C:\Program Files\Mozilla Firefox\defaults\pref\dsengine.js -- or --
  • C:\Program Files (x86)\Mozilla Firefox\defaults\pref\dsengine.js

Oh sorry, forgot to mention that one :'D

more options

Here is another one to try:

Internet Explorer:

Homepage: To reset your homepage in Internet Explorer, please follow these steps:

    1. Go into tools > Internet Options
    2. Type the Homepage address you would like to use in the textbox in the homepage section
    3. Click Apply, then click OK

Default Search: To reset your default search in Internet Explorer, please follow these steps:

    1. Go into Tools > Internet Options
    2. Under Search in the General Tab, click Settings
    3. Choose the search provider you wish to use and click Close
    4. Click Apply, then click OK

Firefox:

Homepage: To reset your homepage in Firefox, please follow these steps:

    1. At the top of the Firefox window, click on the Firefox and then click Options
    2. Select the General Panel
    3. Type the Homepage address you would like to use in the textbox in the homepage section
    4. Click OK

Default Search: To reset your default search in Firefox, please follow these steps:

    1. Type about:config in the address bar
    2. Search for browser.search.defaultenginename and double click on it.
    3. Change the value for the Search engine you want
    4. Click OK


..type bing in the search filed and then right clicked, modify anything and everything that says that useless f-ing bing..