Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure Connection Failed + SEC_ERROR_REUSED_ISSUER_AND_SERIAL when accessing google

  • 19 replies
  • 7 have this problem
  • 118 views
  • Last reply by FredMcD

more options

It's been a while now since I randomly started getting the above problem. I've tried the solutions described here: https://cheapsslsecurity.com/blog/troubleshoot-secure-connection-failed-error-firefox/ I've stopped the Kaspersky Internet Security, I've installed and re-installed Firefox, I've tried editing/deleting the damn security ceritficates, mothing worked. And nothing of Firefox's help pages... helped either.

I'm using the latest Firefox, latest KIS version, all the drivers are up-to-date, system (Win 7 64-bit) runs perfectly with no error whatsoever, same for the Inetrnet connection. At this point I'm just about ready to flush Firefox down the drain because of this frustrating problem. It will probably go away after restarting the system, but I don't want to do this at Firefox's notice whenever it feels like it. I just want it to go away period.

Since it looks like it's impossible to attach a simple .jpeg to this message (file keeps loading forever), here's the full text of the error: "Secure Connection Failed An error occurred during a connection to www.google.com. You have received an invalid certificate. Please contact the server administrator or email correspondent and give them the following information: Your certificate contains the same serial number as another certificate issued by the certificate authority. Please get a new certificate containing a unique serial number. Error code: SEC_ERROR_REUSED_ISSUER_AND_SERIAL The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem."

Side note: very funny having to confirm this question by checking my gmail address... which I can't access because of the reasons stated above.

Modified by Rork

All Replies (19)

more options

Rork said

It's been a while now since I randomly started getting the above problem. I've tried the solutions described here: https://cheapsslsecurity.com/blog/troubleshoot-secure-connection-failed-error-firefox/ I've stopped the Kaspersky Internet Security, Side note: very funny having to confirm this question by checking my gmail address... which I can't access because of the reasons stated above.

You have to disable in a step step process to eliminate what might be at the root of the problem to know what else to look.

Modified by WestEnd

more options

Yeah, my bad: I didn't stop it, I disabled it.

more options

With programs like that, there is the toolbar that can do some things, and there is the main program. Disabling the toolbar may not disable the main program.

more options

KIS can be STOPPED from the toolbar and DiSABLED via system restart - that is, if you want to be real thorough. I tried both ways. Also tried once with Kaspersky protection add-on (which is not marked as Legacy) disabled in Firefox. Regardless, KIS always provides notifications when blocking sites. O yea, one more thing, the only Firefox add-on I use is Speed Dial.

more options

Note : Kaspersky and a few others send their own certificate and it is being rejected. See Kaspersky forums.

This seems to work most of the time but nobody likes telling it : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer

Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

more options

Ugh, I can understand why nobody likes this solution. Can anyone guarantee that this bug won't surafce again later, thereby imposing this painful operation again and again?

So Kaspersky and Google send their certificates and Firefox rejects them. Mayhap the problem is with Firefox's certifcates and the way it handles them - just a thought. One observation that might help: sometimes accessing gmail via another search engine (I used Bing) and then accesing a link from a message makes google accessible again. But it doesn't always work.

Well, I already reinstalled from scratch once Firefox, but didn't run twice Windows Disk Cleanup. I daresay it's too much trouble, not to mention risky, as Dick Cleanup is not 100% sure. Instead of putting the entire system through this needless and not-guaranteed-to-work risk, a way simpler solution is using another browser. Still, I wouldn't want to give up on Firefox, so maybe there's another way to go; or this will be fixed in the next Firefox version.

more options

Well in my system I run Defender and Windows Firewall and have no issues with FF57 with Google as the homepage or doing search with google. Is your FF x86 or x64 version that your using on Windows 7?

more options

No Kaspersky sends the certificate to the site and is rejected. Firefox reports that in this case.

Firefox does not accept or reject as a whole unless what comes back is truly reject-able.

Though as said in my possible solution it can just be a file thing and is fixable.

The added URL's for backup and save and every thing is in case something happens to you bookmarks, passwords you do not get angry. As anything can happen, it's a computer.

Or you can play with these : There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites

Please let us know if this solved your issue or if need further assistance.

more options

WestEnd said

Well in my system I run Defender and Windows Firewall and have no issues with FF57 with Google as the homepage or doing search with google. Is your FF x86 or x64 version that your using on Windows 7?

x64, the one without Java support.

more options

Pkshadow said

No Kaspersky sends the certificate to the site and is rejected. Firefox reports that in this case.

It happened with KIS disabled, remember?

Pkshadow said

Though as said in my possible solution it can just be a file thing and is fixable.

My feeling as well :) .

Pkshadow said

The added URL's for backup and save and every thing is in case something happens to you bookmarks, passwords you do not get angry. As anything can happen, it's a computer.

It's not the Firefox backup I'm worried about. The risk with Windows Disk Cleanup is that it might delete files in temp folders which are not supposed to be deleted (yea, I know, a paradox, but there it is, I'm not enough tech savvy to explain it), which leads in errors in registry on startup. Oh, I'm not yet at angry, just working my way through frustration right now :)) .

Pkshadow said

Or you can play with these : There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

I only use KIS, never had any problems with it. Even its adblocker is better than adblock imho.

Pkshadow said

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

Checked all of them, except the add exception option, because adding google as an exception means something is seriously wrong with Firefox. Perhaps I should've been clearer: this problem only ever happens with google or when using google search from the search bar in Firefox's top right corner. And even if said error is present, I can still access every other site as long as I don't get directed to it via google.

Pkshadow said

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

Doesn't apply. I get a specific error message, as can be sen in the title of this thread.

Pkshadow said

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

Done this a while ago, didn't help.

Pkshadow said

http://kb.mozillazine.org/Error_loading_websites

Most of this doesn't apply. I get a specific error, always the same, happens random and not very often. And what I've tried didn't help.

more options

I’d suggest to uninstall Kaspersky, check for the issue (and report back), and then reinstall it. Security software is known to cause isues like these.

more options

Strange that the same security software doesn't cause issues with any other browser, don't you think? Also strange that I never had any problems associated with KIS, except when it comes to working with Firefox - and even those were solved by re-installing Kaspersly certificate. Anyway, if it comes to choosing between KIS and Firefox, the answer is a no-brainer. I'll let you guess it ;) .

more options

Nothing strange when it comes to computing. :) Firefox simply uses a different mechanism with regard to certificate archives (it has its own), hence you can run into issues that you won’t run into with other browsers, and software makers more than once came up with a fix simply because of Firefox. As far as I know, plans for changing this are in the making, but for now you should just take that into account. The easiest way to fix is usually to uninstall such software rather than just disabling it (since the latter may not completelety disable the software or one of its features) or to run Windows in Safe Mode with networking enabled beforehand - the latter may even fix it without any further action. So please do not assume the (or any) suggestion won’t work anyway, just try.

I know people who don’t use any security software at all and guess what, they never suffer these issues with Firefox. ;)

Modified by Tonnes

more options

Yea, sure, uninstall paid software which covers my system's security because the free software has problems with it... and incidentally with other such sofware as well. I know you mean well, but this is a non-solution. And really, uninstalling is a last-resort solution and an easy one to offer when it doesn't involve your own PCand your own time. You can completely disable KIS, not only from its settings, but also from Windows settings; I've done all that, as far as it can be done. The random nature of the Firefox error makes it really difficult to check for long periods of time with KIS completely disabled.

more options

Have you contacted Kaspersky about this?

more options

Once before , some time ago. You can imagine they said it's not their problem, since said problem only happens on Firefox - and they are perfectly right. But once again, since it seems this is turning into a Kaspersky discussion: the bug appeared even with KIS disabled.

more options

Getting this when I try to access pages below the front page at a blog - just started this week. Of course it's the same certificate: they're all the same site. Who do I complain to about their software having a nasty bug? (Yes, Kaspersky. Will whine at them, too.) I DO NOT get the "Advanced" option with this message, so I can't supply certificate data.

Modified by PJEvans

more options

Just a helpful reminder for whatever passes nowadays as Firefox tech support: the problem is still there, even after all the time and updates.

Funny that this happens and http redirects and various pop-ups work just fine with Firefox who doesn't have a simple block site option or something along those lines.

more options

I called for more help.