X
Tap here to go to the mobile version of the site.

Support Forum

Where can I download the libraries required for firefox?

Posted

Where can I download the libraries required for installation of firefox?

Where can I download the libraries required for installation of firefox?

Additional System Details

Installed Plug-ins

  • Gecko Media Player 1.0.8Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer
  • Version: 5.41.0.0
  • Shockwave Flash 10.3 r183

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:51.0) Gecko/20100101 Firefox/51.0 SeaMonkey/2.48

More Information

Pkshadow
  • Top 10 Contributor
1056 solutions 14618 answers

https://support.mozilla.org/en-US/kb/install-firefox-linux

Please let us know if this solved your issue or if need further assistance.

https://support.mozilla.org/en-US/kb/install-firefox-linux Please let us know if this solved your issue or if need further assistance.

Question owner

From that link I got the libraries:

   Firefox will not run at all without the following libraries or packages:
       GTK+ 3.4 or higher
       GLib 2.22 or higher
       Pango 1.14 or higher
       X.Org 1.0 or higher (1.7 or higher is recommended)
       libstdc++ 4.6.1 or higher
   For optimal functionality, we recommend the following libraries or packages:
       NetworkManager 0.7 or higher
       DBus 1.0 or higher
       GNOME 2.16 or higher
       PulseAudio

But where do I get them?

From that link I got the libraries: Firefox will not run at all without the following libraries or packages: GTK+ 3.4 or higher GLib 2.22 or higher Pango 1.14 or higher X.Org 1.0 or higher (1.7 or higher is recommended) libstdc++ 4.6.1 or higher For optimal functionality, we recommend the following libraries or packages: NetworkManager 0.7 or higher DBus 1.0 or higher GNOME 2.16 or higher PulseAudio But where do I get them?
James
  • Top 25 Contributor
  • Moderator
1483 solutions 10299 answers

In your package manager on your not mentioned Linux distro. You should have much to all of the packages already installed as try to make sure you have the versions mentioned at minimum.

Since you are running SeaMonkey 2.48 which has same Gecko as Firefox 51.0 you should be able to run Firefox 57.0.1 from www.mozilla.org/firefox/all/ I believe.

Note you appear to have a rather old version of Flash Player 10.3 as the current is 27.0.0.187 https://get.adobe.com/flashplayer/

In your package manager on your not mentioned Linux distro. You should have much to all of the packages already installed as try to make sure you have the versions mentioned at minimum. Since you are running SeaMonkey 2.48 which has same Gecko as Firefox 51.0 you should be able to run Firefox 57.0.1 from www.mozilla.org/firefox/all/ I believe. Note you appear to have a rather old version of Flash Player 10.3 as the current is 27.0.0.187 https://get.adobe.com/flashplayer/

Question owner

I'm running precise puppy 571, and it is quite old. The package manager usually doesn't have what I want. so I have been manually loading them in. Firefox started freezing on me, so here I am trying to get it working. All I want is the libraries that work with firefox.

I have tried a few versions all give me the same error, which I think is caused by the version of gtk3 I loaded, because there is no guidance so far of how to get the right version or what is the right version.

I just searched for "flash" & "flashplayer" and the 'package manager' gave me nothing.

I'm running precise puppy 571, and it is quite old. The package manager usually doesn't have what I want. so I have been manually loading them in. Firefox started freezing on me, so here I am trying to get it working. All I want is the libraries that work with firefox. I have tried a few versions all give me the same error, which I think is caused by the version of gtk3 I loaded, because there is no guidance so far of how to get the right version or what is the right version. I just searched for "flash" & "flashplayer" and the 'package manager' gave me nothing.