X
Tap here to go to the mobile version of the site.

Support Forum

How can I get rid of the (completely useless and irritating) fullscreen notice in firefox 57

Posted

Every time I switch to full screen in Youtube I get this completely useless message [Youtube is now using the full screen, press esc to leave] To my opinion It is unbelievably irritating, and it is a totally useless function It is like [water is wet] after ONE time you know it. Why is this thing still in firefox? or why isn't there a "don't show this again" checkbox in that full screen notice ? In the previous versions I could switch it off in [about:config] but what ever I do this invernal screen keeps coming and blocks the view for a time.. What do I have to do to get rid of it in firefox 57?

Every time I switch to full screen in Youtube I get this completely useless message [Youtube is now using the full screen, press esc to leave] To my opinion It is unbelievably irritating, and it is a totally useless function It is like [water is wet] after ONE time you know it. Why is this thing still in firefox? or why isn't there a "don't show this again" checkbox in that full screen notice ? In the previous versions I could switch it off in [about:config] but what ever I do this invernal screen keeps coming and blocks the view for a time.. What do I have to do to get rid of it in firefox 57?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Tonnes
  • Top 25 Contributor
  • Locale Leader
245 solutions 1453 answers
  1. In the address bar, type about:config and press Enter.
  2. Accept the risk.
  3. Type full-screen-api.warning.timeout or a part of it.
  4. Right-click the preference, choose Modify and change the value to 0 (zero).
  5. Close the page.

You should no longer see the message. This still works me in 56 and Nightly, so I assume in 57 too.

#In the address bar, type ''about:config'' and press Enter. #Accept the risk. #Type '''full-screen-api.warning.timeout''' or a part of it. #Right-click the preference, choose Modify and change the value to '''0''' (zero). #Close the page. You should no longer see the message. This still works me in 56 and Nightly, so I assume in 57 too.

Question owner

My apologies for the late answer. I tried your suggestion and to be short, it works, and then it doesn't work, then it works again, and 10minutes later the full screen warning drops down again and doesn't leave again. It is so #$@#$%@ iritating that because of the other problems like not being able to stay logged in on certain websites and impossibility of firefo57.x to remember the last download location. I downgraded to version 52 which works like it should. To my opinion Mozilla should go back to Beta with this "upgrade" until ALL the bugs are fixed.

I think Firefox 57 is a DISASTER which can ruin the reputation of Mozilla

My apologies for the late answer. I tried your suggestion and to be short, it works, and then it doesn't work, then it works again, and 10minutes later the full screen warning drops down again and doesn't leave again. It is so #$@#$%@ iritating that because of the other problems like not being able to stay logged in on certain websites and impossibility of firefo57.x to remember the last download location. I downgraded to version 52 which works like it should. To my opinion Mozilla should go back to Beta with this "upgrade" until ALL the bugs are fixed. I think Firefox 57 is a DISASTER which can ruin the reputation of Mozilla
jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

Hi Dutchheretic, what settings are you using in Firefox ESR to suppress the message?

If you set full-screen-api.warning.timeout to 0 and, while in full screen, move your mouse pointer to the top of the screen, the message may come down so you can click the exit full screen button, and become locked there.

I've historically set the preference to a short time (quarter second) so it just blips away quickly, partly to avoid that problem:

  • full-screen-api.warning.timeout => change from 3000 to 250 (time message stays on screen)

Whatever value you use for the timeout, I suggest setting the delay to zero and just get it over with. ;-)

  • full-screen-api.warning.delay => change from 500 to 0 (time before the message appears)
Hi Dutchheretic, what settings are you using in Firefox ESR to suppress the message? If you set full-screen-api.warning.timeout to 0 and, while in full screen, move your mouse pointer to the top of the screen, the message may come down so you can click the exit full screen button, and become locked there. I've historically set the preference to a short time (quarter second) so it just blips away quickly, partly to avoid that problem: * full-screen-api.warning.timeout => change from 3000 to 250 (time message stays on screen) Whatever value you use for the timeout, I suggest setting the delay to zero and just get it over with. ;-) * full-screen-api.warning.delay => change from 500 to 0 (time before the message appears)

Question owner

Thank you for your suggestion .. I have used EVERY probability, every setting, it just doesn't work In all former versions it was enough to set the timeout and the delay on 0 but in this new windows10 look firefox 57 it doesn't.

(this is to the firefox makers) The full screen warning is a totally useless function, it is like a popup message at your water tap WARNING! WATER IS WET, close the tap to stop water flow We KNOW it when youtube uses the full screen because we can SEE it.. PLEASE REMOVE IT !!

Thank you for your suggestion .. I have used EVERY probability, every setting, it just doesn't work In all former versions it was enough to set the timeout and the delay on 0 but in this new windows10 look firefox 57 it doesn't. (this is to the firefox makers) The full screen warning is ''' a totally useless function''', it is like a popup message at your water tap ''WARNING! WATER IS WET, close the tap to stop water flow'' We KNOW it when youtube uses the full screen because we can SEE it.. '''PLEASE REMOVE IT !!'''

Modified by Dutchheretic

jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

First, you can give comments on desired feature changes here:

https://qsurvey.mozilla.com/s3/FirefoxInput/

Second, I've read the warning is intended to reduce the risk of pages successfully impersonating applications and phishing users.

Anyway, when you come back to the mainstream releases, you can try again and see whether you can discover what triggers the return of the message (if it's something other than mousing up to the top of the screen).

First, you can give comments on desired feature changes here: https://qsurvey.mozilla.com/s3/FirefoxInput/ Second, I've read the warning is intended to reduce the risk of pages successfully impersonating applications and phishing users. Anyway, when you come back to the mainstream releases, you can try again and see whether you can discover what triggers the return of the message (if it's something other than mousing up to the top of the screen).
cor-el
  • Top 10 Contributor
  • Moderator
16390 solutions 147861 answers

Note that this message is a security feature: a website could use it to display a fake image of a browser window with a website to trick you to click a link to download malware or impose as an other website and make you fill a login form.

Note that this message is a security feature: a website could use it to display a fake image of a browser window with a website to trick you to click a link to download malware or impose as an other website and make you fill a login form.

Question owner

REALLY ? a security message ? Everyone I have installed firefox for (in the hundreds) complained about this stupid screen and By all I had to set the options on 0 to get rid of it It is #@$# irritating

REALLY ? a security message ? Everyone I have installed firefox for (in the hundreds) complained about this stupid screen and By all I had to set the options on 0 to get rid of it It is #@$# irritating

Modified by Dutchheretic

Helpful Reply

@jscher2000 Thanks for the link I will take a look at it tomorrow (it is no 1:30 AM here)

@jscher2000 Thanks for the link I will take a look at it tomorrow (it is no 1:30 AM here)