X
Tap here to go to the mobile version of the site.

Support Forum

Since the upgrade some of my videos, (Youtube, Facebook, webcams) are showing totally green and pink!. Sometimes during the day it is OK, other times not.

Posted

I have tried a clean reinstall of Firefox and Flash with no effect. I tried a refresh and it was fine... for 10 minutes. I can't understand why it is OK sometimes during the day. All is fine on Chrome and Explorer.

I have been on Firefox since conception but it is noe spoiling my online time so maybe time to part company...

I have tried a clean reinstall of Firefox and Flash with no effect. I tried a refresh and it was fine... for 10 minutes. I can't understand why it is OK sometimes during the day. All is fine on Chrome and Explorer. I have been on Firefox since conception but it is noe spoiling my online time so maybe time to part company...

Chosen solution

if you don not want to fiddle with firefox internals (though the warning message is more of a joke - firefox is a free product so there's no warranty on it), there's one more way you can fix it in the firefox menu: go to the firefox menu ≡ > options > general panel. in there untick the box that says "use recommended performance settings" and then untick the box saying use hardware acceleration when available. when you restart firefox once after that the video playback issue is also instantly resolved. Firefox's performance settings

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5281 solutions 23329 answers

Helpful Reply

hi, we are currently aware of this issue on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue.

otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

hi, we are currently aware of this issue on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue. otherwise you can do the following to work around the problem: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''media.windows-media-foundation.use-nv12-format'''. double-click it and change its value to '''false'''.

Question owner

Thanks for the info. I updated my graphics driver but it did not solve it. I am not prepared to alter the config of my PC just to work round a Firefox issue.

Is this an issue that Firefox are working on and are likely to fix? If not then I may as well transfer my bookmarks and settings over to explorer and leave Firefox. Great shame after all the years I have been with them.

Thanks for the info. I updated my graphics driver but it did not solve it. I am not prepared to alter the config of my PC just to work round a Firefox issue. Is this an issue that Firefox are working on and are likely to fix? If not then I may as well transfer my bookmarks and settings over to explorer and leave Firefox. Great shame after all the years I have been with them.
philipp
  • Top 25 Contributor
  • Moderator
5281 solutions 23329 answers

sure, firefox developers are working on this - however the workaround that i've described is very quickly done & effective and not something that would alter the configuration of your pc. its effects are essentially contained in fixing the video rendering issue you're seeing in firefox...

sure, firefox developers are working on this - however the workaround that i've described is very quickly done & effective and not something that would alter the configuration of your pc. its effects are essentially contained in fixing the video rendering issue you're seeing in firefox...

Question owner

Thanks Philipp, I appreciate your help. I'm not too computer savvy but when I tried the second fix you described I had a message up saying this would invalidate your Windows / PB guarantee so it was not worth my going there. I'll transfer over to Opera or Chrome for now as they are working OK on video links etc. but will look back at Firefox in a future date to see if they have fixed the issue.

Thanks Philipp, I appreciate your help. I'm not too computer savvy but when I tried the second fix you described I had a message up saying this would invalidate your Windows / PB guarantee so it was not worth my going there. I'll transfer over to Opera or Chrome for now as they are working OK on video links etc. but will look back at Firefox in a future date to see if they have fixed the issue.
philipp
  • Top 25 Contributor
  • Moderator
5281 solutions 23329 answers

Chosen Solution

if you don not want to fiddle with firefox internals (though the warning message is more of a joke - firefox is a free product so there's no warranty on it), there's one more way you can fix it in the firefox menu: go to the firefox menu ≡ > options > general panel. in there untick the box that says "use recommended performance settings" and then untick the box saying use hardware acceleration when available. when you restart firefox once after that the video playback issue is also instantly resolved. Firefox's performance settings

if you don not want to fiddle with firefox internals (though the warning message is more of a joke - firefox is a free product so there's no warranty on it), there's one more way you can fix it in the firefox menu: go to the firefox ''menu ≡ > options > general'' panel. in there untick the box that says "use recommended performance settings" and then untick the box saying '''use hardware acceleration when available'''. when you restart firefox once after that the video playback issue is also instantly resolved. [[Firefox's performance settings]]

Question owner

Thanks Philipp, the unticking of "use hardware acceleration when available" box worked and order is now restored to my life (and Firefox browsing)

Many thanks for your help :)

Thanks Philipp, the unticking of "use hardware acceleration when available" box worked and order is now restored to my life (and Firefox browsing) Many thanks for your help :)