X
Tap here to go to the mobile version of the site.

Support Forum

I get a green/purple screen trying to watch videos only after the firefox update

Posted

Up until the firefox update everything was going fine so I know it isnt my drivers, especially since i keep them up to date for gaming.

However, after the update yesterday I can no longer watch videos on any website, be it youtube or elsewhere, without getting an extremely offensive to the eyes neon green and purple screen. I know this isnt just my computer as I can watch videos saved to my computer or on other browsers with no issue, but firefox is my browser of choice as i've had issues with others such as google chrome not allowing me to download things, so i'd really prefer if there was a fix for this beyond switching to google. For now I have two browsers open, chrome and firefox, for normal internet use and videos as firefox can no longer do both. This is way, way more frustration than should be coming from an "improvement" to your browser, I dont even know why the hell there /was/ an update if all it was going to do was cause issues.

In the screenshot the video is green and purple as described when before the update it was just a black screen lyric video. It's worse for videos with more going on like people moving around, but the update's glitch has made it and other videos totally unwatchable for me as I cant stand the neon. I do not know how to fix this, i've tried disabling acceleration on flash, updating my drivers which did nothing as they were already up to date, etc. I dont know if i'm going to have to switch to something like safari in an attempt to find a browser that actually works for more than a year before updates destroy it's functionality, because this is ridiculous, I came to firefox because chrome let me down and now firefox has too.

Up until the firefox update everything was going fine so I know it isnt my drivers, especially since i keep them up to date for gaming. However, after the update yesterday I can no longer watch videos on any website, be it youtube or elsewhere, without getting an extremely offensive to the eyes neon green and purple screen. I know this isnt just my computer as I can watch videos saved to my computer or on other browsers with no issue, but firefox is my browser of choice as i've had issues with others such as google chrome not allowing me to download things, so i'd really prefer if there was a fix for this beyond switching to google. For now I have two browsers open, chrome and firefox, for normal internet use and videos as firefox can no longer do both. This is way, way more frustration than should be coming from an "improvement" to your browser, I dont even know why the hell there /was/ an update if all it was going to do was cause issues. In the screenshot the video is green and purple as described when before the update it was just a black screen lyric video. It's worse for videos with more going on like people moving around, but the update's glitch has made it and other videos totally unwatchable for me as I cant stand the neon. I do not know how to fix this, i've tried disabling acceleration on flash, updating my drivers which did nothing as they were already up to date, etc. I dont know if i'm going to have to switch to something like safari in an attempt to find a browser that actually works for more than a year before updates destroy it's functionality, because this is ridiculous, I came to firefox because chrome let me down and now firefox has too.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Mkll 314 solutions 1978 answers

Try disabling hardware acceleration in the options menu.

Try disabling hardware acceleration in the options menu.

Question owner

Mkll said

Try disabling hardware acceleration in the options menu.

i... can you read? I already did that and nothing happened. My god.

"I do not know how to fix this, i've tried disabling acceleration on flash, updating my drivers which did nothing as they were already up to date, etc."

''Mkll [[#answer-1029514|said]]'' <blockquote> Try disabling hardware acceleration in the options menu. </blockquote> i... can you read? I already did that and nothing happened. My god. "I do not know how to fix this, i've tried disabling acceleration on flash, updating my drivers which did nothing as they were already up to date, etc."
Mkll 314 solutions 1978 answers

Youtube uses HTML5, not Flash Player.

Youtube uses HTML5, not Flash Player.
philipp
  • Top 25 Contributor
  • Moderator
5281 solutions 23329 answers

hi, can you try if the problem goes away when you enter about:config into the address bar (and confirm the warning message in case it's showing up) and look for the preference layers.gpu-process.enable in the list. then toggle it to false and restart firefox once...

hi, can you try if the problem goes away when you enter '''about:config''' into the address bar (and confirm the warning message in case it's showing up) and look for the preference '''layers.gpu-process.enable''' in the list. then toggle it to '''false''' and restart firefox once...
dog3456 0 solutions 4 answers

philipp said

hi, can you try if the problem goes away when you enter about:config into the address bar (and confirm the warning message in case it's showing up) and look for the preference layers.gpu-process.enable in the list. then toggle it to false and restart firefox once...
phillip,

what you described did work for me, but what did i do? will it cause other problems with my browser?

''philipp [[#answer-1030596|said]]'' <blockquote> hi, can you try if the problem goes away when you enter '''about:config''' into the address bar (and confirm the warning message in case it's showing up) and look for the preference '''layers.gpu-process.enable''' in the list. then toggle it to '''false''' and restart firefox once... </blockquote phillip, what you described did work for me, but what did i do? will it cause other problems with my browser?
philipp
  • Top 25 Contributor
  • Moderator
5281 solutions 23329 answers

@dog3456, in the meantime we have found a more targeted fix - you can go go to about:config and reset "layers.gpu-process.enable" again.

then please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue. if not, you should set media.windows-media-foundation.use-nv12-format in about:config false - that disables an advanced rendering feature that was accidentally turned on for older graphics drivers as well (where it's causing some issues as you are noticing)...

@dog3456, in the meantime we have found a more targeted fix - you can go go to about:config and reset "layers.gpu-process.enable" again. then please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue. if not, you should set '''media.windows-media-foundation.use-nv12-format''' in about:config '''false''' - that disables an advanced rendering feature that was accidentally turned on for older graphics drivers as well (where it's causing some issues as you are noticing)...