X
Tap here to go to the mobile version of the site.

Support Forum

Firefox takes up a lot of memory when opening developer tools panel for a local host page

Posted

Hello!

Recently I noticed that debugging a webpage with firefox on my machine has become slower and slower, and I found out that firefox takes up up to 2 GB of memory when opening developer tools (F12) for my local test page. This doesn't happen with the live version on the Internet, so I think this problem is caused by firefox.

My local setup is a FreeBSD server running a pre-configured jail in VirtualBox. This setup is done like this in order to simulate the live server. Has anyone experienced this kind of issue before? I'm happy to provide more information such as logs, but I have no idea what kind of information would be useful here. Thanks in advance!

Hello! Recently I noticed that debugging a webpage with firefox on my machine has become slower and slower, and I found out that firefox takes up up to 2 GB of memory when opening developer tools (F12) for my local test page. This doesn't happen with the live version on the Internet, so I think this problem is caused by firefox. My local setup is a FreeBSD server running a pre-configured jail in VirtualBox. This setup is done like this in order to simulate the live server. Has anyone experienced this kind of issue before? I'm happy to provide more information such as logs, but I have no idea what kind of information would be useful here. Thanks in advance!
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • Firefox 56.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
  • Support URL: https://support.mozilla.org/1/firefox/56.0.2/WINNT/zh-TW/

Extensions

  • Ecosia — The search engine that plants trees! 3.4.5 ({d04b0b40-3dab-4f0b-97a6-04ec3eddbfb0})
  • OneNote Web Clipper 3.7.2 (Clipper@OneNote.com)
  • Restart 3.0.2 (Restart@schuzak.jp)
  • Safe Browsing Version 4 (temporary add-on) 1.0.0 (sbv4-gradual-rollout@mozilla.com)
  • uBlock Origin 1.14.16 (uBlock0@raymondhill.net)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4400
  • adapterDescription2:
  • adapterDeviceID: 0x041e
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 041e1849
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.15063.674
  • driverDate: 9-29-2016
  • driverDate2:
  • driverVersion: 20.19.15.4531
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'available', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'disabled', u'description': u'Advanced Layers', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'ADVANCED_LAYERS'}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'Direct2D 1.1', u'AzureContentBackend': u'Direct2D 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl1DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4400 Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000007589) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture_nv12 EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4400 Direct3D11 vs_5_0 ps_5_0)
  • webgl2Version: OpenGL ES 3.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl2WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000007589) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture_nv12 EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
smorele
  • Top 25 Contributor
35 solutions 285 answers

Helpful Reply

Hello, strange fact. Logically, you should have the same behavior for each location. Can you reproduce with a simple web page (a simple Hello World) served locally?

Hello, strange fact. Logically, you should have the same behavior for each location. Can you reproduce with a simple web page (a simple Hello World) served locally?
Was this helpful to you? 1
Quote

Question owner

This problem cannot be reproduced on a hello world page. Here are some observations:

  • After pressing F12, the memory hogging behavior only happens when I click on the debugger tab. It doesn't happen with other tabs.
  • That led me to think that maybe the javascript it is trying to load is too big. I tried turning on minifying javascript on the local server (it previously wasn't minified for debugging purposes), but that didn't work.
This problem cannot be reproduced on a hello world page. Here are some observations: * After pressing F12, the memory hogging behavior only happens when I click on the debugger tab. It doesn't happen with other tabs. * That led me to think that maybe the javascript it is trying to load is too big. I tried turning on minifying javascript on the local server (it previously wasn't minified for debugging purposes), but that didn't work.
Was this helpful to you?
Quote
Pkshadow
  • Top 10 Contributor
377 solutions 3996 answers

Looks like some issues going on with your Graphic Card Drivers for Intel(R) HD Graphics 4400 as they are from 9-29-2016 Please check here : https://www.intel.com/content/www/us/en/support/products/81497/graphics-drivers/graphics-for-4th-generation-intel-processors/intel-hd-graphics-4400.html Though not sure they run for you on your setup.

What would be useful is if it is the multiprocessor causing these issues. Sure have a equivalent of Task Manager. Look to see how many instance of Firefox there is and keep a eye on the ram.

Yes can help with that if know for sure that is the issue.

Try turning this off : Mozilla experiment, called 'Shield Studies'. Without even knowing it, you may have volunteered for this Mozilla experiment. Would you go to : Options => Privacy & Security => under 'Data Collection and Use' : Did you uncheck : 'Allow Firefox to install and run studies ' or is it checked  ?

To check if you are enrolled in these studies : Type in the address bar about:studies

Any extensions that you see listed there, you can either disable or remove, just like this Safe Browsing version 4 (at the end of the experiment they will be disabled anyway). See for further information : https://support.mozilla.org/en-US/kb/shield

If as per Task Manager equv and see ram going way out of line with say 7 tabs open and are pushing 2.5 each you can turn off :

You can try to modify multi-process settings to see if this has effect. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://kb.mozillazine.org/about:config Also can reverse everything this tells you to enable it. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Please let us know if this solved your issue or if need further assistance.

Looks like some issues going on with your Graphic Card Drivers for Intel(R) HD Graphics 4400 as they are from 9-29-2016 Please check here : https://www.intel.com/content/www/us/en/support/products/81497/graphics-drivers/graphics-for-4th-generation-intel-processors/intel-hd-graphics-4400.html Though not sure they run for you on your setup. What would be useful is if it is the multiprocessor causing these issues. Sure have a equivalent of Task Manager. Look to see how many instance of Firefox there is and keep a eye on the ram. Yes can help with that if know for sure that is the issue. Try turning this off : Mozilla experiment, called 'Shield Studies'. Without even knowing it, you may have volunteered for this Mozilla experiment. Would you go to : Options => Privacy & Security => under 'Data Collection and Use' : Did you uncheck : 'Allow Firefox to install and run studies ' or is it checked ? To check if you are enrolled in these studies : Type in the address bar about:studies Any extensions that you see listed there, you can either disable or remove, just like this Safe Browsing version 4 (at the end of the experiment they will be disabled anyway). See for further information : https://support.mozilla.org/en-US/kb/shield If as per Task Manager equv and see ram going way out of line with say 7 tabs open and are pushing 2.5 each you can turn off : You can try to modify multi-process settings to see if this has effect. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false http://kb.mozillazine.org/about:config Also can reverse everything this tells you to enable it. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Please let us know if this solved your issue or if need further assistance.
Was this helpful to you?
Quote

Question owner

Pkshadow said

Looks like some issues going on with your Graphic Card Drivers for Intel(R) HD Graphics 4400 as they are from 9-29-2016 Please check here : https://www.intel.com/content/www/us/en/support/products/81497/graphics-drivers/graphics-for-4th-generation-intel-processors/intel-hd-graphics-4400.html Though not sure they run for you on your setup. What would be useful is if it is the multiprocessor causing these issues. Sure have a equivalent of Task Manager. Look to see how many instance of Firefox there is and keep a eye on the ram. Yes can help with that if know for sure that is the issue. Try turning this off : Mozilla experiment, called 'Shield Studies'. Without even knowing it, you may have volunteered for this Mozilla experiment. Would you go to : Options => Privacy & Security => under 'Data Collection and Use' : Did you uncheck : 'Allow Firefox to install and run studies ' or is it checked  ? To check if you are enrolled in these studies : Type in the address bar about:studies Any extensions that you see listed there, you can either disable or remove, just like this Safe Browsing version 4 (at the end of the experiment they will be disabled anyway). See for further information : https://support.mozilla.org/en-US/kb/shield If as per Task Manager equv and see ram going way out of line with say 7 tabs open and are pushing 2.5 each you can turn off : You can try to modify multi-process settings to see if this has effect. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false http://kb.mozillazine.org/about:config Also can reverse everything this tells you to enable it. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Please let us know if this solved your issue or if need further assistance.

I tried all the methods you listed, but none of them worked.

  1. Started firefox in safe mode - didn't work
  2. Unchecked all data collection boxes and removed study "safe-browsing-v4-1387651" - didn't work
  3. dom.ipc.processCount was already 1
  4. Changed both autostarts to false (autostart.2 was originally true) - didn't work

After some digging around it seems more and more likely that what is causing the error is the local server, not firefox - as opening debugger for the live version doesn't have the same issue. What is stumping me now is why there is such a difference between local and live, and what kind of difference it is.

''Pkshadow [[#answer-1023889|said]]'' <blockquote> Looks like some issues going on with your Graphic Card Drivers for Intel(R) HD Graphics 4400 as they are from 9-29-2016 Please check here : https://www.intel.com/content/www/us/en/support/products/81497/graphics-drivers/graphics-for-4th-generation-intel-processors/intel-hd-graphics-4400.html Though not sure they run for you on your setup. What would be useful is if it is the multiprocessor causing these issues. Sure have a equivalent of Task Manager. Look to see how many instance of Firefox there is and keep a eye on the ram. Yes can help with that if know for sure that is the issue. Try turning this off : Mozilla experiment, called 'Shield Studies'. Without even knowing it, you may have volunteered for this Mozilla experiment. Would you go to : Options => Privacy & Security => under 'Data Collection and Use' : Did you uncheck : 'Allow Firefox to install and run studies ' or is it checked ? To check if you are enrolled in these studies : Type in the address bar about:studies Any extensions that you see listed there, you can either disable or remove, just like this Safe Browsing version 4 (at the end of the experiment they will be disabled anyway). See for further information : https://support.mozilla.org/en-US/kb/shield If as per Task Manager equv and see ram going way out of line with say 7 tabs open and are pushing 2.5 each you can turn off : You can try to modify multi-process settings to see if this has effect. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false http://kb.mozillazine.org/about:config Also can reverse everything this tells you to enable it. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Please let us know if this solved your issue or if need further assistance. </blockquote> I tried all the methods you listed, but none of them worked. # Started firefox in safe mode - didn't work # Unchecked all data collection boxes and removed study "safe-browsing-v4-1387651" - didn't work # dom.ipc.processCount was already 1 # Changed both autostarts to false (autostart.2 was originally true) - didn't work After some digging around it seems more and more likely that what is causing the error is the local server, not firefox - as opening debugger for the live version doesn't have the same issue. What is stumping me now is why there is such a difference between local and live, and what kind of difference it is.
Was this helpful to you?
Quote
smorele
  • Top 25 Contributor
35 solutions 285 answers

the difference may come from different factors (os and its configuration, server configuration, and physical resources) Hard to really explain, try another Linux distribution, another web server or change your configuration.

the difference may come from different factors (os and its configuration, server configuration, and physical resources) Hard to really explain, try another Linux distribution, another web server or change your configuration.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.