Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox stopped working this morning, tried reinstall no luck. chrome and IE both work.

  • 5 replies
  • 3 have this problem
  • Last reply by FredMcD

more options

Firefox was working yesterday, however this morning when I went to launch it, it never loaded. Opened up task manager it pops open for a moment then instantly closes I have tried uninstalling it both by using windows 10 uninstall function and did a reinstall same issue. I have tried uninstalling by manually deleting both folders in program files (normal and x86). reinstall same issue. I cant run Profile Manager because it does the same thing. I went to my firewall settings there are multiple instances of Firefox ,not really sure what to do, two just say "Firefox" (no quotes) the other says Firefox "C:\Program Files\Mozilla Firefox". Any help with this issue would be appreciated.

All Replies (5)

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

Removed them from the the trusted list and reinstalled now only have the one instance of Firefox, but still having the same issue, also ensured that the internet security was up to date and also downloaded a few tools to see if it was malware, and everything came back ok, restarted and still same issue.

Modified by plasmaflux

more options

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first try No Proxy. If there is a problem, then try System Proxy.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

In what address bar? Firefox isn't opening at all so i don't even have access to the address bar.

more options

Now even with Firefox Safe Mode?

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there? Starting Any Computer In Safe Mode; Free Online Encyclopedia