X
Tap here to go to the mobile version of the site.

Support Forum

Why has Firefox slowed to the point of unusable?

Posted

Firefox slowed to the point where it is unusable. It also stalls, and even crashes. Other browsers work find, and my internet connection speeds are as good as I can expect.

I have uninstalled and reinstalled to no avail.

My machine is Intel QuadCore i5-3470 CPU @ 3.20GHz, 32 GB RAM, running MS Windows 10 Home on an MSI B75MA-P45 motherboard. It was assembled by Net Solution Computers of Morley, Western Australia, and has a SAMSUNG U28D590D VDU driven by an NVIDIA QUADRO K620 Video Card and RealTek High Definition Audio. I have Windows Defender and Malwarebytes as Anti-virus with Firefox and Skype running in the background.

Firefox slowed to the point where it is unusable. It also stalls, and even crashes. Other browsers work find, and my internet connection speeds are as good as I can expect. I have uninstalled and reinstalled to no avail. My machine is Intel QuadCore i5-3470 CPU @ 3.20GHz, 32 GB RAM, running MS Windows 10 Home on an MSI B75MA-P45 motherboard. It was assembled by Net Solution Computers of Morley, Western Australia, and has a SAMSUNG U28D590D VDU driven by an NVIDIA QUADRO K620 Video Card and RealTek High Definition Audio. I have Windows Defender and Malwarebytes as Anti-virus with Firefox and Skype running in the background.

Chosen solution

No way to know what gives unless it comes back.

After a few days, if the problem does not return, Please flag your last post as Solved Problem so others will know.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; Trident/7.0; .NET4.0C; .NET4.0E; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729; SLCC2; Media Center PC 6.0; rv:11.0) like Gecko

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59858 answers

What's your Firefox version?

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

While still in Safe Mode,

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 crash reports, and copy them. Now go to the reply box and paste them in.

aboutcrashesFx29

For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

What's your Firefox version? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? While still in Safe Mode, In the address bar, type '''about:crashes'''<enter>. '''Note: ''' If any reports do not have '''BP-''' in front of the numbers/letters, click it to submit them. '''The crash report is several pages of data. We ''' '''need the report numbers to see the whole report. ''' Using your mouse, '''mark''' the '''most recent 7 - 10''' crash reports, and copy them. Now go to the reply box and paste them in. ;[[Image:aboutcrashesFx29|width=500]] For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

Question owner

Thanks for the reply, Fred. Perhaps 'crashes' was a little expansive. Certainly FF hasn't registered any. It's just that when I try to print a page using Win2Pdf FF freezes and I have to kill it and start again. That, however, is not the big problem.

The big problem is that FF gets outpaced by Cybersnails. It is literally impossible to get anything useful done. Internet Explorer (which I am using at the moment - very much against the grain and purely out of necessity) flies along nicely. As I said, my interned data speeds are okay. It's only FF that doesn't want to run. As I said, I have installed a completely new installation (56.0.1 64-bit). How can I get FF running properly - what is wrong and how do I fix it?

Thanks

Thanks for the reply, Fred. Perhaps 'crashes' was a little expansive. Certainly FF hasn't registered any. It's just that when I try to print a page using Win2Pdf FF freezes and I have to kill it and start again. That, however, is not the big problem. The big problem is that FF gets outpaced by Cybersnails. It is literally impossible to get anything useful done. Internet Explorer (which I am using at the moment - very much against the grain and purely out of necessity) flies along nicely. As I said, my interned data speeds are okay. It's only FF that doesn't want to run. As I said, I have installed a completely new installation (56.0.1 64-bit). How can I get FF running properly - what is wrong and how do I fix it? Thanks
FredMcD
  • Top 10 Contributor
4269 solutions 59858 answers

Did you try Firefox in Safe Mode?

Did you try Firefox in Safe Mode?

Question owner

Yes I did

Yes I did

Question owner

And it's still slow

And it's still slow
FredMcD
  • Top 10 Contributor
4269 solutions 59858 answers

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Question owner

Hold the phone. Everything is just ginger-peachy today. FF is bowling merrily along like nothing ever happened. I'll keep you posted.

I have no idea what caused yesterday's problem, but I can assure you it was very real. I would up using Internet Explorer for the day - eeeech!

Thanks for the effort

Hold the phone. Everything is just ginger-peachy today. FF is bowling merrily along like nothing ever happened. I'll keep you posted. I have no idea what caused yesterday's problem, but I can assure you it was very real. I would up using Internet Explorer for the day - eeeech! Thanks for the effort
FredMcD
  • Top 10 Contributor
4269 solutions 59858 answers

Chosen Solution

No way to know what gives unless it comes back.

After a few days, if the problem does not return, Please flag your last post as Solved Problem so others will know.

No way to know what gives unless it comes back. After a few days, if the problem does not return, Please flag your last post as '''Solved Problem''' so others will know.

Question owner

Vagulus said

Hold the phone. Everything is just ginger-peachy today. FF is bowling merrily along like nothing ever happened. I'll keep you posted.

FF is bowling merrily along like nothing ever happened. I don't know what happpened, but it has been clear for about a month.

Thanks folks.

''Vagulus [[#answer-1018420|said]]'' <blockquote> Hold the phone. Everything is just ginger-peachy today. FF is bowling merrily along like nothing ever happened. I'll keep you posted. </blockquote> FF is bowling merrily along like nothing ever happened. I don't know what happpened, but it has been clear for about a month. Thanks folks.