Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need to disable the pop-up blocker

  • 2 replies
  • 25 have this problem
  • 2279 views
  • Last reply by cor-el

more options

a pop-up blocker is not allowing me to change my password with DELTA. I have a trip next week and need to get onto this sight. HELP!

All Replies (2)

more options

Greetings! Wallacejc,

To disable the pop-up blocker simply follow the below steps:

  • Open the Tools menu at the top right of your browser.
  • Click Options.
  • Click the Content tab.
  • Next to Block pop-up windows, click Exceptions.
  • Type www.wix.com and click Allow.
  • Click Close.
  • Click OK.

Note: If you see the pop up when logging in your editor, simply click on Options.

more options

Note that on Mac it is Firefox -> Preferences.

Are you sure this is about a pop-up blocker?


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window