X
Tap here to go to the mobile version of the site.

Support Forum

why cant i play games

Posted

It keeps telling me I need adobe flash player.I allready have it.

It keeps telling me I need adobe flash player.I allready have it.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

More Information

jscher2000
  • Top 10 Contributor
8568 solutions 70052 answers

Hi, is this problem on your Windows 7 PC?

( A moderator can move your question from this board to the regular Firefox board in that case. )

If you check Adobe's test site, does it show that your Flash is current? https://helpx.adobe.com/flash-player.html

By default, sites require permission to use Flash. Look for a light gray notification icon toward the left end of the toolbar that looks a bit like a Lego block. There may be a colored dot "pulsing" on the icon. Click that icon to check and change the status. An example screenshot is attached.

More info: Why do I have to click to activate plugins?

Hi, is this problem on your Windows 7 PC? ( A moderator can move your question from this board to the regular Firefox board in that case. ) If you check Adobe's test site, does it show that your Flash is current? https://helpx.adobe.com/flash-player.html By default, sites require permission to use Flash. Look for a light gray notification icon toward the left end of the toolbar that looks a bit like a Lego block. There may be a colored dot "pulsing" on the icon. Click that icon to check and change the status. An example screenshot is attached. More info: [[Why do I have to click to activate plugins?]]