Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

OMG!!!! HOW to get rid of BING!!!!???

more options

Hello...the title says it all.

No one seems to be able to fix this problem. I am very tired of looking for a solution....

Anyone there?

Chosen solution

Thank you for sharing your Firefox configuration (to the right of your question, "Question Details" then More System Details).

You are infected with the "SearchAssist Incognito" extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions that Firefox installs on its own are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Try to Remove SearchAssist Incognito. If there is no Remove button, it is in a shared location and may have an uninstaller in the Windows Control Panel.

Sometimes a link will appear above an extension you asked to Disable or Remove, to restart Firefox before the change takes effect. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

Read this answer in context 👍 1

All Replies (3)

more options

Have you tried this?

  • Enter about:preferences in your urlbar This will take you to your options page
  • Go the search section of the Options page
  • find Bing in the "One-click Search Engines" list and click it so that it's highlights
  • Click the Remove button

Hope this helps If it can't be done that way, make sure there is nothing installed by Bing in your computer. that might be the reason

more options

Chosen Solution

Thank you for sharing your Firefox configuration (to the right of your question, "Question Details" then More System Details).

You are infected with the "SearchAssist Incognito" extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions that Firefox installs on its own are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Try to Remove SearchAssist Incognito. If there is no Remove button, it is in a shared location and may have an uninstaller in the Windows Control Panel.

Sometimes a link will appear above an extension you asked to Disable or Remove, to restart Firefox before the change takes effect. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

more options

My Hero! jscher2000

PULEEEEEEZE (for others) make this a sticky. Ive searched all over and didnt find an answer to this....I found many looking for a solution. Google and IE also.

HATE you BING!