Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox: SLOW, Uninstalled , Reinstalled, will not open .. Repeated multiple times with no success

  • 3 replies
  • 5 have this problem
  • 272 views
  • Last reply by TxDan001

more options

Long time Mozilla product user; Firefox, Thunderbird and other. Firefox became unusable. I deleted Firefox. I installed Firefox. It will not open. I have completely deleted all files/folders related to ALL Mozilla products. Windows 7 64 bit. I have tried 64 bit and 32 bit Firefox with no success. When I click to open I get the blue "working" circle for a few seconds then it stops. Task Manager shows no Firefox activity.

Chosen solution

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

Hi TxDan001, you posted using Firefox Beta (Firefox 57). Is that on a different system? What's the system info for the system that has the problem (Firefox version, OS version)?

more options

Hello ... thanks for your speedy reply. I found the solution. After multiple Firefox uninstalls/re-installs ... Win7 now using Firefox Quantum browser (awesome!) .. I discovered the problem was in my Avast settings. All is well. Thank you again!