Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Adobe Flash Player not recognized

  • 12 replies
  • 2 have this problem
  • 54 views
  • Last reply by FredMcD

more options

Using Windows 10, FF 55.0.3, Shockwave plugin 27.0.0.130, Adobe Flashplayer 27 NPAPI.

I am using Adobe Bridge and select to preview a gallery in the browser. Bridge will let FF start and then I get the message (in FF), that there is no flash player installed. I installed many many times, as decribed here in several messages, so often the flash player. I also did the steps described by the college student "ComputerWhiz" (=Wesley Branton) here: https://support.mozilla.org/nl/questions/1037689 (renaming pluginreg.dat). I disabled my virus scanner (E-Set). Also I deactivate in FF all the Extensions (to be sure no one causes a conflict), restarted FF but still FF does not recognize the flash player.

Please help me and do not give answers like to find out which flashplayer version I have or where to download flashplayer. Just an answer straight to the point why FF does not recognize the installed Adobe Flashplayer and how to solve it. Thx in advance

Modified by ni_hao

All Replies (12)

more options

ni_hao said

Please help me and do not give answers like to find out which flashplayer version I have or where to download flashplayer. Just an answer straight to the point why FF does not recognize the installed Adobe Flashplayer and how to solve it. Thx in advance

Hi   !

I can only think of one possible reason : When you downloaded Adobe Flash Player, were you using Firefox, or Edge / IE (or another browser) ? For, if you were using another browser, you wouldn't be getting the version that Firefox needs, and that might explain why Firefox doesn't recognize Flash as being installed. It's a mere stab in the dark ........

more options

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

more options

Thanks FredMcD. All plugins were and thus are set to: always activate. Left-Click icon shows me: the local location where the file has been stored and Permissions (no permissions set for this pages). However I can not select anything.

Modified by ni_hao

more options

I called for more help.

more options

Happy112 said

I can only think of one possible reason : When you downloaded Adobe Flash Player, were you using Firefox, or Edge / IE (or another browser) ? For, if you were using another browser, you wouldn't be getting the version that Firefox needs, and that might explain why Firefox doesn't recognize Flash as being installed. It's a mere stab in the dark ........

Thanks Happy112 (A.L.) for "stepping in the dark" for me. I am using FF. I 1st downloaded Adobe FlashPlayer (FP) when FF was open. After the FF error, I closed FF and downloaded FP again by first selecting OS and browser and finally downloaded FP which was "offered" to me. Both times the same FP was installed here (so I think I've the right FP release).

Modified by ni_hao

more options

FredMcD said

I called for more help.

1 week (+) later: what does that mean?

more options

I'll call again

more options

Quoting you :

"After the FF error, I closed FF and downloaded FP again "

So, you didn't download Flash using Firefox  ?

See the Chosen Solution in this thread : https://support.mozilla.org/en-US/questions/1161136

more options

The System Details list shows that the Shockwave Flash plugin is installed.

This issue can be caused by an extension that isn't working properly. I see some Flash related extensions:

  • Flash and Video Download
  • Flash Video Downloader

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Just after I turned my laptop on a few hours ago, Firefox began updating to its new version 57Quantum . Since this occurred, I have not been able to get adobe/shockwave flash to work on any website that I go to. I have downloaded and re-downloaded, and reinstalled and reinstalled, Adobe Flash 27.0.0.187. But in my Firefox add-ons window, I am told that the version is 27.0.0.159,and that it is out-of-date and dangerous, and that I should update it. So I click on the update button, and it takes me to Adobe's download page for 27.0.0.187. But even though Adobe Flash 27.0.0.187 is installed on my laptop, the Firefox add-on page DOES NOT UPDATE from 27.0.0.159.

Surely this is something that Firefox needs to fix.

more options

gh777 said

Just after I turned my laptop on a few hours ago, Firefox began updating to its new version 57Quantum . Since this occurred, I have not been able to get adobe/shockwave flash to work on any website that I go to. I have downloaded and re-downloaded, and reinstalled and reinstalled, Adobe Flash 27.0.0.187. But in my Firefox add-ons window, I am told that the version is 27.0.0.159,and that it is out-of-date and dangerous, and that I should update it. So I click on the update button, and it takes me to Adobe's download page for 27.0.0.187. But even though Adobe Flash 27.0.0.187 is installed on my laptop, the Firefox add-on page DOES NOT UPDATE from 27.0.0.159. Surely this is something that Firefox needs to fix.

It might be best if you started your own thread. You can do so by clicking the 'Ask a question' button at the top of this page, and then post your question (you could copy and paste what you posted here).

more options

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.