X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashes

Posted

My Firefox is always crashing when I try to view videos, especially when I try to change the time in the video. It crashes the tab, and then takes down all the other tabs with it.

I've done a virus scan, clean install, and tried running in safe mode. Made sure all addons are up to date and tried with or without flash. Nothing works. This has been going on for a couple of weeks now. I have Firefox 55.0.3 (64-bit).

My Firefox is always crashing when I try to view videos, especially when I try to change the time in the video. It crashes the tab, and then takes down all the other tabs with it. I've done a virus scan, clean install, and tried running in safe mode. Made sure all addons are up to date and tried with or without flash. Nothing works. This has been going on for a couple of weeks now. I have Firefox 55.0.3 (64-bit).

Chosen solution

bp-8fb87f2e-878f-44c3-801c-da8121170909 Signature: CAudioClient::FinalRelease

This is for Sumo's Related Bugs 1380775 RESOLVED DUPLICATE WebRTC crash on Duet PCS device

1362764 RESOLVED FIXED Crash in CAudioClient::FinalRelease


I called for more help.


Note: v55 has been giving users problems. Reinstall v54.

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

More Information

FredMcD
  • Top 10 Contributor
3652 solutions 50110 answers

There have been many users having video issues of late.

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration


Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.


Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

There have been many users having video issues of late. See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration ----------------- Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.adobe.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know. ----------------- Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Question owner

I turned off hardware acceleration in Firefox and my Flash player. My graphic drivers are up to date and WebGL was disabled.

The video will play, but whenever I change the video progress bar to another time the browser will crash. Also, when the video finishes, the browser will crash.

I turned off hardware acceleration in Firefox and my Flash player. My graphic drivers are up to date and WebGL was disabled. The video will play, but whenever I change the video progress bar to another time the browser will crash. Also, when the video finishes, the browser will crash.
FredMcD
  • Top 10 Contributor
3652 solutions 50110 answers

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 crash reports, and copy them. Now go to the reply box and paste them in.

aboutcrashesFx29

For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

In the address bar, type '''about:crashes'''<enter>. '''Note: ''' If any reports do not have '''BP-''' in front of the numbers/letters, click it to submit them. '''The crash report is several pages of data. We ''' '''need the report numbers to see the whole report. ''' Using your mouse, '''mark''' the '''most recent 7 - 10''' crash reports, and copy them. Now go to the reply box and paste them in. ;[[Image:aboutcrashesFx29|width=500]] For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

Question owner

My recent crash reports:

bp-2e1d9198-81d7-4f71-8b42-4e71d1170909 2017-09-08 11:00 PM bp-0ea6b488-a0f1-43bf-86db-f45470170909 2017-09-08 9:53 PM bp-523182c9-92f1-44b9-aa14-825751170907 2017-09-06 8:23 PM bp-f3b9d7ce-7146-40ff-b2d0-b10c10170903 2017-09-03 11:46 AM

My recent crash reports: bp-2e1d9198-81d7-4f71-8b42-4e71d1170909 2017-09-08 11:00 PM bp-0ea6b488-a0f1-43bf-86db-f45470170909 2017-09-08 9:53 PM bp-523182c9-92f1-44b9-aa14-825751170907 2017-09-06 8:23 PM bp-f3b9d7ce-7146-40ff-b2d0-b10c10170903 2017-09-03 11:46 AM
FredMcD
  • Top 10 Contributor
3652 solutions 50110 answers

bp-2e1d9198-81d7-4f71-8b42-4e71d1170909 Signature: CAudioClient::FinalRelease

mbae64.dll = Malwarebytes Anti-Exploit

nvwgf2umx.dll = Dwm.exe = Microsoft Desktop Window Manager

This is for Sumo's Related Bugs 1380775 RESOLVED DUPLICATE WebRTC crash on Duet PCS device

1362764 RESOLVED FIXED Crash in CAudioClient::FinalRelease +++++++++++++++++++++++++++++++++++++++++ bp-0ea6b488-a0f1-43bf-86db-f45470170909 bp-523182c9-92f1-44b9-aa14-825751170907

Signature: nvwgf2umx.dll | CContext::TID3D11DeviceContext_RSSetScissorRects_<T>

nvwgf2umx.dll = Dwm.exe = Microsoft Desktop Window Manager ++++++++++++++++++++++++++++++++++++++++++++ bp-f3b9d7ce-7146-40ff-b2d0-b10c10170903 Signature: IPCError-browser | ShutDownKill

Attention Sumo's there are 20 related bug reports

nvwgf2umx.dll = Dwm.exe = Microsoft Desktop Window Manager


Update Malwarebytes. If the problem continues, disable it.


Perform a System File Check to fix corrupted system files

Win 7, 8, 10, Vista: https://support.microsoft.com/en-us/kb/929833 Win XP: https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/system_file_checker.mspx?mfr=true

Wiki - Windows 10 System File Check http://answers.microsoft.com/en-us/windows/wiki/windows_10-update/system-file-check-sfc-scan-and-repair-system-files/bc609315-da1f-4775-812c-695b60477a93

bp-2e1d9198-81d7-4f71-8b42-4e71d1170909 Signature: CAudioClient::FinalRelease mbae64.dll = Malwarebytes Anti-Exploit nvwgf2umx.dll = Dwm.exe = Microsoft Desktop Window Manager This is for Sumo's Related Bugs 1380775 RESOLVED DUPLICATE WebRTC crash on Duet PCS device 1362764 RESOLVED FIXED Crash in CAudioClient::FinalRelease +++++++++++++++++++++++++++++++++++++++++ bp-0ea6b488-a0f1-43bf-86db-f45470170909 bp-523182c9-92f1-44b9-aa14-825751170907 Signature: nvwgf2umx.dll | CContext::TID3D11DeviceContext_RSSetScissorRects_<T> nvwgf2umx.dll = Dwm.exe = Microsoft Desktop Window Manager ++++++++++++++++++++++++++++++++++++++++++++ bp-f3b9d7ce-7146-40ff-b2d0-b10c10170903 Signature: IPCError-browser | ShutDownKill Attention Sumo's there are 20 related bug reports nvwgf2umx.dll = Dwm.exe = Microsoft Desktop Window Manager ----------------------- Update Malwarebytes. If the problem continues, disable it. ----------------------- Perform a System File Check to fix corrupted system files '''Win 7, 8, 10, Vista:''' https://support.microsoft.com/en-us/kb/929833 '''Win XP:''' https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/system_file_checker.mspx?mfr=true Wiki - Windows 10 System File Check http://answers.microsoft.com/en-us/windows/wiki/windows_10-update/system-file-check-sfc-scan-and-repair-system-files/bc609315-da1f-4775-812c-695b60477a93

Question owner

I did a system file check and ran DISM, and they found no issues. I disabled Malwarebytes but that didn't make any difference. This problem was happening before I installed Malwarebytes.

I did a system file check and ran DISM, and they found no issues. I disabled Malwarebytes but that didn't make any difference. This problem was happening before I installed Malwarebytes.
FredMcD
  • Top 10 Contributor
3652 solutions 50110 answers

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you. ----------------- Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false http://www.ghacks.net/2016/07/22/multi-process-firefox/ Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar.

Question owner

Hardware acceleration is disabled and I disabled set the autostart configurations to false as well. The browser now closes entirely instead of the tabs crashing and restarting.

Hardware acceleration is disabled and I disabled set the autostart configurations to false as well. The browser now closes entirely instead of the tabs crashing and restarting.
FredMcD
  • Top 10 Contributor
3652 solutions 50110 answers

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

Question owner

The issue was not resolved. The browser is crashing and closing now, instead of crashing each tab and having each tab reloaded without closing the browser. The error is different, but the effect is the same.

The issue was not resolved. The browser is crashing and closing now, instead of crashing each tab and having each tab reloaded without closing the browser. The error is different, but the effect is the same.
FredMcD
  • Top 10 Contributor
3652 solutions 50110 answers

Sorry, please post any new rash reports.

Sorry, please post any new rash reports.

Question owner

bp-8fb87f2e-878f-44c3-801c-da8121170909 2017-09-09 9:28 AM

bp-8fb87f2e-878f-44c3-801c-da8121170909 2017-09-09 9:28 AM
FredMcD
  • Top 10 Contributor
3652 solutions 50110 answers

Chosen Solution

bp-8fb87f2e-878f-44c3-801c-da8121170909 Signature: CAudioClient::FinalRelease

This is for Sumo's Related Bugs 1380775 RESOLVED DUPLICATE WebRTC crash on Duet PCS device

1362764 RESOLVED FIXED Crash in CAudioClient::FinalRelease


I called for more help.


Note: v55 has been giving users problems. Reinstall v54.

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

bp-8fb87f2e-878f-44c3-801c-da8121170909 Signature: CAudioClient::FinalRelease This is for Sumo's Related Bugs 1380775 RESOLVED DUPLICATE WebRTC crash on Duet PCS device 1362764 RESOLVED FIXED Crash in CAudioClient::FinalRelease --------------------- I called for more help. ---------------- '''Note: ''' v55 has been giving users problems. Reinstall v54. https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here. If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues. You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

Question owner

That fixed the issue. Version 55 is causing all the problems. Hopefully this gets fixed soon in a future version. Thanks for your help.

That fixed the issue. Version 55 is causing all the problems. Hopefully this gets fixed soon in a future version. Thanks for your help.
FredMcD
  • Top 10 Contributor
3652 solutions 50110 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.
cor-el
  • Top 10 Contributor
  • Moderator
16334 solutions 147396 answers

Helpful Reply

You can try the current 56.0 beta release to see if that version works.

Note that downgrading a profile from 55 to 54 can cause issues because changes were made to some data storage.

You can try the current 56.0 beta release to see if that version works. *https://www.mozilla.org/en-US/firefox/channel/desktop/ Note that downgrading a profile from 55 to 54 can cause issues because changes were made to some data storage.

Question owner

Actually 54 was causing me some issues and I switched to the beta. It's working better for me. No issues so far.

Actually 54 was causing me some issues and I switched to the beta. It's working better for me. No issues so far.