X
Tap here to go to the mobile version of the site.

Support Forum

Autofill for logins works incorrectly. Can't delete logins. Can't turn off "remember logins for sites". Can't block sites. Exemptions don't work.

Posted

I noticed that my Yahoo mail login box auto-fills logins I don't use - or logins I don't want anyone to see. After recent Firefox update to 55.0.3 64 bit - I can't delete those entries. What I could easily do before - drop down the list and hit delete - doesn't work anymore. But what bothers me most - is that there are entries there - that appeared - that I didn't use in years!!! It was not me doing that! I didn't put that information there. It looks like somehow Yahoo or Firefox retrieved that information and posted it in a list. Why?

The "remember logins for sites" checkbox does nothing. Exceptions don't work. I typed yahoo.com there and clicked on exemptions and it did nothing. I erased yahoo.com from the list below that box - and it did nothing. I uninstalled Firefox - then reinstalled a fresh copy - still the same. All bookmarks came back and the auto-fill logins are still there!

I tried to remove or turn off autocomplete from about:config - but there is no such setting in it.

Did someone hack my PC? Is this yahoo doing that?

Can this be somehow blocked?

In any case - please help me - or I will be forced to permanently erase Firefox, because I really can't have anyone see the information. It is horrible that I can't delete that. I feel that I have no control over what I can and what I cannot delete on my own computer!

But what is even more horrible - is that I cannot install fresh and clean Firefox. It remembers everything - and I wanted it to delete everything!!!

How to delete those damn logins?!

I noticed that my Yahoo mail login box auto-fills logins I don't use - or logins I don't want anyone to see. After recent Firefox update to 55.0.3 64 bit - I can't delete those entries. What I could easily do before - drop down the list and hit delete - doesn't work anymore. But what bothers me most - is that there are entries there - that appeared - that I didn't use in years!!! It was not me doing that! I didn't put that information there. It looks like somehow Yahoo or Firefox retrieved that information and posted it in a list. Why? The "remember logins for sites" checkbox does nothing. Exceptions don't work. I typed yahoo.com there and clicked on exemptions and it did nothing. I erased yahoo.com from the list below that box - and it did nothing. I uninstalled Firefox - then reinstalled a fresh copy - still the same. All bookmarks came back and the auto-fill logins are still there! I tried to remove or turn off autocomplete from about:config - but there is no such setting in it. Did someone hack my PC? Is this yahoo doing that? Can this be somehow blocked? In any case - please help me - or I will be forced to permanently erase Firefox, because I really can't have anyone see the information. It is horrible that I can't delete that. I feel that I have no control over what I can and what I cannot delete on my own computer! But what is even more horrible - is that I cannot install fresh and clean Firefox. It remembers everything - and I wanted it to delete everything!!! How to delete those damn logins?!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

More Information

FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ------------------ https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Question owner

yes. It is still there. Here is what happened. I noticed your response in my emailbox of yahoo. I closed the window without logging out. I restarted Firefox in safemode as instructed (with Shift). Firefox started without bookmarks - BUT when I typed yahoo in my address bar and found mail - it went into my mailbox directly without prompting me for a password!

So I had to log out - and then when login page appeared - I still saw all the logins I wanted to get rid off. It also added another entry - which is now my login here.

yes. It is still there. Here is what happened. I noticed your response in my emailbox of yahoo. I closed the window without logging out. I restarted Firefox in safemode as instructed (with Shift). Firefox started without bookmarks - BUT when I typed yahoo in my address bar and found mail - it went into my mailbox directly without prompting me for a password! So I had to log out - and then when login page appeared - I still saw all the logins I wanted to get rid off. It also added another entry - which is now my login here.

Question owner

I do not have Advanced SystemCare nor Surfing Protection. I only have Noscript 5.0.9 - but it never gave me any trouble.

I do not have Advanced SystemCare nor Surfing Protection. I only have Noscript 5.0.9 - but it never gave me any trouble.

Question owner

I think I should say - that the checkbox on the "remember logins for sites" can be placed and removed. But that does nothing. There is no change in behavior whatsoever.

I think I should say - that the checkbox on the "remember logins for sites" can be placed and removed. But that does nothing. There is no change in behavior whatsoever.
FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

Just to let you know, v55 has been giving users several problems. If we can't get this going, I will have you downgrade to v45.

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

Just to let you know, v55 has been giving users several problems. If we can't get this going, I will have you downgrade to v45. https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here. If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues. You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]
FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

Extra password entries; You can open the Password Manager and remove those entries.

Type about:preferences#security<enter> in the address bar.

Under Logins, Turn on Remember Logins. To check the passwords you have listed, press Saved Logins.

Extra password entries; You can open the Password Manager and remove those entries. Type '''about:preferences#security'''<enter> in the address bar. Under '''Logins, ''' Turn on '''Remember Logins. ''' To check the passwords you have listed, press '''Saved Logins. '''
FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers

andrew9 said

it went into my mailbox directly without prompting me for a password!

If you don't log out of a site, you will not be asked to login later. For low-level sites, like forums and such, it does not really matter.

High-level sites, like banks and such, that have your personal information you should always log out when you are done.

''andrew9 [[#answer-1001255|said]]'' <blockquote> it went into my mailbox directly without prompting me for a password! </blockquote> If you don't log out of a site, you will not be asked to login later. For low-level sites, like forums and such, it does not really matter. High-level sites, like banks and such, that have your personal information you should always log out when you are done.

Question owner

Thank you for all the answers - but is there a way to delete all that info manually?

I mean - how do I do a clean install - how to first uninstall the Firefox completely - so that information does not come back after reinstalling new?

I want to remove it ALL.

Not only that - I want to know HOW the browser digged out those long unused logins? I mean how can I get to the root of this problem?

I got loggin that I used 5 years ago!!!! This is creepy - the software somehow found that loggin and displays it in the autofill list. Where are those files preserved - so that the software does NOT find it again?

Thank you for all the answers - but is there a way to delete all that info manually? I mean - how do I do a clean install - how to first uninstall the Firefox completely - so that information does not come back after reinstalling new? I want to remove it ALL. Not only that - I want to know HOW the browser digged out those long unused logins? I mean how can I get to the root of this problem? I got loggin that I used 5 years ago!!!! This is creepy - the software somehow found that loggin and displays it in the autofill list. Where are those files preserved - so that the software does NOT find it again?

Modified by andrew9

FredMcD
  • Top 10 Contributor
4267 solutions 59839 answers
Use these links to create a new profile. http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible Type '''about:profiles'''<enter> in the address bar.