Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox 55.0.2 will not open links

  • 3 replies
  • 22 have this problem
  • 3075 views
  • Last reply by FredMcD

more options

firefox 55.0.2 will not open links from mail. Win 10, newest, on desktop.

Chosen solution

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

In my case, (v 55.0.3) after updating, a lot of links (not all) will open in "e". This occurs randomly. Since I refuse to use "e", except for the dumb webmeisters that force one to wonder if I delete "e" will this hurt win 10 operations.

more options

IE is part of Windows. Removing it would cause problems.

Open Windows Internet Explorer. Have it declared as the default browser, But turn off the option to check this when the browser opens (If you want).

Now do the same thing using Firefox.

Win:10:Default

https://www.bing.com/search?q=change+default+browser+windows+10&pc=MOZI&form=MOZSBR