X
Tap here to go to the mobile version of the site.

Support Forum

Firefox gets super slow after a while of using it, have to close it every x amount of time..

Posted

It really seems like some kind of memory leak... always happens, it seems related to videos/ youtube, I have currently nearly 600 tabs open, but I read on a forum a guy have 1000 tabs and it runs smooth, so something is really wrong.. I got a 6600k overclocked at 4.5ghz and 16ghb of ram@3200 so it's not the hardware, also I'm running chrome in the same time, and even when my CPU reaches nearly 100% chrome runs smooth.. I have to close it and reopen it every time it's so annoying.

Would be nice to get some help.. I also tryed to disable all extensions, still had the same problem, right now I disabled kaspersky for the browser, it's not helping, something is really wrong with firefox.. I tryed to do a refresh.. HELL.. I even tryed to reinstall it !! and still got the same problem..

At this point if I can't figure this out soon I will be using stricly chrome..but I like firefox better, and all my shortcuts and bookmarks are there also

It really seems like some kind of memory leak... always happens, it seems related to videos/ youtube, I have currently nearly 600 tabs open, but I read on a forum a guy have 1000 tabs and it runs smooth, so something is really wrong.. I got a 6600k overclocked at 4.5ghz and 16ghb of ram@3200 so it's not the hardware, also I'm running chrome in the same time, and even when my CPU reaches nearly 100% chrome runs smooth.. I have to close it and reopen it every time it's so annoying. Would be nice to get some help.. I also tryed to disable all extensions, still had the same problem, right now I disabled kaspersky for the browser, it's not helping, something is really wrong with firefox.. I tryed to do a refresh.. HELL.. I even tryed to reinstall it !! and still got the same problem.. At this point if I can't figure this out soon I will be using stricly chrome..but I like firefox better, and all my shortcuts and bookmarks are there also

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

mattcamp 42 solutions 356 answers

Helpful Reply

600 or 1600 open tabs are a little too many and would put any browser severely to the test.

16 GB aren't enough for this type of situation.

Maybe the guy who runs 1600 tabs has 32 GB, I don't think you can do it with 16 GB, regardless of the browser.

What you can do to prevent memory leaks is to override the automatic cache management by setting up a manual limit. Check screenshot for a better understanding.

600 or 1600 open tabs are a little too many and would put any browser severely to the test. 16 GB aren't enough for this type of situation. Maybe the guy who runs 1600 tabs has 32 GB, I don't think you can do it with 16 GB, regardless of the browser. What you can do to prevent memory leaks is to override the automatic cache management by setting up a manual limit. Check screenshot for a better understanding.

Modified by mattcamp

Helpful Reply

I had that way before 600, near 200-300, but I'm pretty sure with 10 tabs it happens too.. no I don't reach my memory cap, and chrome handles it just fine like I said, I reaaallly think it's firefox

Also keep in mind when I restart firefox it works fine with 600 :)

Cool I'll try that thanks

Look I even made a screenshot, as it started to lag

I had that way before 600, near 200-300, but I'm pretty sure with 10 tabs it happens too.. no I don't reach my memory cap, and chrome handles it just fine like I said, I reaaallly think it's firefox Also keep in mind when I restart firefox it works fine with 600 :) Cool I'll try that thanks Look I even made a screenshot, as it started to lag

Modified by realstrongforce

Question owner

that's it no more responses :(

that's it no more responses :(
mattcamp 42 solutions 356 answers

I don't speak French but it looks like your RAM is pretty maxed out there.

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

I don't speak French but it looks like your RAM is pretty maxed out there. Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Question owner

I did disable that already, didn't do anything, anything since I reduced the number of tabs to 350 ish I didn't had to restart it, so I suppose there is some kind of memory leak/hog when have too many tabs open with max ram usage after a while

I did disable that already, didn't do anything, anything since I reduced the number of tabs to 350 ish I didn't had to restart it, so I suppose there is some kind of memory leak/hog when have too many tabs open with max ram usage after a while
mattcamp 42 solutions 356 answers

Well, 350 tabs mean a lot of memory usage.

You need to also consider what other applications you have open, and how much RAM they use.

Well, 350 tabs mean a lot of memory usage. You need to also consider what other applications you have open, and how much RAM they use.

Question owner

Yea but the thing is, even with 650 tabs open it runs fine for a while, regardless of the amount of memory of RAM used, therefore the problem isn't related to the memory usage but to Firefox itself !

Yea but the thing is, even with 650 tabs open it runs fine for a while, regardless of the amount of memory of RAM used, therefore the problem isn't related to the memory usage but to Firefox itself !