X
Tap here to go to the mobile version of the site.

Support Forum

How to stop Firefox from superimposing search/address bar over tabs?

Posted

Earlier today my Comodo IceDragon updated itself to v52.0.0.4, after which the search bar had vanished and only appears when I place the cursor over any open tabs. This happens instantly and prevents me from accessing any tabs. I have the Classic Theme Restorer addon installed but cannot find any option that will solve this.

In desperation I opened Firefox thinking that I would at least be able to use that but it too has the same problem. How do I override this and get back to 2 different toolbars, one for tabs and one for the search/address bar please?

Earlier today my Comodo IceDragon updated itself to v52.0.0.4, after which the search bar had vanished and only appears when I place the cursor over any open tabs. This happens instantly and prevents me from accessing any tabs. I have the Classic Theme Restorer addon installed but cannot find any option that will solve this. In desperation I opened Firefox thinking that I would at least be able to use that but it too has the same problem. How do I override this and get back to 2 different toolbars, one for tabs and one for the search/address bar please?

Chosen solution

Sync between 55 and earlier versions could be a factor, but it's a bit difficult to sort out exactly what is being copied back and forth that would have this effect. Under Options > Sync it's probably a good idea to uncheck Add-ons and Preferences so those can be managed locally in the different versions.

Do you have any other extensions that affect the toolbar area?

To resolve the issue, you may need to re-customize the toolbars. Toolbar data is stored in two places, a preference that stores a list of which items are on which bars, and a dedicated file which stores size and position information, and information on which bars are displayed. Let's start with that second one.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. You can re-enable the display the menu bar and Bookmarks Toolbar, if desired, using any of these:

To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list.

Any improvement?

To reset the toolbar layout -- subject to still being modified in real time by CTR, open the Customize pane as described in Customize Firefox controls, buttons and toolbars. At the bottom of the Customize tab the "Restore Defaults" button should restore the selection of items to those you saw in the new profile. Then you can move buttons and bars around to your preferred positions.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

jscher2000
  • Top 10 Contributor
8690 solutions 71039 answers

Are you saying that your entire main toolbar is gone unless you hover your tabs, or that the search bar individually appears and disappears from your main toolbar? If you want to post a screenshot or two illustrating the problem, that might help. This article has tips on capturing screenshots: How do I create a screenshot of my problem? Please cut out or blur any sensitive data in the image before attaching it to your reply.

More generally, this is not the default behavior. Some thoughts on things to investigate:

  • Are you using full screen? The F11 key switches Firefox between full screen and normal views.
  • If you have customized the layout using Classic Theme Restorer, make sure you have the latest version that works on Firefox 52 (presumably the ESR release). Also check its settings related to the toolbars.
  • If you use custom style rules in a userChrome.css file or through an extension such as Stylish for Firefox, check any that relate to :hover states or the nav-bar.
Are you saying that your entire main toolbar is gone unless you hover your tabs, or that the search bar individually appears and disappears from your main toolbar? If you want to post a screenshot or two illustrating the problem, that might help. This article has tips on capturing screenshots: [[How do I create a screenshot of my problem?]] Please cut out or blur any sensitive data in the image before attaching it to your reply. More generally, this is not the default behavior. Some thoughts on things to investigate: * Are you using full screen? The F11 key switches Firefox between full screen and normal views. * If you have customized the layout using Classic Theme Restorer, make sure you have the latest version that works on Firefox 52 (presumably the ESR release). Also check its settings related to the toolbars. * If you use custom style rules in a userChrome.css file or through an extension such as Stylish for Firefox, check any that relate to :hover states or the nav-bar.

Question owner

Update: the problem appears to be the Classic Theme Restorer addon because disabling it partially solved the problem. However, I say partially as it appears the address bar auto-hides now and only reappears when I mouse over the tabs. While that may appeal to some people I personally don't want that happening and would like to return to the original version of having both tabs and search/address bar visible at the same time.

Perhaps someone can tell me how to achieve that please?

Update: the problem appears to be the Classic Theme Restorer addon because disabling it partially solved the problem. However, I say partially as it appears the address bar auto-hides now and only reappears when I mouse over the tabs. While that may appeal to some people I personally don't want that happening and would like to return to the original version of having both tabs and search/address bar visible at the same time. Perhaps someone can tell me how to achieve that please?

Question owner

jscher2000 said

Are you saying that your entire main toolbar is gone unless you hover your tabs, or that the search bar individually appears and disappears from your main toolbar? If you want to post a screenshot or two illustrating the problem, that might help. This article has tips on capturing screenshots: How do I create a screenshot of my problem? Please cut out or blur any sensitive data in the image before attaching it to your reply. More generally, this is not the default behavior. Some thoughts on things to investigate:
  • Are you using full screen? The F11 key switches Firefox between full screen and normal views.
  • If you have customized the layout using Classic Theme Restorer, make sure you have the latest version that works on Firefox 52 (presumably the ESR release). Also check its settings related to the toolbars.
  • If you use custom style rules in a userChrome.css file or through an extension such as Stylish for Firefox, check any that relate to :hover states or the nav-bar.

I'm not using full screen and have checked I'm using the latest version of Classic Theme Restorer. I also have Stephane Rosselli's FT Deep Dark skin installed so it may be that as no updates are showing as available for it.

Anyway, I enabled Classic Theme Restorer again to take the screenshots you requested. One shows tabs without address/search bar while the other shows what happens when I mouse over any tab, address/search bar with no access to tabs.

I do not use any custom css as I haven't a clue how it works.

''jscher2000 [[#answer-996831|said]]'' <blockquote> Are you saying that your entire main toolbar is gone unless you hover your tabs, or that the search bar individually appears and disappears from your main toolbar? If you want to post a screenshot or two illustrating the problem, that might help. This article has tips on capturing screenshots: [[How do I create a screenshot of my problem?]] Please cut out or blur any sensitive data in the image before attaching it to your reply. More generally, this is not the default behavior. Some thoughts on things to investigate: * Are you using full screen? The F11 key switches Firefox between full screen and normal views. * If you have customized the layout using Classic Theme Restorer, make sure you have the latest version that works on Firefox 52 (presumably the ESR release). Also check its settings related to the toolbars. * If you use custom style rules in a userChrome.css file or through an extension such as Stylish for Firefox, check any that relate to :hover states or the nav-bar. </blockquote> I'm not using full screen and have checked I'm using the latest version of Classic Theme Restorer. I also have Stephane Rosselli's FT Deep Dark skin installed so it may be that as no updates are showing as available for it. Anyway, I enabled Classic Theme Restorer again to take the screenshots you requested. One shows tabs without address/search bar while the other shows what happens when I mouse over any tab, address/search bar with no access to tabs. I do not use any custom css as I haven't a clue how it works.
jscher2000
  • Top 10 Contributor
8690 solutions 71039 answers

Okay, this is hard to understand. Are the tabs on the main toolbar, or are the contents of the main toolbar injected into the Tabs bar?? How did it work before?

Could you put on some sunglasses and switch to the default theme to see whether that resolves the issue? If it doesn't resolve the issue, then FT Deep Dark is probably blameless and you can explore whether something in CTR has gone haywire.

Okay, this is hard to understand. Are the tabs on the main toolbar, or are the contents of the main toolbar injected into the Tabs bar?? How did it work before? Could you put on some sunglasses and switch to the default theme to see whether that resolves the issue? If it doesn't resolve the issue, then FT Deep Dark is probably blameless and you can explore whether something in CTR has gone haywire.

Question owner

It's not FT Deep Dark. With CTR disabled I get both displayed when I mouseover the main toolbar, which is where the tabs are located. The same thing happens in default mode so it seems to me that CTR is the problem.

Nevertheless, I do not like this hidden address bar and would like to be able to turn off that option in about:config. Do you know how I can do that please jscher2000?

It's not FT Deep Dark. With CTR disabled I get both displayed when I mouseover the main toolbar, which is where the tabs are located. The same thing happens in default mode so it seems to me that CTR is the problem. Nevertheless, I do not like this hidden address bar and would like to be able to turn off that option in about:config. Do you know how I can do that please jscher2000?
jscher2000
  • Top 10 Contributor
8690 solutions 71039 answers

I'm not aware of any Firefox setting that can display or hide the main toolbar or the tab bar when you hover/mouseover them. Is it a CTR setting?

I'm not aware of any Firefox setting that can display or hide the main toolbar or the tab bar when you hover/mouseover them. Is it a CTR setting?

Question owner

No. Like I said in my original post, I searched throughout the addon for an option to return that to normal. But it's not the tab bar that's being hidden, it's the address bar which only appears when you mouseover the tab bar.

I also have a new laptop with Win 10 and a default Firefox install (no addons yet). That also displays this new auto-hidden address bar so it must be something that was introduced to FF recently. I really want to disable that functionality because, while I appreciate it gives access to more desktop real estate, I prefer having access to both the tabs and address bar by default.

No. Like I said in my original post, I searched throughout the addon for an option to return that to normal. But it's not the tab bar that's being hidden, it's the address bar which only appears when you mouseover the tab bar. I also have a new laptop with Win 10 and a default Firefox install (no addons yet). That also displays this new auto-hidden address bar so it must be something that was introduced to FF recently. I really want to disable that functionality because, while I appreciate it gives access to more desktop real estate, I prefer having access to both the tabs and address bar by default.
jscher2000
  • Top 10 Contributor
8690 solutions 71039 answers

As a test, I did the following, and I did not see any automatic hiding (64-bit Windows 7, 32-bit Firefox). (I did not connect to my Sync account to avoid picking up any customizations from my current profile.)

New Profile Test

This takes about 3 minutes, plus the time to open a few pages.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like TEST, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but I think those are still "under construction" so please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new.

Do you get automatic hiding of the main toolbar?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

As a test, I did the following, and I did not see any automatic hiding (64-bit Windows 7, 32-bit Firefox). (I did not connect to my Sync account to avoid picking up any customizations from my current profile.) '''New Profile Test''' This takes about 3 minutes, plus the time to open a few pages. Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Click the Create a New Profile button, then click Next. Assign a name like TEST, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Set as default profile''' button below that profile, then scroll back up and click the '''Restart normally''' button. (There are some other buttons, but I think those are still "under construction" so please ignore them.) Firefox should exit and then start up using the new profile, which will just look brand new. ''Do you get automatic hiding of the main toolbar?'' When you are done with the experiment, open the about:profiles page again, click the '''Set as default profile''' button for your normal profile, then click the '''Restart normally''' button to get back to it.

Question owner

Indeed, the main toolbar was visible and the address/search bar was directly underneath. This suggests that one or more of my addons have corrupted Firefox or it is the result of a malware infection somewhere.

I don't want to lose all the data from my existing profile so what are my options in this case?

Incidentally, whilst I thought that disabling CTR was the solution I did not notice that the search bar had vanished. I only have the address bar now. When starting-up I can see both the address bar and search bar but as soon as the address bar goes into hiding the search bar is lost completely.

Oh, and another thing that may be relevant: In my initial post I said that this happened once IceDragon updated to v52.0.0.4 however, that was incorrect as it has been that version for at least 2 or 3 months now. In fact what really happened is that I signed into Sync yesterday and immediately did the same with my new Win 10 based laptop. The latter has a bare roots version of Firefox v55.0.1 on it while this machine has Win 7 with IceDragon v52.0.0.4. Some of the addons on this machine are not compatible with v55.0.1 so I'm wondering whether syncing the 2 is the cause of all my woes?

Indeed, the main toolbar was visible and the address/search bar was directly underneath. This suggests that one or more of my addons have corrupted Firefox or it is the result of a malware infection somewhere. I don't want to lose all the data from my existing profile so what are my options in this case? Incidentally, whilst I thought that disabling CTR was the solution I did not notice that the search bar had vanished. I only have the address bar now. When starting-up I can see both the address bar and search bar but as soon as the address bar goes into hiding the search bar is lost completely. Oh, and another thing that may be relevant: In my initial post I said that this happened once IceDragon updated to v52.0.0.4 however, that was incorrect as it has been that version for at least 2 or 3 months now. In fact what really happened is that I signed into Sync yesterday and immediately did the same with my new Win 10 based laptop. The latter has a bare roots version of Firefox v55.0.1 on it while this machine has Win 7 with IceDragon v52.0.0.4. Some of the addons on this machine are not compatible with v55.0.1 so I'm wondering whether syncing the 2 is the cause of all my woes?
jscher2000
  • Top 10 Contributor
8690 solutions 71039 answers

Chosen Solution

Sync between 55 and earlier versions could be a factor, but it's a bit difficult to sort out exactly what is being copied back and forth that would have this effect. Under Options > Sync it's probably a good idea to uncheck Add-ons and Preferences so those can be managed locally in the different versions.

Do you have any other extensions that affect the toolbar area?

To resolve the issue, you may need to re-customize the toolbars. Toolbar data is stored in two places, a preference that stores a list of which items are on which bars, and a dedicated file which stores size and position information, and information on which bars are displayed. Let's start with that second one.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. You can re-enable the display the menu bar and Bookmarks Toolbar, if desired, using any of these:

To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list.

Any improvement?

To reset the toolbar layout -- subject to still being modified in real time by CTR, open the Customize pane as described in Customize Firefox controls, buttons and toolbars. At the bottom of the Customize tab the "Restore Defaults" button should restore the selection of items to those you saw in the new profile. Then you can move buttons and bars around to your preferred positions.

Sync between 55 and earlier versions could be a factor, but it's a bit difficult to sort out exactly what is being copied back and forth that would have this effect. Under Options > Sync it's probably a good idea to uncheck Add-ons and Preferences so those can be managed locally in the different versions. Do you have any other extensions that affect the toolbar area? To resolve the issue, you may need to re-customize the toolbars. Toolbar data is stored in two places, a preference that stores a list of which items are on which bars, and a dedicated file which stores size and position information, and information on which bars are displayed. Let's start with that second one. Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''xulstore.json''' to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old. Start Firefox back up again. You can re-enable the display the menu bar and Bookmarks Toolbar, if desired, using any of these: * right-click a blank spot on the tab bar (or the "+" button) * tap the Alt key to activate the classic menu bar > View > Toolbars * in Customize mode > Show/Hide Toolbars (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list. ''Any improvement?'' To reset the toolbar layout -- subject to still being modified in real time by CTR, open the Customize pane as described in [[Customize Firefox controls, buttons and toolbars]]. At the bottom of the Customize tab the "Restore Defaults" button should restore the selection of items to those you saw in the new profile. Then you can move buttons and bars around to your preferred positions.

Helpful Reply

Here's a list of the other addons I have which may or may not be affecting the toolbars:

Add to Search Bar Beyond Australis Classic Toolbar Buttons Download Status Bar S3.Google Translator The Addon Bar (restored) Thumbnail Zoom Plus

So I tried everything you suggested and the problem remained so I picked on the 2 other most obvious addons being CTB and Beyond Australis. Disabling CTB made no difference but BA corrected the problem. Then, out of curiosity, I re-enabled CTR and the 2 toolbars remained so it looks like it was Beyond Australis all along.

Thank you very much for all your assistance jscher2000. Should I change xulstore and localstore back to their original filenames now?

Here's a list of the other addons I have which may or may not be affecting the toolbars: Add to Search Bar Beyond Australis Classic Toolbar Buttons Download Status Bar S3.Google Translator The Addon Bar (restored) Thumbnail Zoom Plus So I tried everything you suggested and the problem remained so I picked on the 2 other most obvious addons being CTB and Beyond Australis. Disabling CTB made no difference but BA corrected the problem. Then, out of curiosity, I re-enabled CTR and the 2 toolbars remained so it looks like it was Beyond Australis all along. Thank you very much for all your assistance jscher2000. Should I change xulstore and localstore back to their original filenames now?
jscher2000
  • Top 10 Contributor
8690 solutions 71039 answers

Helpful Reply

7leagues said

Disabling CTB made no difference but BA corrected the problem. Then, out of curiosity, I re-enabled CTR and the 2 toolbars remained so it looks like it was Beyond Australis all along.

Thanks for reporting back on that.

Should I change xulstore and localstore back to their original filenames now?

If thinks are working okay now, then no, I would continue working with the new files and leave the old ones behind.

''7leagues [[#answer-997099|said]]'' <blockquote> Disabling CTB made no difference but BA corrected the problem. Then, out of curiosity, I re-enabled CTR and the 2 toolbars remained so it looks like it was Beyond Australis all along. </blockquote> Thanks for reporting back on that. <blockquote>Should I change xulstore and localstore back to their original filenames now?</blockquote> If thinks are working okay now, then no, I would continue working with the new files and leave the old ones behind.

Question owner

Thanks very much jscher2000. Have a great day!

Thanks very much jscher2000. Have a great day!