Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

all my received messages disappeared

more options

suddenly only some of the most recent received messages are shown in the inbox

All Replies (5)

more options

Hi, is this problem on a webmail site that you're viewing in a Firefox tab or in the separate, stand-alone Thunderbird email program? Just in case your question ended up on the wrong board. (A moderator/admin can move it if needed.)

If this problem is in Firefox, have you tried "the usual"? If a site is generally known to work in Firefox, these are general suggestions to try when it stops working correctly:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

more options

jscher2000 said

Hi, is this problem on a webmail site that you're viewing in a Firefox tab or in the separate, stand-alone Thunderbird email program? Just in case your question ended up on the wrong board. (A moderator/admin can move it if needed.) If this problem is in Firefox, have you tried "the usual"? If a site is generally known to work in Firefox, these are general suggestions to try when it stops working correctly: Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: How to clear the Firefox cache If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:
  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button
In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually. Then try reloading the page. Does that help? Testing in Firefox's Safe Mode: In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. If Firefox is not running: Hold down the Shift key when starting Firefox. If Firefox is running: You can restart Firefox in Safe Mode using either:
  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled
and OK the restart. Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh). Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)
more options

My problem is with Thunderbird. What do you suggest?

more options

Chosen Solution

more options

juergendstens said

suddenly only some of the most recent received messages are shown in the inbox

I want to express my thanks for responding to y cry for help and offering suggestions to remedy the problem. My grandson, who initially set up Thunderbird recovered my email messages from the "TRASH" folder, without determining how they got there. I am indebted to all for their concern. Thank you again. It is time for me to le/arn more about Thunderbird to get to profiicint. Juergen 8/15/2017