X
Tap here to go to the mobile version of the site.

Support Forum

address bar switches position with bookmark bar

Posted

Question line is the issue. Toolbars are formatted, top to bottom, as - Menu Bar /Bookmark Bar with 'Multirow Plus' / Tabs. The menu and bookmark bars switch positions periodically. If I go to to Menu/customize and immediately click Exit, the tool bars go back to formatted look.

Win 7 ver. 54.0.1 (64-bit)

Question line is the issue. Toolbars are formatted, top to bottom, as - Menu Bar /Bookmark Bar with 'Multirow Plus' / Tabs. The menu and bookmark bars switch positions periodically. If I go to to Menu/customize and immediately click Exit, the tool bars go back to formatted look. Win 7 ver. 54.0.1 (64-bit)

Chosen solution

Note that you should remove extension that adds this tabs on bottom feature or at least disable this feature in your extensions to prevent interference.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
15586 solutions 141085 answers

Helpful Reply

This is likely a problem with the extension that places the Tab bar on bottom that n't working properly.

I use code in userChrome.css to place the tabs on bottom.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* tabs on bottom */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10}
#TabsToolbar {-moz-box-ordinal-group:1000!important}

  • create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userChrome.css file in the editor window
  • make sure that the userChrome.css file starts with the default @namespace line
  • make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

This is likely a problem with the extension that places the Tab bar on bottom that n't working properly. I use code in userChrome.css to place the tabs on bottom. Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* tabs on bottom */ #navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10} #TabsToolbar {-moz-box-ordinal-group:1000!important} </nowiki></pre> <hr> *create the <b>chrome</b> folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *use a plain text editor like Notepad to create a (new) <b>userChrome.css</b> file in the chrome folder (file name is case sensitive) *paste the code in the userChrome.css file in the editor window *make sure that the userChrome.css file starts with the default <u>@namespace line</u> *make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.<br>otherwise Windows may add a hidden <i>.txt</i> file extension and you end up with a not working <i>userChrome.css.txt</i> file You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Was this helpful to you? 2
Quote

Question owner

Thanks. Beautifully presented. I'm not usually so dense, however after creating new folder in Profile... Questions: 1. I'm to open Notepad and create new css? Is that the scripting above /* tabs on bottom */....? 2. Then I paste (without saving) the text in Notepad into where? I don't know of a userChrome.css FILE or the editor window. 3. What is the @namespace line?

My apology in advance. I think it's me, not your instructions.

Thanks. Beautifully presented. I'm not usually so dense, however after creating new folder in Profile... Questions: 1. I'm to open Notepad and create new css? Is that the scripting above /* tabs on bottom */....? 2. Then I paste (without saving) the text in Notepad into where? I don't know of a userChrome.css FILE or the editor window. 3. What is the @namespace line? My apology in advance. I think it's me, not your instructions.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15586 solutions 141085 answers

Helpful Reply

You need to create the chrome folder in the profile folder if this folder isn't there.

  • Help -> Troubleshooting Information -> Profile Directory: Show Folder

Then you need to create a plain text file with the name userChrome.css in this folder. Paste the full content I posted above between the horizontal separators in this file including the @namespace line.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once in userChrome.css */

/* tabs on bottom */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {
 -moz-box-ordinal-group:10 !important;
}
#TabsToolbar {
 -moz-box-ordinal-group:1000 !important;
}
You need to create the chrome folder in the profile folder if this folder isn't there. *Help -> Troubleshooting Information -> Profile Directory: Show Folder Then you need to create a plain text file with the name userChrome.css in this folder. Paste the full content I posted above between the horizontal separators in this file including the @namespace line. <pre><nowiki> @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once in userChrome.css */ /* tabs on bottom */ #navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) { -moz-box-ordinal-group:10 !important; } #TabsToolbar { -moz-box-ordinal-group:1000 !important; } </nowiki></pre>
Was this helpful to you? 1
Quote

Question owner

Done. I'll watch to see if that does the job. Thanks.

Done. I'll watch to see if that does the job. Thanks.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15586 solutions 141085 answers

Chosen Solution

Note that you should remove extension that adds this tabs on bottom feature or at least disable this feature in your extensions to prevent interference.

Note that you should remove extension that adds this tabs on bottom feature or at least disable this feature in your extensions to prevent interference.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.