Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't load my new website - while other browsers do

  • 5 replies
  • 1 has this problem
  • 396 views
  • Last reply by jscher2000

more options

Hi,

I have uploaded a new version of my website, and though I can access it with other browsers (Internet Explorer, Chrome, Opera), Firefox will only load the old "under construction" picture and not my new site. I have tried clearing the cache, to no effect.

I have tried access the site from link, and get the construction picture - it's ONLY Firefox that does this...!!

Please advise. Thanks.

Chosen solution

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
Read this answer in context 👍 0

All Replies (5)

more options

Please provide public (no password) link(s) that we can check out. No Personal Information Please !

more options
more options

“The main thing is to keep the main thing the main thing.” S. Covey

Interesting thought.

I had no problem with the link.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Then restart. Poke around safe websites. Are there any problems?

more options

Chosen Solution

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
more options

One way to assess whether this is a cache problem is to open the site in a private window (private windows do not re-use cached files from regular windows or previous sessions). You can right-click the link in your earlier reply, or another link to the site, or a bookmark, and choose Open in New Private Window.