X
Tap here to go to the mobile version of the site.

Support Forum

Why is Firefox 54.0.1 (64-bit) hogging CPU?

Posted

I'm running El Capitan on a Mid 2010 Macbook Pro with 4 GB memory and 240 GB free storage. I just did a clean install (factory reset) of El Capitan. I then downloaded Firefox. When I open just one tab at a typical blog website or a news site, Firefox and Firefox Web Content use 89% and 46% CPU respectively. If I check Energy Impact in Activity Monitor, it's about 150. If I run Netflix, the energy impact varies between 55% and 70%. My computer also gets very hot. I can't open more than one tab without my computer overheating. This did not happen before with the old Firefox version.

I went through all of the steps that Mozilla recommends on the Troubleshooting page when I first upgraded to El Capitan. I've checked all Plug Ins and Extensions in Safe Mode, I reset Firefox, I tried it with a new profile, I reinstalled it, etc. I thought there must have been something wrong with my computer, so I then did the clean install (factory reset) of El Capitan and Firefox. The problem persists with the new install.

Yes, using the option to cut out all ads, etc. (reader view) helps, but this option is not available on all websites (MSN main page, Instagram, Twitter). Plus, using reader view all the time like that means needing to click twice instead of once when moving back to the previous page, so I don't believe this a long term solution, especially considering that I had not problems in the past.

Please advise!

I'm running El Capitan on a Mid 2010 Macbook Pro with 4 GB memory and 240 GB free storage. I just did a clean install (factory reset) of El Capitan. I then downloaded Firefox. When I open just one tab at a typical blog website or a news site, Firefox and Firefox Web Content use 89% and 46% CPU respectively. If I check Energy Impact in Activity Monitor, it's about 150. If I run Netflix, the energy impact varies between 55% and 70%. My computer also gets very hot. I can't open more than one tab without my computer overheating. This did not happen before with the old Firefox version. I went through all of the steps that Mozilla recommends on the Troubleshooting page when I first upgraded to El Capitan. I've checked all Plug Ins and Extensions in Safe Mode, I reset Firefox, I tried it with a new profile, I reinstalled it, etc. I thought there must have been something wrong with my computer, so I then did the clean install (factory reset) of El Capitan and Firefox. The problem persists with the new install. Yes, using the option to cut out all ads, etc. (reader view) helps, but this option is not available on all websites (MSN main page, Instagram, Twitter). Plus, using reader view all the time like that means needing to click twice instead of once when moving back to the previous page, so I don't believe this a long term solution, especially considering that I had not problems in the past. Please advise!
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

Pkshadow
  • Top 10 Contributor
263 solutions 2871 answers

You could try this : https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix Check this out : https://addons.mozilla.org/en-US/firefox/addon/fat-free-firefox/

Only 4 Gigs of ram is the main issue. You are trying to do to much with too little as is 7 years out of date. Would probably be best to run 32 bit version as it uses less resources. Suggest to google how to tweak up what you have to run better.

Can try to increase your Swap File | Do not know Mac check links from below url for how to https://www.google.ca/search?q=increase+swap+file+Mac+OS&ie=utf-8&oe=utf-8&gws_rd=cr&ei=fJptWc3oKcHEjwOQtLDwCQ

Please let us know if this solved your issue or if need further assistance.

You could try this : https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix Check this out : https://addons.mozilla.org/en-US/firefox/addon/fat-free-firefox/ Only 4 Gigs of ram is the main issue. You are trying to do to much with too little as is 7 years out of date. Would probably be best to run 32 bit version as it uses less resources. Suggest to google how to tweak up what you have to run better. Can try to increase your Swap File | Do not know Mac check links from below url for how to https://www.google.ca/search?q=increase+swap+file+Mac+OS&ie=utf-8&oe=utf-8&gws_rd=cr&ei=fJptWc3oKcHEjwOQtLDwCQ Please let us know if this solved your issue or if need further assistance.

Modified by Pkshadow

Was this helpful to you? 0
Quote

Question owner

Hello,

Thank you for your reply. I mentioned in my original post that I have tried all of the suggestions you are recommending in your first two links. The problem persists in safe mode, etc., etc. My computer has been completely wiped with a new install of both El Capitan and Firefox 54.0.1

The requirements to run Firefox are the following:

   Macintosh computer with an Intel x86 processor
   512 MB of RAM
   200 MB hard drive 

I have all of these requirements (and then some): 4 GB of RAM and 240 GB of disk space, so I'm not sure how 4GB of RAM is the problem. My system is not out of date. It is 7 years old, but it is running the second most recent OSX and it has all of the requirements to do so.

In any case, I tried to follow your instructions about running Firefox in 32 bit mode. I searched for half an hour and could not find instructions on how to do this. The only instructions I found DO NOT apply to my computer (clicking "Open in 32 Bit Mode" in the Firefox Info window). This option does not exist on my system.

Please provide instructions for running Firefox 54.0.1 in 32 bit mode. Please provide instructions that are applicable to my situation.

Thank you.

Hello, Thank you for your reply. I mentioned in my original post that I have tried all of the suggestions you are recommending in your first two links. The problem persists in safe mode, etc., etc. My computer has been completely wiped with a new install of both El Capitan and Firefox 54.0.1 The requirements to run Firefox are the following: Macintosh computer with an Intel x86 processor 512 MB of RAM 200 MB hard drive I have all of these requirements (and then some): 4 GB of RAM and 240 GB of disk space, so I'm not sure how 4GB of RAM is the problem. My system is not out of date. It is 7 years old, but it is running the second most recent OSX and it has all of the requirements to do so. In any case, I tried to follow your instructions about running Firefox in 32 bit mode. I searched for half an hour and could not find instructions on how to do this. The only instructions I found DO NOT apply to my computer (clicking "Open in 32 Bit Mode" in the Firefox Info window). This option does not exist on my system. Please provide instructions for running Firefox 54.0.1 in 32 bit mode. Please provide instructions that are applicable to my situation. Thank you.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15592 solutions 141164 answers

On Mac you only have the 64 bit Firefox version, so you can skip that.

You can try to disable hardware acceleration in Firefox.

  • Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.


When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect.

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

On Mac you only have the 64 bit Firefox version, so you can skip that. You can try to disable hardware acceleration in Firefox. *Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems ---- When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect. You can disable multi-process windows in Firefox by setting these prefs to false on the <b>about:config</b> page. *browser.tabs.remote.autostart = false *browser.tabs.remote.autostart.2 = false You can open the <b>about:config</b> page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config *http://www.ghacks.net/2016/07/22/multi-process-firefox/
Was this helpful to you?
Quote

Question owner

Hello Cor-El,

Thank you for your reply. Your instructions certainly improved the situation, but the CPU is still running between 30% and 60% for Youtube, Instagram, and picture heavy websites (even some text heavy websites as well). This is much better than the previous 150% or so. Also, Firefox Web Content is gone from activity monitor after your fix, which was hogging more CPU than just Firefox.

Are there any other things I can do to keep improving the situation? I really want to keep FF; I've been using it for over 10 years and don't want to switch now.

Hello Cor-El, Thank you for your reply. Your instructions certainly improved the situation, but the CPU is still running between 30% and 60% for Youtube, Instagram, and picture heavy websites (even some text heavy websites as well). This is much better than the previous 150% or so. Also, Firefox Web Content is gone from activity monitor after your fix, which was hogging more CPU than just Firefox. Are there any other things I can do to keep improving the situation? I really want to keep FF; I've been using it for over 10 years and don't want to switch now.
Was this helpful to you?
Quote
Pkshadow
  • Top 10 Contributor
263 solutions 2871 answers

Seems like still the issue for you in after Cor-el's help. Glad it is toned down a little. You can go over these, am sure you have checked but : https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://www.mozilla.org/en-US/plugincheck/

Adjust plugin behavior. Once all of your plugins are up to date, testing them is pretty easy:
   Visit the Plugins tab of the Add-Ons manager.
   Click each drop-down menu that says "Always Activate" and set it to "Ask to Activate" instead.
   Browse as usual. You will see a small popup every time a plugin asks to be activated. If you say "Yes" and your CPU usage rises, that plugin is the problem.
   When the problem is identified, look for alternative plugins for the same format. If there are none, leave that plugin in "Ask to Activate" mode.

Please keep a note of the pages that are acting up on you. Are these pages heavily loaded with scripts, video that auto plays or loops, heavy with url's as maybe do not want Firefox to read ahead and turn off tab previews if on. Limit the amount of installed search engines as they do update.

Please let us know if this solved your issue or if need further assistance.

Seems like still the issue for you in after Cor-el's help. Glad it is toned down a little. You can go over these, am sure you have checked but : https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://www.mozilla.org/en-US/plugincheck/ Adjust plugin behavior. Once all of your plugins are up to date, testing them is pretty easy: Visit the Plugins tab of the Add-Ons manager. Click each drop-down menu that says "Always Activate" and set it to "Ask to Activate" instead. Browse as usual. You will see a small popup every time a plugin asks to be activated. If you say "Yes" and your CPU usage rises, that plugin is the problem. When the problem is identified, look for alternative plugins for the same format. If there are none, leave that plugin in "Ask to Activate" mode. Please keep a note of the pages that are acting up on you. Are these pages heavily loaded with scripts, video that auto plays or loops, heavy with url's as maybe do not want Firefox to read ahead and turn off tab previews if on. Limit the amount of installed search engines as they do update. Please let us know if this solved your issue or if need further assistance.
Was this helpful to you? 0
Quote

Helpful Reply

Hello,

As mentioned, I have a clean install of Firefox 54.0.1. There are no plug ins or extensions installed except for the ones that come with Firefox. Regardless, I have checked in safe mode and the problem is exactly the same.

I have also noted the pages that cause problems: MSN, Youtube, Instagram, Twitter if playing video content or scrolling.

I have only one search engine: Google.

I was wrong about Firefox Web Content: it does come back here and there, but it does not use large amounts of CPU any longer. If it does, it is only for a few seconds.

Please recommend a solution as I would like to upload my old bookmarks and get back to being able to use the internet.

Hello, As mentioned, I have a clean install of Firefox 54.0.1. There are no plug ins or extensions installed except for the ones that come with Firefox. Regardless, I have checked in safe mode and the problem is exactly the same. I have also noted the pages that cause problems: MSN, Youtube, Instagram, Twitter if playing video content or scrolling. I have only one search engine: Google. I was wrong about Firefox Web Content: it does come back here and there, but it does not use large amounts of CPU any longer. If it does, it is only for a few seconds. Please recommend a solution as I would like to upload my old bookmarks and get back to being able to use the internet.
Was this helpful to you? 1
Quote

Question owner

Could someone please respond with a solution to this problem? I checked the exact same websites as mentioned above with Safari. Safari uses between 7% and 9% CPU on YouTube while Firefox is still using between 40% and 60%. On Twitter, Safari (and the website address itself) uses between 10% and 25% while scrolling and watching videos. Firefox, on Twitter, uses between 90% and 120% while watching videos (averaging about 90%), and between 30% and 60% when simply scrolling (averaging about 50%).

My computer gets hot while using Firefox but stays cool while using Safari.

This is clearly an issue with Firefox and not the age of my computer, the size of my RAM or memory, and my plugins or extensions, and so on.

I would appreciate a response and a solution. Thank you.

Could someone please respond with a solution to this problem? I checked the exact same websites as mentioned above with Safari. Safari uses between 7% and 9% CPU on YouTube while Firefox is still using between 40% and 60%. On Twitter, Safari (and the website address itself) uses between 10% and 25% while scrolling and watching videos. Firefox, on Twitter, uses between 90% and 120% while watching videos (averaging about 90%), and between 30% and 60% when simply scrolling (averaging about 50%). My computer gets hot while using Firefox but stays cool while using Safari. This is clearly an issue with Firefox and not the age of my computer, the size of my RAM or memory, and my plugins or extensions, and so on. I would appreciate a response and a solution. Thank you.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.