X
Tap here to go to the mobile version of the site.

Support Forum

How do I get Firefox to switch to English on thliday Inn website? I am in Mexico, but my language is English. My interface is in English-website content isnt

Posted

When I go to the Holiday Inn website, the interface is in English but the web content is in Spanish. I live in Mexico, but my language is English. At the top of the page, there is an option to switch to English, but when I click on it, nothing happens. I need help :(

When I go to the Holiday Inn website, the interface is in English but the web content is in Spanish. I live in Mexico, but my language is English. At the top of the page, there is an option to switch to English, but when I click on it, nothing happens. I need help :(

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

jscher2000
  • Top 10 Contributor
6902 solutions 56368 answers

Some sites are going to be a problem because they very stubbornly cling to the most logical language for your current IP address. Others may have a better mechanism for overriding that.

For the hotel's own website, assuming you are staying there, I would ask them what their trick is.

If you use any add-ons that block page content (e.g., ad blocker, tracking blocker, script blocker...), try making an exception to ensure that those add-ons are not creating this problem.


Generally speaking, the most reliable workaround is to use a VPN that sends your requests through a router in the U.S. That may be difficult to set up when you are having browser challenges, but for future reference:

The Best VPN Services of 2017 | PCMag.com

Some sites are going to be a problem because they very stubbornly cling to the most logical language for your current IP address. Others may have a better mechanism for overriding that. For the hotel's own website, assuming you are staying there, I would ask them what their trick is. If you use any add-ons that block page content (e.g., ad blocker, tracking blocker, script blocker...), try making an exception to ensure that those add-ons are not creating this problem. ---- Generally speaking, the most reliable workaround is to use a VPN that sends your requests through a router in the U.S. That may be difficult to set up when you are having browser challenges, but for future reference: [http://www.pcmag.com/article2/0,2817,2403388,00.asp The Best VPN Services of 2017 | PCMag.com]
cor-el
  • Top 10 Contributor
  • Moderator
15846 solutions 143330 answers

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache": *Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now" "Remove the cookies" from websites that cause problems. *Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies" Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

I was very well written and easy to follow, but I still cannot get to the English language (:

I was very well written and easy to follow, but I still cannot get to the English language (:
cor-el
  • Top 10 Contributor
  • Moderator
15846 solutions 143330 answers

Chosen Solution

Does this link work? *https://www.ihg.com/holidayinn/hotels/us/en/reservation

Question owner

You are my hero!!

You are my hero!!